• Andreas Beckmann's avatar
    debian: Add Conflicts against obsolete packages using install-info in their prerm · b89a125d
    Andreas Beckmann authored
    These packages have been removed after they were released with lenny
    or squeeze, but they may survive dist-upgrades to wheezy and jessie.
    
    Since their prerm uses install-info they cannot be removed any longer
    after installing dpkg 1.17.x and there is no upgrade path to a fixed
    package version. So use Conflicts, because these packages need to be
    removed (with their prerm) before a dpkg that would disallow to
    subsequently remove them is upgraded. Breaks would only at most
    request to deconfigure them.
    
    All Conflicts have the form PACKAGE (<< VERSION). If the source package
    still exists, the VERSION that dropped the problematic PACKAGE was used.
    Otherwise the next possible maintainer upload VERSION that could
    reintroduce PACKAGE into sid was used.
    
    [guillem@debian.org:
     - Replace Breaks with Conflicts.
     - Update lintian-overrides. ]
    
    Closes: #735159
    Signed-off-by: Guillem Jover's avatarGuillem Jover <guillem@debian.org>
    b89a125d
dpkg.lintian-overrides 282 Bytes