Commit 2bd0da6e authored by Carlos Maddela's avatar Carlos Maddela

Release version 0.3.10

parent d6f97fd1
ruby-debian (0.3.10) unstable; urgency=medium
[ Cédric Boutillier ]
* Remove version in the gem2deb build-dependency.
[ Antonio Terceiro ]
* Remove myself from uploaders.
[ Carlos Maddela ]
* Build with Debhelper compat level 12.
* Fix formatting and remove trailing spaces from debian/changelog.
* Update VCS details.
* Update debian/copyright.
* Fix spelling error in dpkg-ruby man page.
* Suppress uses-dpkg-database-directly Lintian warning.
* Mark ruby-debian package Multi-Arch: same.
* Build as verbosely as possible, unless terse build option set.
* Re-implement gnu_build_architecture() using dpkg-architecture.
dpkg's --print-gnu-build-architecture option was removed in version
1.13.1.
* Set Rules-Requires-Root: no.
* Declare compliance with Debian Policy 4.3.0.
* Add myself to uploaders list and remove Ryan Niebur. (Closes: #856365)
* Re-run wrap-and-sort.
* Add support for xz, lzma and bzip2 compressed debs. (Closes: #718389)
* Ignore :any after package names when checking dependencies.
* Include unpurged conf files in Debian::Dpkg.listfiles results.
(Closes: #681988)
* Fix errors during argument parsing in dpkg-checkdeps.
* Improve handling of non-UTF8 package info.
Instead of just giving up when non-UTF8 package info is found, try
to convert it to UTF8 first, and then skip the current package if
this fails. (Closes: #773485)
[ James Lu ]
* Call 'dpkg --print-architecture' instead of
'dpkg --print-installation-architecture'. (Closes: #854522)
[ Sam Morris ]
* Fix warnings generated by lib/debian.rb. (Closes: #889651)
-- Carlos Maddela <e7appew@gmail.com> Fri, 22 Feb 2019 15:12:04 +1100
ruby-debian (0.3.9) unstable; urgency=medium
* Move maintenance into the Ruby team; make the team the maintainer, and
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment