Commit 17e7ba3f authored by Dirk Eddelbuettel's avatar Dirk Eddelbuettel

Import Debian changes 2.2.1-6

r-base (2.2.1-6) unstable; urgency=medium

  * debian/r-base-core.preinst: The symbolic link /usr/lib/R/share 
    introduced in -4 prevents the directory added in -5 to be created
    so remove if found in the preinst.

  * Urgency still set up to medium so that testing and unstable users get 
    the fix quickly. 
parent 6fa31613
r-base (2.2.1-6) unstable; urgency=medium
* debian/r-base-core.preinst: The symbolic link /usr/lib/R/share
introduced in -4 prevents the directory added in -5 to be created
so remove if found in the preinst.
* Urgency still set up to medium so that testing and unstable users get
the fix quickly.
-- Dirk Eddelbuettel <edd@debian.org> Mon, 6 Feb 2006 12:00:21 -0600
r-base (2.2.1-5) unstable; urgency=medium r-base (2.2.1-5) unstable; urgency=medium
* debian/build-help.pl: Empty stanza to just print warning when called. * debian/build-help.pl: Empty stanza to just print warning when called.
......
#!/bin/sh
#
# preinst script for the Debian GNU/Linux r-base-core package
# This version written by Dirk Eddelbuettel <edd@debian.org>
set -e
#DEBHELPER#
case "$1" in
install|upgrade)
# edd 06 Feb 2006 2.2.1-4 created this symlink, we now want a directory
if [ -h /usr/lib/R/share ]
then
echo "Remving symbolic link /usr/lib/R/share"
rm /usr/lib/R/share
fi
;;
abort-upgrade)
;;
*)
echo "preinst called with unknown argument \`$1'" >&2
;;
esac
exit 0
...@@ -437,7 +437,7 @@ install-arch-stamp: ...@@ -437,7 +437,7 @@ install-arch-stamp:
# edd 06 Feb 2006 softlink fails with upgrades from older versions # edd 06 Feb 2006 softlink fails with upgrades from older versions
dh_installdirs -p$(corepackage) usr/lib/R/share/perl dh_installdirs -p$(corepackage) usr/lib/R/share/perl
install -m 0644 debian/build-help.pl \ install -m 0644 debian/build-help.pl \
debian/$(corepackage)/usr/lib/R/share/perl debian/$(corepackage)/usr/lib/R/share/perl/
# add tab completion by Deepayan # add tab completion by Deepayan
install -m 0644 debian/R.bash_completion \ install -m 0644 debian/R.bash_completion \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment