1. 04 Apr, 2018 21 commits
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.2.1-6 · 17e7ba3f
      Dirk Eddelbuettel authored
      r-base (2.2.1-6) unstable; urgency=medium
      
        * debian/r-base-core.preinst: The symbolic link /usr/lib/R/share 
          introduced in -4 prevents the directory added in -5 to be created
          so remove if found in the preinst.
      
        * Urgency still set up to medium so that testing and unstable users get 
          the fix quickly. 
      17e7ba3f
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.2.1-5 · 6fa31613
      Dirk Eddelbuettel authored
      r-base (2.2.1-5) unstable; urgency=medium
      
        * debian/build-help.pl: Empty stanza to just print warning when called.
        * debian/rules: Install that quasi-empty file debian/build-help.pl as 
          /usr/lib/R/share/perl/build-help.pl  so that the not-yet-updated 
          r-cran-* et al add-on packages for R do not fail now that the upstream
          build-help.pl is install in /usr/share/R/share/perl/.  The softlink
          solution introduced in 2.2.1-4 fails for upgrades on testing where
          /usr/lib/R/share/ already exists as a directory.
        
        * Urgency set up to medium so that testing users get the fix quickly. 
          No other changes than creation of the two-liner build-help.pl 
      6fa31613
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.2.1-4 · 78726ffa
      Dirk Eddelbuettel authored
      r-base (2.2.1-4) unstable; urgency=low
      
        * debian/rules: Until the postinst and postrm calls in all r-cran-* 
          packages have been updated, add a transitional link so we can call
          /usr/lib/R/share/perl/build-help.pl			(Closes: #349637)
      78726ffa
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.2.1-3 · 9500ebb3
      Dirk Eddelbuettel authored
      r-base (2.2.1-3) unstable; urgency=low
      
        * Re-wrote parts of debian/* to take advantage of recent upstream changes
          permitting installation of (most) files outside of /usr/lib/R;
        * debian/rules: Use configure options 
            --datadir=/usr/share/R/share and 
            --includedir=/usr/share/R/include
          as well as 'make install' targets
            rsharedir, rincludedir, and rdocdir
        * debian/r-{base-html.{files,dirs}, doc-pdf.{files,links},
          doc-html.{file,links}}:
          updated accordingly to refer to /usr/share/R/* instead of /usr/lib/R
        * For R itself (but not for packages), architecture-independent files 
          of r-base-core now install below /usr/share/R 	(Closes: #300765)
        
        * debian/control: Added Build-Depends: for libx11-dev, libxt-dev, x-dev
          (though the existing Build-Depends on tcl/tk effectively cover this).
          Credits for the suggestion go to the xlibs-split-check script .
      9500ebb3
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.2.1-2 · 5fdd48f8
      Dirk Eddelbuettel authored
      r-base (2.2.1-2) unstable; urgency=low
      
        * debian/control: Remove Build-Depends: on libpaperg-dev as we do not
          actually build against libpaper anyway 		(Closes: #346403)
        * debian/control: Add Depends: on libpaper-utils to r-base-core, 
          and remove different Suggests: of libpaperg
      
        * debian/control: Update Standards-Version: to 3.6.2
        * debian/control: Change Architecture: any for empty r-recommended
      5fdd48f8
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.2.1-1 · 51e699d4
      Dirk Eddelbuettel authored
      r-base (2.2.1-1) unstable; urgency=low
      
        * New upstream version 2.2.1 released this morning
        
        * debian/control: Remove unnecessary f2c from Depends: in r-base-dev 
        * debian/rules: Set DH_COMPAT=4
      
      r-base (2.2.0.rc.20051214-1) unstable; urgency=low
      
        * Second beta release of the upcoming R 2.2.1 planned for December 20
      
      r-base (2.2.0.rc.20051206-1) unstable; urgency=low
      
        * First beta release of the upcoming R 2.2.1 planned for December 20
      
        * debian/rules: Install bash completion file debian/R.bash_completion 
          by Deepayan Sarkar and announced to r-devel on 2005-11-30
      
      r-base (2.2.0.final-4) unstable; urgency=low
      
        * debian/rules: Really skip 'make check' on hppa	(Closes: #333462)
      
      r-base (2.2.0.final-3) unstable; urgency=low
      
        * debian/rules: Skip 'make check' on hppa		(Closes: #333462)
      
      r-base (2.2.0.final-2) unstable; urgency=low
      
        * Rebuilt with properly renamed .orig.tar.gz          (Closes: #332586)
      
      r-base (2.2.0.final-1) unstable; urgency=low
      
        * New upstream version 2.2.0 released today, following six
          Debian pre-releases  (and a repeat of a version number snafu made
          years ago, hence the need for the '.final')
      
      r-base (2.2.0.beta.20050929-1) unstable; urgency=low
      
        * Second weekly beta release (using 2005-09-22 candidate) of R 2.2.0 
      
        * debian/rules: Call configure with LIBnn=lib to enforce use of
          /usr/lib everywhere, including amd64  		(Closes: #329952)
      
        * share/perl/build-help.pl: Wrote patch to re-enable deprecated --htmllists
          argument as a no-op so that our r-cran-* postinst files can call it.
      
      r-base (2.2.0.beta.20050922-2) unstable; urgency=low
      
        * debian/rules:  Create softlink from R's TeX files (used for doc.
          and Sweave) into the texmf hierarchy. (Thanks, Gregor Gorjanc)
        * debian/r-base-core.dirs: Add 'usr/share/texmf/tex/latex'
        * debian/r-base-core.postinst: Call texhash if it exists
        
        * Really re-apply the Perl fix (share/perl/{build-help.pl,R/Rdlists.pm)
          to maintain compatibility with all the r-cran-* packages postinst
          							(Closes: #330085)
      
      r-base (2.2.0.beta.20050922-1) unstable; urgency=low
      
        * First beta release candidate (dated 2005-09-22) of R 2.2.0 
      
        * Following prior practice, this release is designated for unstable
          after the two first alpha releases in experiment. 
      
        * share/perl/build-help.pl, share/perl/R/Rdlists.pm: As in the previous
          snapshot, fall back to R 2.1.1 code to support other r-cran-* packages
      
      r-base (2.2.0.alpha.20050915-1) experimental; urgency=low
      
        * Second alpha release of the upcoming R 2.2.0 planned for October 6
      
        * share/perl/build-help.pl, share/perl/R/Rdlists.pm: As in the previous
          snapshot, fall back to R 2.1.1 code to support other r-cran-* packages
      
      r-base (2.2.0.alpha.20050908-2) experimental; urgency=low
      
        * debian/rules: Also re-set the newly added variables R_SHARE_DIR, 
          R_INCLUDE_DIR and R_DOC_DIR in /usr/bin/R 		(Closes: #327446)
      
        * share/perl/build-help.pl: Revert to the version from R 2.1.1 as
          we need the now deprecated --htmllists argument in the postinst
          and postrm scripts of several dozen r-cran-* packages.
        * share/perl/R/Rdlists.pm: Carry build_htmlpkglists() and read_titles()
          over from 2.1.1 to support the --htmllists code
      
      r-base (2.2.0.alpha.20050908-1) experimental; urgency=low
      
        * First alpha release of the upcoming R 2.2.0 planned for October 6
      
        * debian/{control,rules}: Build-Depends switched to gcc-4.0 
          by removing "gcc-3.4, g++-3.4, g77-3.4" 
      51e699d4
    • Dirk Eddelbuettel's avatar
      Import Upstream version 2.2.1 · 2384e0d3
      Dirk Eddelbuettel authored
      2384e0d3
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.1.1-1 · 4073d6c7
      Dirk Eddelbuettel authored
      r-base (2.1.1-1) unstable; urgency=low
      
        * New upstream version 2.1.1 released today
        
        * debian/control: Remove redundant Build-Depends on 'mawk | gawk | awk'
      
      r-base (2.1.0.beta.20050613-1) unstable; urgency=low
      
        * Upgraded to the R 2.1.1 beta release candidate dated 2005-06-13
      
        * debian/rules: configure call with AWK="/usr/bin/awk" (Closes: #307683)
        * debian/control: New Build-Depends on 'mawk | gawk | awk'
      4073d6c7
    • Dirk Eddelbuettel's avatar
      Import Upstream version 2.1.1 · 1786031e
      Dirk Eddelbuettel authored
      1786031e
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.1.0-1 · 51641a46
      Dirk Eddelbuettel authored
      r-base (2.1.0-1) unstable; urgency=low
      
        * New upstream version 2.1.0 released today
      
      r-base (2.0.1.beta.20050410-1) unstable; urgency=low
      
        * Upgraded to the R 2.1.0 beta release candidate dated 2005-04-10
      
        * With R 2.1.0 scheduled to be released on April 18, this release
          candidate will be uploaded to unstable to allow for wider testing
        
        * debian/rules: Also copy new file 'repositories' to /etc/R and link back
      
      r-base (2.0.1.alpha.20050403-1) experimental; urgency=low
      
        * Upgraded to the R 2.1.0 alpha release candidate dated 2005-04-03
      
        * This upload is still slated for experimental; beta release 
          candidates of 2.1.0 will go into unstable
      
      r-base (2.0.1.alpha.20050322-1) experimental; urgency=low
      
        * Initial attempt at packaging the upcoming R 2.1.0
      
        * debian/rules: No longer install $RHOME/bin/Rdindex
        
        * debian/rules: No longer build the Gnome GUI which has been
          unbundled upstream as it was never fully completed
        * debian/control: Update r-gnome Description
        * debian/control: r-gnome is now Binary: all, removed ${shlibs:Depends}
          and versioned (= ${Source-Version}) part of Depends on r-base-core 
        * debian/control: Reduce Build-Depends by libgnome-dev, libzvt-dev, 
          libgtkxmhtml-dev, libglade-gnome0-dev
        * debian/r-gnome.NEWS: New file with message about removeal of UI
        
        * debian/control: For r-base-dev, switched from the black magic
          "g77 | m68k, f2c | not+m68k, type-handling" to "g77, f2c" as
          type-handling no longer allows this (Closes: #296287)
      
        * debian/r-mathlib.shlibs: Correct to 'libRmath 1 r-mathlib (>= 2.0)'
          with thanks to Chris Lawrence
      51641a46
    • Dirk Eddelbuettel's avatar
      Import Upstream version 2.1.0 · 4e20891f
      Dirk Eddelbuettel authored
      4e20891f
    • Dirk Eddelbuettel's avatar
      Import Debian changes 2.0.1-4 · 9a058e8f
      Dirk Eddelbuettel authored
      r-base (2.0.1-4) unstable; urgency=low
      
        * Removed erreneously left-over doc-base file (Closes: #296194)
        * debian/r-doc-{html,pdf}.links: Link individual files, not the
          entire manual directory, in order to circumvent a dhelp bug 
      
      r-base (2.0.1-3) unstable; urgency=low
      
        * debian/r-doc-html.doc-base.*: Added five doc-base control files
          to register the html documentation with doc-base (Closes: #296089)
      
      r-base (2.0.1-2) unstable; urgency=low
      
        * debian/control: Switch the Depends: on the helper package r-base-dev
          to libreadline5-dev to help readline5 migration (Closes: #291655)
        * debian/control: Also switch Build-Depends: to libreadline5-dev
      
      r-base (2.0.1-1) unstable; urgency=medium
      
        * New upstream release
        * Urgency medium as this version contains numerous upstream fixes, 
          as well as Debian fixes from 2.0.0-4 that have are not yet in testing 
      
        * debian/control: Add r-recommended to Depends: for r-base
      
      r-base (2.0.0-4) unstable; urgency=medium
      
        * Urgency medium to get the fix into the testing distribution in which 
          r-recommended currently has insufficiently detailed Depends:
        * debian/control: Change Depends: for r-recommended to be versioned, and
          impose a minimum standard of package versions rebuilt under R 2.0.0 
          as required by the underlying lazyloading changes (Closes: #278528)
      
      r-base (2.0.0-3) unstable; urgency=low
      
        * Two improvements suggested by Kurt Hornik:
          - debian/control: r-base now Depends: on r-base-core (= ${Source-Version})
          - debian/control: Fix MASS book title in Description: of r-recommends
      
        * Reorganisation of r-mathlib suggested and tested by Faheem Mitha:
          - debian/control: r-mathlib now only Recommends: insteads of Depends:
            on r-base-core and r-base-dev (Closes: #276038)
          - debian/rules: Small changes to give r-mathlib its own doc directory
          - debian/r-mathlib.links: Renamed to r-mathlib.links.unused disable
        
        * Update to use of Lapack code as suggested by Doug Bates:
          - debian/rules: Set Lapack back to --with-lapack=no
          - debian/control: Remove "lapack3-dev | atlas3-base-dev" from Build-Depends
          - debian/control: Remove "lapack3-dev | atlas3-base-dev | liblapack-3.so"
            from Depends for r-base-dev as well
          - debian/rules: Turn 'make check' back on (outside of arm)
      
      r-base (2.0.0-2) unstable; urgency=low
      
        * src/main/startup.c: Removed 'static' on RestoreAction declaration
          as recommend by Brian Ripley in bug report follow-up (Closes: #275791)
      
      r-base (2.0.0-1) unstable; urgency=low
      
        * New upstream release
        
        * src/library/tools/R/admin.R, src/scripts/INSTALL.in: Applied
          small patch by Brian Ripley to address package build issues
      
      r-base (1.9.1.beta.20040929-1) experimental; urgency=low
      
        * Upgraded to the R 2.0.0 beta release candidate dated 2004-09-29
        * Still uploading to 'experimental' to keep 1.9.1-3 in testing
      
      r-base (1.9.1.beta.20040928-1) experimental; urgency=low
      
        * Upgraded to the R 2.0.0 beta release candidate dated 2004-09-28
        * Still uploading to 'experimental' to keep 1.9.1-3 in testing
        * debian/rules: No longer install BUGS which is no longer in upstream sources
      
      r-base (1.9.1.beta.20040925-1) experimental; urgency=low
      
        * Upgraded to the R 2.0.0 beta release candidate dated 2004-09-25
        * Still uploading to 'experimental' to keep 1.9.1-3 in testing
      
      r-base (1.9.1.beta.20040921-1) experimental; urgency=low
      
        * Upgraded to the R 2.0.0 beta release candidate dated 2004-09-21
        * Still uploading to 'experimental' to keep 1.9.1-3 in testing
      
      r-base (1.9.1.alpha.20040912-1) experimental; urgency=low
      
        * Upgraded to the R 2.0.0 alpha release candidate dated 2004-09-12
        * Still uploading to 'experimental' as 1.9.1-3 is not yet in testing
      
      r-base (1.9.1.alpha.20040906-1) experimental; urgency=low
      
        * Upgraded to the initial R 2.0.0 alpha release candidate dated 2004-09-06 
      
        * Distribution set to 'experimental' as we would like the previous release
          1.9.1-3 to migrate to 'testing' first; as that has happened we will make
          alpha and/or beta releases of 2.0.0 to 'unstable' prior to the formal 
          release  
      
      r-base (1.9.1-3) unstable; urgency=low
      
        * debian/control: Expanded Depends for r-base-dev to include virtual
          packages libblas-3.so and liblapack-3.so as final alternatives.
        * debian/copyright: Author list updated as suggested by Kurt Hornik
        * src/modules/gnome/system.c: Change 'R_Interactive = 1' instead of the 
          isatty() call, as suggested by Brian D. Ripley (Closes: #269107)
      
      r-base (1.9.1-2) unstable; urgency=low
      
        * debian/r-base-core.postinst: Papersize code conditional on paperconf
        * debian/control: Added Suggests for libpaper-utils
      
      r-base (1.9.1-1) unstable; urgency=low
      
        * Upgraded to version 1.9.1 released today
      
        * debian/rules: Configure with R_PAPERSIZE='letter' 
        * debian/r-base-core.postinst: Re-wrote papersize setting code
      
      r-base (1.9.0.beta.20040614-1) unstable; urgency=low
      
        * Upgraded to the initial 1.9.1 beta release candidate of 2004-06-14
      
      r-base (1.9.0.alpha.20040607-1) unstable; urgency=low
      
        * Upgraded to the initial 1.9.1 alpha release candidate of 2004-06-07
      
        * Contains upstream fix for version number in search entry of CRAN
          packages, with thanks to Kurt Hornik (Closes: #248430)
        
        * debian/Renviron-R_PAPERSIZE.patch: New patch to set R_PAPERSIZE in 
          /etc/R/Renviron by respecting both a prior setting and the value
          in /etc/papersize, with thanks to Matej Cepl  (Closes: #245525)
      
        * debian/control: Remove unversioned g++ from Build-Depends [ lintian ]
        * debian/control: r-mathlib, r-recommended get versioned Depends
          on r-base-core as doc directories are symlinked [ lintian ]
      
      r-base (1.9.0-1) unstable; urgency=low
      
        * Upgraded to version 1.9.0 released today
      
      r-base (1.8.1.cvs.20040410-1) unstable; urgency=low
      
        * Upgraded to beta release candidate 2004-04-10 of R 1.9.0
      
      r-base (1.8.1.cvs.20040331-1) unstable; urgency=low
      
        * Upgraded to beta release candidate 2004-03-31 of R 1.9.0
      
      r-base (1.8.1.cvs.20040321-1) unstable; urgency=low
      
        * Upgraded to beta release candidate 2004-03-21 of R 1.9.0
      
      r-base (1.8.1.cvs.20040314-1) unstable; urgency=low
      
        * Upgraded to release candidate 2004-03-14 of R 1.9.0
      
      r-base (1.8.1.cvs.20040307-1) unstable; urgency=low
      
        * Upgraded to release candidate 2004-03-07 of R 1.9.0
      
      r-base (1.8.1.cvs.20040229-2) unstable; urgency=low
      
        * debian/control: Declare Replaces: r-recommended as well for r-base-html
          and r-base-latex as they contain parts of 'grid' which used to be in
          r-recommended, but is now in r-base-core and these two (Closes: #235891)
        
        * debian/rules: Do not ship usr/share/info/dir(.old) (Closes: #235713)
      
      r-base (1.8.1.cvs.20040229-1) unstable; urgency=low
      
        * Upgraded to release candidate 2004-02-29 of R 1.9.0
        
        * debian/rules changes to configure call
           --without-r-recommended (as r-recommended is now a meta-package)
           --with-bzlib to override default of no
           --with-pcre to override default of no
           --with-zlib to override default of no
           R_BROWSER=sensible-browser to not depend on mozilla
      
        * debian/control: r-base-core Replace r-recommended (<= 1.8.1-1) as 
          the grid package moved 
        
        * debian/control: r-recommended is now a metapackage that depends on the
          individual packages which are now part of the Debian distribution; 
          and added appropriate Depends for all of them
        * debian/rules: Hence 'configure [...] --without-recommended-packages	[...]'
        * debian/control: Added Conflicts: r-recommended (<< 1.9.0) to r-base-core
        
        * debian/rules: In make-arch target, now call "make docs" with 
          R_CMD_BUILD_HELP_OPTS="--txt --example" to build only the documentation 
          needed for binary-arch targets (thanks to Kurt Hornik for enabling this)
        
        * debian/rules: configure with PAGER=/usr/bin/pager as all the good
          reasons pointed out in #230524 regarding octave2.1 apply to R too
        
        * debian/control: Depends for r-base-dev changed from the imperfect 
          "g77 | f2c" to to "g77 | m68k, f2c | not+m68k, type-handling" with 
          thanks to Wouter Verhelst
        
        * debian/control: Changed Build-Depends from 'blas-dev (>=1.0-9),lapack-dev'
           to 'refblas3-dev | atlas3-base-dev, lapack3-dev | atlas3-base-dev'
        * debian/control: Dito for Depends: for r-base-dev 
        * debian/rules: Set configure arguments for refblas3/atlas3 and 
          lapack3/atlas3, respectively, instead of blas/atlas v2.
      
      r-base (1.8.1-2) unstable; urgency=low
      
        * debian/control: Added to Build-Depends
           libpaper-utils for paperconf
           libjpeg62-dev for jpeg (thanks to Kurt Hornik for the suggestion)
           libprce3-dev for pcre
           linpng12-dev for png
           zlib1g-dev for zlib
          
        * debian/control: Added to Depends for r-base-dev
           libjpeg62-dev, libpcre3-dev  (thanks to Kurt Hornik for the suggestion)
      
      r-base (1.8.1-1) unstable; urgency=low
      
        * Upgraded to version 1.8.1 released today
        
        * debian/control: Move r-base-html and r-base-latex from the Depends: for
          r-base to Recommends: as one cannot depend on packages of lower priority
        * debian/rules: Use --without-blas on arm
      
      r-base (1.8.0.cvs.20031114-1) unstable; urgency=low
      
        * Upgraded to the initial 1.8.1 beta release of 2003-11-14
      
      r-base (1.8.0.cvs.20031107-1) unstable; urgency=low
      
        * Upgraded to the initial 1.8.1 alpha release of 2003-11-07
        * debian/rules: Configure with R_PRINTCMD=/usr/bin/lpr (Closes: #219419)
      
      r-base (1.8.0.cvs.20031101-1) unstable; urgency=low
      
        * Upgraded to 1.8.0 patched aka pre-1.8.1 as of 2003-11-01
        * Also upgraded R-recommended via rsync
        * debian/rules: make docs has to be called when binary-arch is built 
      
      r-base (1.8.0.cvs.20031024-1) unstable; urgency=low
      
        * Upgraded to 1.8.0 patched as of 2003-10-24
        * Also upgraded R-recommended via rsync
        * To avoid possible upgrade conflicts with pre-releases of 1.8.1, we 
          use previously used ".cvs.YYYYMMDD" naming convention for the package
        * debian/rules: 'make {docs,help,html}' are now called in binary-indep
          which was not possible with earlier versions of R; however as make
          recommended implies make doc, we manually descend into its top dir.
      
      r-base (1.8.0-2) unstable; urgency=low
      
        * With a big thanks to Camm Maguire for investigating this problem,
          we are reverting back to the previously used setup of defaulting to 
          Blas while automagically switching to Atlas where installed:
          - debian/rules: Patch R.sh.in to disable use of R_LD_LIBRARY_PATH (beyond
            the required $R_HOME/nbin) which conflicts with Debian's transparent 
            switch of Atlas for Blas (as /usr/lib/libblas would be found instead)
          - debian/rules: Configure again with --with-blas=blas
          - debian/control: Hence remove Depends: on atlas2-base-dev | atlas2-dev
          - debian/shlibs.local: Remove, no longer needed
          - debian/rules: No longer need to postprocess Depends
          - debian/rules: Other small cleanups
      
      r-base (1.8.0-1) unstable; urgency=low
      
        * Upgraded to version 1.8.0 released today
      
      r-base (1.7.1.cvs.20031004-1) unstable; urgency=low
      
        * Upgraded to release candidate 1.8.0beta_2003-10-04 of R 1.8.0
        * debian/control: Change Depends: to atlas2-base-dev | atlas2-dev 
      
      r-base (1.7.1.cvs.20030927-1) unstable; urgency=low
      
        * Upgraded to release candidate 1.8.0beta_2003-09-27 of R 1.8.0
        * debian/control: Add Depends: on atlas2-dev for r-base-dev
      
      r-base (1.7.1.cvs.20030920-1) unstable; urgency=low
      
        * Upgraded to release candidate 1.8.0alpha_2003-09-20 of R 1.8.0
        * debian/{r-base-core,r-gnome}.menu: Small beautifications
      
      r-base (1.7.1.cvs.20030913-1) unstable; urgency=low
      
        * Upgraded to release candidate 1.8.0alpha_2003-09-13 of R 1.8.0
      
      r-base (1.7.1.cvs.20030906-1) unstable; urgency=low
      
        * Upgraded to release candidate 2003-09-06 of R 1.8.0
      
      r-base (1.7.1.cvs.20030830-1) unstable; urgency=low
      
        * Upgraded to release candidate 2003-08-30 of R 1.8.0
      
      r-base (1.7.1.cvs.20030822-1) unstable; urgency=low
      
        * Upgraded to release candidate 2003-08-22 of R 1.8.0
        * debian/control: Standards-Version increased to 3.6.1.0
      
      r-base (1.7.1.cvs.20030814-1) unstable; urgency=low
      
        * Upgraded to release candidate 2003-08-14 of R 1.7.2 (or 1.8.0)
      
      r-base (1.7.1.cvs.20030808-1) unstable; urgency=low
      
        * Upgraded to release candidate 2003-08-08 of R 1.7.2 (or 1.8.0)
        * Upstream release candidate sources do not contain the source for the
          r-recommended package so tools/rsync-recommended was used to obtain
          these and a new, Debian-only, orig.tar.gz of both was created
        * debian/control: r-base-dev now has a versioned Depends on r-base-core
          which requires equal version numbers between the two (Closes: #199295)
        * debian/control: Upgraded Standards-Version to 3.6.0
      
      r-base (1.7.1-1) unstable; urgency=low
      
        * New upstream version 1.7.1 released today
      
      r-base (1.7.0.cvs.20030607-1) unstable; urgency=low
      
        * Upgraded to initial release candidate (dated 2003-06-07) of R 1.7.1
        * debian/{control,rules}: Switch back to default compiler version as 3.3 
          is in unstable and testing; m68k still needs f2c for Fortan code
      
      r-base (1.7.0.cvs.20030602-1) unstable; urgency=low
      
        * Upgraded to initial release candidate (dated 2003-06-02) of R 1.7.1
        * debian/{rules,control}: Try f2c on m68k as a last resort
      
      r-base (1.7.0.cvs.20030526-1) unstable; urgency=low
      
        * Upgraded to release candidate 2003-05-26 of R 1.7.1
        * Manually rsync'ed r-recommendeds sources as R-patched pre-release do
          not comprise r-recommended, also manually re-built upstream tarball
        * debian/control: Require gcc/g++/g77-3.2 as version 3.3 is in unstable
          gcc 3.2 works fine everywhere with the exception of m68k (Closes: #194175)
        * debian/shlibs.local: Have libatlas imply either the actual atlas2-base 
          or the virtual atlas2 provided by tuned libraries (Closes: #193831)
        * debian/control: Added 'xpdf-reader | pdf-viewer' to Build-Depends
        * debian/control: Upgraded Standards-Version to 3.5.10
      
      r-base (1.7.0-3) unstable; urgency=low
      
        * debian/rules: No longer configure for use of an external lapack library
          as some numerical infelicities have come up on shore.
        * debian/rules: Now call configure --with-blas=atlas for Atlas / Blas 
        * debian/shlibs.local: add '| blas | blas2' to 'libatlas 2 atlas2-base'
        * debian/control: r-gnome Recommends: r-cran-gtkdevice (Closes: #190735)
      
      r-base (1.7.0-2) unstable; urgency=low
      
        * debian/control: r-recommended Description updates w.r.t. MASS edition
        * debian/rules: Remove Depends of r-recommended on atlas2-base as it is 
          neither 'virtual' nor required as r-recommnded itself depends on 
          r-base-core so that we get its Depends on atlas2-base | blas2 | blas
      
      r-base (1.7.0-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (1.6.2.cvs.20030413-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-04-13 of R 1.7.0
        * debian/control: Section set to gnome for r-gnome
        * debian/r-recommended.preinst: rm doc dir (Closes: #188995)
      
      r-base (1.6.2.cvs.20030409-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-04-09 of R 1.7.0
        * debian/rules: Hack result of dh_shlibdeps with Perl to remove the
          double atlas2 entry caused by the virtual depends on blas and lapack
        * debian/rules: Small improvement to R_LIBS patch to conform with
          standard of respecting prior settings, if any, of the variable
        * debian/control: Upgraded Standards-Version to 3.5.9
      
      r-base (1.6.2.cvs.20030405-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-04-05 of R 1.7.0
        * debian/rules: Configure with --with-blas, not --with-blas=blas
        * debian/r-base-core.prerm: s/treu/true/
        * debian/rules: Link $R_HOME/doc into /usr/share/doc/r-base-core, rather
          than its subdirectories doc and manual as e.g. manual link could be
          dangling if r-doc-pdf is not installed (Closes: #187573)
      
      r-base (1.6.2.cvs.20030403-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-04-03 of R 1.7.0
        * debian/rules: Add R_LIBS setting to /etc/R/Renviron such that 
          user-installed packages will be in /usr/local/lib/R/site-library,
          Debian packages will install into /usr/lib/R/site-library and
          the r-base-core and r-recommended packages will use the standard
          /usr/lib/R/library directory
        * debian/r-base-core.dirs: Add /usr/lib/R/site-library
        * debian/r-base-core.postinst: Add failsafe creation of directory
          /usr/local/lib/R/site-library as per Policy section 10.1.2
        * debian/r-base-core.prerm: Add failsafe creation of directory
          /usr/local/lib/R/site-library as per Policy section 10.1.2
      
      r-base (1.6.2.cvs.20030331-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-03-30 of R 1.7.0
        * debian/control: Added lapack-dev to Depends for r-base-dev
        * debian/rules: Removed rrecommended tests
      
      r-base (1.6.2.cvs.20030330-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-03-30 of R 1.7.0
        * Upstream sources fix the problem reported in #186857 (Closes: #186857)
      
      r-base (1.6.2.cvs.20030326-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-03-26 of R 1.7.0
        * debian/rules: Configure with --with-lapack
        * debian/control: Build-Depends on lapack-dev
        * debian/rules: Explicitly use gcc/g77/g++-3.2 for builds on testing
        * debian/r-gnome.menu: The Needs: entry was corrected to "x11"
      
      r-base (1.6.2-2) unstable; urgency=low
      
        * Rebuilding on Debian unstable with gcc/g++/g77 as the new default
        * debian/control: Depends g77 (>= 3.2.2), g++ (>= 3.2.2) for r-base{,-dev}
        * debian/rules: Adjusted accordingly by defaulting to gcc, g++, g77
      
      r-base (1.6.2-1) unstable; urgency=low
      
        * New upstream version 1.6.2 released today
        * debian/r-base-core.lintian: Added exceptions for 
          image-file-in-usr-lib usr/lib/R/doc/html/{left,logo,logosm,right,up}.jpg
        * debian/rules: Substitute Perl path to /usr/bin/perl for 
          usr/lib/R/bin/{Rdconv,Rdindex,Rprof,Sd2Rd,build,check}
      
      r-base (1.6.1.cvs.20030103-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2003-01-03 of R 1.6.2
      
      r-base (1.6.1.cvs.20021230-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2002-12-30 of R 1.6.2
        * Added Douglas Bates as an Uploader following email discussion with Dirk
      
      r-base (1.6.1-3) unstable; urgency=low
      
        * debian/{control,rules}: Configure switch from f2c to g77 for m68k
        * debian/{control,rules}: Configure switch from tcl/tk8.3 to tcl/tk8.4
        * debian/control: Added libpaperg-dev to Build-Depends (Closes: #168259)
        * debian/r-base-control: Substitute result from paperconf call 
          into $R_HOME/etc/Renviron, not /usr/bin/R 
        * debian/rules: Move $R_HOME/etc/* files into /etc/R/ (Closes: #170018)
      
      r-base (1.6.1-2) unstable; urgency=low
      
        * Rebuilt with support for bzip2 (compression) and pcre (reg.expressions)
        * debian/control: Added libbz2-dev and libpcre3-dev to Build-Depends
        * debian/rules: Set R_BROWSER to /usr/bin/mozilla in $R_HOME/etc/Renviron
      
      r-base (1.6.1-1) unstable; urgency=low
      
        * Upgraded to R version 1.6.1 released today
      
      r-base (1.6.0.rel.20021024-1) unstable; urgency=low
      
        * Upgraded to release candidate dated 2002-10-24 of R 1.6.1
        * debian/control: Set section for r-base-dev to devel
        * debian/r-doc-info.prerm: Add upgrade target
      
      r-base (1.6.0.rel.20021017-1) unstable; urgency=low
      
        * Upgraded to first release candidate (dated 2002-10-17) of R 1.6.1
        * Since 1.6.0, the R Core upstream stream now bundles the sources 
          of the r-recommended package directly in the r-base sources -- thus 
          the source package r-recommended will be replaced by a binary 
          package derived from these sources
        * debian/control: Added new package r-recommended
        * debian/r-recommended.{files,links}: Defined accordingly
        * debian/copyright: Include the copyright file from r-recommended
      
      r-base (1.6.0.rel-1) unstable; urgency=low
      
        * Upgraded to new upstream release 1.6.0 [ which we need to rename
          1.6.0.rel so that is sorts higher than 1.6.0.rc.20020927 ]
      
      r-base (1.6.0.rc.20020927-1) unstable; urgency=low
      
        * Upgraded to new release candidate of R 1.6.0
      
      r-base (1.6.0.rc.20020917-1) unstable; urgency=low
      
        * Upgraded to new release candidate of R 1.6.0
      
      r-base (1.6.0.rc.20020910-1) unstable; urgency=low
      
        * First release candidate of R 1.6.0 which is scheduled to be released on
          October 1, 2002 -- this release corresponds to the first feature freeze
        * debian/control: More Suggests: of the r-doc-* packages
      9a058e8f
    • Dirk Eddelbuettel's avatar
      Import Upstream version 2.0.1 · 07217808
      Dirk Eddelbuettel authored
      07217808
    • Dirk Eddelbuettel's avatar
      Import Debian changes 1.5.1-0woody1 · 0d2098a5
      Dirk Eddelbuettel authored
      r-base (1.5.1-0woody1) woody-proposed-updates; urgency=low
      
        * Backport for woody built against atlas with corrected virtual Depends 
          on blas/atlas to prevent bugs like #150253 and #152284 in woody
        * debian/rules: Use "-O0 -g0" on arm and m68k to shorten compile time
        * debian/control: Added lib{ncurses5,readline4}-dev to r-base-dev Depends 
      
      r-base (1.5.1-1) unstable; urgency=low
      
        * Upgraded to new upstream release 1.5.1
        * debian/rules: Also create link from libRmath.so to libRmath.so.1
        * debian/rules: Include test.c example in r-mathlib (Closes: #149723)
        * debian/README.mathlib: Added, includes src/nmath/standalone/README
      
      r-base (1.5.0-3) unstable; urgency=low
      
        * debian/r-doc-html.links: Link into /usr/lib/R/doc/manual (Closes: #148628)
        * debian/r-doc-pdf.links: Idem
      
      r-base (1.5.0-2) unstable; urgency=low
      
        * debian/rules: Remove usr/share/info/dir{,.old} (Closes: #148054)
      
      r-base (1.5.0-1) unstable; urgency=low
      
        * Upgraded to new upstream release 1.5.0
      
      r-base (1.4.1.cvs20020421-1) unstable; urgency=low
      
        * Upgraded to new release candidate 2002-04-21 of R 1.5.0
        * debian/control: Added virtual fortran77-compiler, c-compiler to the
          list of alternative compilers that r-base-dev Depends: on
      
      r-base (1.4.1.cvs20020414-1) unstable; urgency=low
      
        * Upgraded to new release candidate 2002-04-14 of R 1.5.0
      
      r-base (1.4.1.cvs20020407-1) unstable; urgency=low
      
        * Upgraded to new release candidate 2002-04-07 of R 1.5.0
      
      r-base (1.4.1.cvs20020331-1) unstable; urgency=low
      
        * Upgraded to new release candidate 2002-03-23 of R 1.5.0
      
        * debian/control: Build-Depends on texinfo (>= 4.1-2) to ensure that 
          we will not be bitten by the epsf.tex bug 
      
      r-base (1.4.1.cvs20020323-1) unstable; urgency=low
      
        * Upgraded to new release candidate 2002-03-23 of R 1.5.0
      
        * debian/control: New packages r-base-core, r-base-html, r-base-latex 
          and r-doc-info have been split from the old r-base package which now 
          Depends: on these, but can also be removed -- this adds some extra
          flexibility and can save over eight megabytes of installed files.
        * debian/control: Replaces: r-base (<= 1.4.1-1) for the new packages
      
        * debian/rules: Fortan compiler selection adapted to new upstream configure
        * debian/control: r-base Suggests: r-base-dev instead of gcc
        * debian/copyright: Updated and included current COPYRIGHTS file ...
        * debian/rules: ... and therefore do not install COPYRIGHTS separately
        * debian/control: Added Build-Depends on texi2html (split from tetex-bin)
      
      r-base (1.4.1-1) unstable; urgency=low
      
        * Upgraded to new upstream release 1.4.1
      
      r-base (1.4.0.cvs20020124-1) unstable; urgency=low
      
        * Upgraded to the R-patched_2002-01-24 release candidate for 1.4.1
      
      r-base (1.4.0-1) unstable; urgency=low
      
        * Upgraded to new upstream release 1.4.0
        * debian/control: Add lib{zvt,gtkxmhtml}-dev to Build-Depends [thanks, Doug]
        * debian/control: Fixed hppa Build-Depends [thanks, Matthew Wilcox]
        * debian/rules: Minor cleanup regarding configuration options
        * debian/control: Changed Priority: from extra to optional
        * debian/control: Corrected r-doc-html Description [thanks, Doug Bates]
        * debian/control: Spelling corrections (Closes: #125300)
      
      r-base (1.3.1-6) unstable; urgency=low
      
        * debian/rules: Also apply s/-lg2c/-lg2c-pic/ on etc/Makeconf
        * debian/control: Revert to Arch: all for doc packages, no Depends r-base
        * debian/control: r-base-dev Depends remodelled on r-base Build-Depends
      
      r-base (1.3.1-5) unstable; urgency=low
      
        * debian/rules: Unset CPPFLAGS, LIBS before calling configure to not
          leave traces of /usr/local. Thanks, Kurt Hornik (Closes: #71917)
        * debian/rules: More s/-lg2c/-lg2c-pic/ substitution in src/library/
        * debian/control: Added new package r-mathlib (Closes: #119701)
        * debian/control: Added new package r-doc-html (R manuals in html format)
        * debian/rules: Added suitable rules for r-mathlib and r-doc-html
        * debian/rules: Rewritten/cleaned for DH_COMPAT=3
      
      r-base (1.3.1-4) unstable; urgency=low
      
        * debian/control: Corrected maintainer email
        * debian/rules: Do not run 'make check' on arm as it stumbles over the
          Bessel example; this known misfeature has long been reported upstream
        * debian/README.Atlas: Updated to reflect autoMAGIC loading of Atlas lib
          with ldconfig from libc6_2.2.4-5 or later -- thanks, Ben Collins!
      
      r-base (1.3.1-3) unstable; urgency=low
      
        * New maintainer
        * debian/rules: Substitute -lg2c-pic for -lg2c in Makeconf [Thanks, Jeff!]
        * debian/control: Following advice from the Release Manager, let r-doc-pdf
          and r-base-dev be Arch: any as they Depends: on r-base itself 
        * debian/rules: configure with tkConfig.sh,tclConfig.sh for 8.3 support
        * debian/control: Build-Depends on tcl8.3-dev and tk8.3-dev
        * debian/rules: Let ia64 use gcc-3.0, g77-3.0, g++-3.0
        * debian/control: Build-Depends adjusted accordingly
      
      r-base (1.3.1-2) unstable; urgency=low
      
        * Non-maintainer upload, coordinated with the maintainer
        * Fixed local teTeX issue so that pdf manuals are built (Closes: #112184)
        * debian/*.links: link r-doc-pdf, r-gnome, r-base-dev doc dir to r-base
        * debian/*.preinst: rm doc dir for r-doc-pdf, r-gnome, r-base-dev 
        * debian/control: r-base-dev and r-doc-pdf now depend on r-base
      
      r-base (1.3.1-1) unstable; urgency=low
      
        * Non-maintainer upload, coordinated with the maintainer
        * Upgraded to new upstream release 1.3.1
        * src/scripts/R.sh.in: Modified to detect libs from /etc/ld.so.conf so
          that Atlas is now used automatically when installed, providing very
          significant performance gains. Thanks for Kurt Hornik for the sed magic. 
        * debian/control: Build-Depends for f2c on m68k, g77 everywhere else
        * debian/rules: Use f2c on m68k, g77 everywhere else
        * debian/rules: Compile with -O on m68k, -O2 everywhere else. Thanks 
          to Christian Steigies for countless m68k tests and compilations 
        * debian/r-base.lintian: Added Lintian excpeptions clauses:
          -- for files not under md5sum creation as their content changes
          -- for spurious 'extra license' on license() command documentation
        * debian/rules: Also remove redundant /usr/lib/R/COPYING.LIB, but add
          soft links for both GPL (to COPYING) and LGPL (to COPYING.LIB)
      
      r-base (1.3.0-4) unstable; urgency=low
      
        * Non-maintainer brown-bag release
        * debian/control: Revert back to tcl and tk version 8.0
        * debian/rules: Split off distinct configure and make targets
      
      r-base (1.3.0-3) unstable; urgency=low
      
        * Non-maintainer upload, coordinated with the maintainer
        * debian/rules: Default to --with-blas=blas (available on 9 architectures), 
          Atlas can dynamically override this where available (Closes: #105366)
        * debian/control: Changed atlas reference to blas for Build-Depends,
          requires versioned Build-Depends on blas-dev (>= 1.0-9) 
        * debian/rules: Added link for manual below r-base/doc (Closes: #106315)
        * debian/control: Upgraded Build-Depends: on tk and tcl to versions 8.3
        * debian/control: Upgraded Standards-Version: to 3.5.0
        * debian/control: Added r-recommended to Suggests:
        * debian/rules: Remove modules/*.so on clean
        * debian/README.Atlas: Added simple README file on Atlas
        * doc/manual/Makefile.in: Added --no-split to makeinfo --html calls
        * config.site: gcc-3.0 removed in -2 (Closes: #109030)
        * debian/control: Make was added to Depends in -2 (Closes: #102831)
      
      r-base (1.3.0-2) unstable; urgency=low
      
        * Changed compiler back to gcc from gcc-3.0
        * Added dependency of r-base-dev on make (Closes: #102831)
        * Removed dependency of r-base-dev on wget|lynx
      
      r-base (1.3.0-1) unstable; urgency=low
      
        * New upstream release
        * Changed build-depends on groff to groff-base
        * Changed build of r-gnome package for R's new module architecture
        * Added Dirk E.'s changes to rules and control so atlas is used only on
          selected architectures.
      
      r-base (1.2.3-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (1.2.2-2) unstable; urgency=low
      
        * Corrected format of Closes line (see 1.2.2-1). (Closes: #83876)
        * Added more build-depends entries.  (Closes: #89267)
      
      r-base (1.2.2-1) unstable; urgency=low
      
        * New upstream release.
        * Added build-depends entries. (Closes #83876)
      
      r-base (1.2.1-1) unstable; urgency=low
      
        * New upstream release.
      
      r-base (1.2.0-1) unstable; urgency=low
      
        * New upstream release.
        * Added the r-base-dev package to create the correct dependencies for
          installing R packages from CRAN (Comprehensive R Archive Network)
      
      r-base (1.1.0-1) unstable; urgency=low
      
        * New upstream release.
      
      r-base (1.0.1-1) unstable; urgency=low
      
        * New upstream release.
        * Includes fix for problem with xaxt and yaxt (Closes #61984)
      
      r-base (1.0.0-2) unstable; urgency=low
      
        * The pdf documentation is now in a new package r-doc-pdf
        * A GNOME-enabled version is available in a new package r-gnome (Closes #44503)
        * debian/{rules,control}: Modified accordingly
        * Thanks to Dirk Eddelbuettel who did most of the work for this.
      
      r-base (1.0.0-1) unstable; urgency=low
      
        * New upstream version
        * Fixed names of info files, readline support (Closes: #57774)
        * Added pdf files to doc directory (Closes: #20227)
      
      r-base (0.99.0-2) unstable; urgency=low
      
        * Small but important bug fixes in upstream sources
        * Removed dependence on atlas2 - using blas1 instead
        * Recompiled to use the readline library
      
      r-base (0.99.0-1) unstable; urgency=low
      
        * New upstream release
        * Added creation and installation of info documentation
        * Created the PDF documentation and added it to the doc directory
        * Added dependence on the atlas2 package and used the atlas blas
        * Added /usr/bin/X11 to the path before configuring so imake is found
      0d2098a5
    • Dirk Eddelbuettel's avatar
      Import Upstream version 1.5.1 · 68a3b27a
      Dirk Eddelbuettel authored
      68a3b27a
    • Douglas Bates's avatar
      Import Debian changes 0.90.1-2 · dc9881d4
      Douglas Bates authored
      r-base (0.90.1-2) unstable; urgency=low
      
        * re-created i386 package with proper libreadlineg2 dependency (Closes: #53206)
      
      r-base (0.90.1-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.90.0-2) unstable; urgency=low
      
        * added Conflicts: r-cran in control (Closes: #51673)
        * Reinstated -Xfoo flags in call to dh_md5sums for Bug#35744
        * Set up --mandir so package builds with -rfakeroot (Closes: #51901)
        * Undid Dirk's marking of Rd2txt.1 Rdindex.1 Sd2Rd.1 as undocumented
          (the manual pages are symbolic links to the Rdconv.1 page)
      
      r-base (0.90.0-1) unstable; urgency=low
      
        * Non-maintainer upload dealing with the usr/doc to usr/share/doc
          transition, as well as a  few other lintian errors and warnings 
        * debian/postinst: added #DEBHELPER# stub
        * debian/rules: configure with mandir=/usr/share/man
        * debian/rules: remove extra licenses 
        * debian/rules: also install docs BUGS PLATFORMS VERSION Y2K
        * debian/rules: mark Rd2txt.1 Rdindex.1 Sd2Rd.1 as undocumented
        * debian/dirs: change usr/doc to usr/share/doc
      
      r-base (0.90.0-0) unstable; urgency=low
      
        * new upstream release
        * Added a "suggests" entry in control for the ess package
      
      r-base (0.65.1-2) unstable; urgency=low
      
        * Changed from use of zip/unzip to minizip/miniunzip (Bug#48742)
      
      r-base (0.65.1-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.65.0-1) unstable; urgency=low
      
        * New upstream release
        * Added dependency on unzip package
      
      r-base (0.64.2-1) unstable; urgency=low
      
        * New upstream release
        * Changed dependency from perl to perl5 as per new policy.	
      
      r-base (0.64.1-1) unstable; urgency=low
      
        * New upstream release
        * Change definition of RHOME in /usr/lib/R/bin/R shell script (Bug#37339)
        * Add links so /usr/lib/R/doc/manual .tex files can be LaTeX'd (Hubert Palme)
        * Re-introduced md5sum's but with files that can change removed (Bug#35744)
        * Removed arbitrary --vsize and --nsize flags in R script.
      
      r-base (0.64.0-2) unstable; urgency=low
      
        * removed md5sums from control information (Bug#35744)
      
      r-base (0.64.0-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.63.3-2) unstable; urgency=low
      
        * Recompile for glibc2.1 to fix __setfpucw bug (Bug#34598)
      
      r-base (0.63.3-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.63.2-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.63.1-1) unstable; urgency=low
      
        * New upstream release
        * Linked html directory to /usr/doc/r-base/doc/html (Dirk Eddelbuettel)
      
      r-base (0.63.0-2) unstable; urgency=low
      
        * recompiled against libc6-dev_2.0.7u-6 for __register_frame_info fix
      
      r-base (0.63.0-1) unstable; urgency=low
      
        * New upstream release
      dc9881d4
    • Dirk Eddelbuettel's avatar
      Import Upstream version 0.90.1 · 89c43c41
      Dirk Eddelbuettel authored
      89c43c41
    • Douglas Bates's avatar
      Import Debian changes 0.62.4-2 · 1874f017
      Douglas Bates authored
      r-base (0.62.4-2) frozen; urgency=low, closes=26444
      
        * re-compilation to fix __register_frame_info problem introduced by old
          libraries (Bug #31028 and #31945)
      
      r-base (0.62.4-1) frozen unstable; urgency=low, closes=26444
      
        * New upstream release
        * Fixed link to html directory in /usr/doc (Bug#26444)
        * Check for /usr/bin/paperconf in postinst and set default R_PAPERSIZE (Bug#26447)
        * Remove src/lib directory in debian/rules clean (Bug#28545)
      
      r-base (0.62.3-0) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.62.2-2) unstable; urgency=low
      
        * Cleaned up the build process by removing redundancies in config.site
          and debian/rules.
        * Changed C compiler to gcc instead of egcs.
      
      r-base (0.62.2-1) unstable; urgency=low
      
        * Re-configured to include the readline library
      
      r-base (0.62.2-0) unstable; urgency=low
      
        * New upstream version
      
      r-base (0.62.1-2) unstable; urgency=low
      
        * Corrected definition of RHOME in /usr/bin/R (bug#23621)
        
        * Changed default heap size to 8 Mb. and number of cons cells to 400000
      
      r-base (0.62.1-1) unstable; urgency=low
      
        * new upstream release
      
      r-base (0.61.3-0) unstable; urgency=low
      
        * new upstream release
      1874f017
    • Dirk Eddelbuettel's avatar
      Import Upstream version 0.62.4 · 5c85c090
      Dirk Eddelbuettel authored
      5c85c090
    • Douglas Bates's avatar
      Import Debian changes 0.61.2-2 · c323226e
      Douglas Bates authored
      r-base (0.61.2-2) frozen unstable; urgency=low
      
        * recompiled against xlib6g (bug #21027)
      
      r-base (0.61.2-1) frozen unstable; urgency=low
      
        * Added symbolic link for /usr/lib/R/library in /usr/doc/r-base/ (bug#20190)
      
      r-base (0.61.2-0) unstable; urgency=low
      
        * New upstream release.
      
      r-base (0.61.1-5) unstable; urgency=low
      
        * Removed call to dh_du in build rules.
      
      r-base (0.61.1-4) unstable; urgency=low
      
        * Removed unnecessary call to dh_makeshlibs in build rules
      
      r-base (0.61.1-3) unstable; urgency=low
      
        * Re-compiled to add readline support.
      
      r-base (0.61.1-2) unstable; urgency=low
      
        * Ensured that libraries for the modules are dynamically linked.
      
      r-base (0.61.1-1) unstable; urgency=low
      
        * New upstream release
      
      r-base (0.61.0-3) unstable; urgency=low
      
        * Went through all the warnings reported by -Wall to produce a patch
          file for the developers.
        * Applied Thomas Lumley's patch for problem with c() applied to ordered.
        * Changed debian/rules to delete the .in files for autoconf from the
          package
        
        * Changed priority to "optional"
        * Modified to use pristine original sources.
      
      r-base (0.61.0-2) unstable; urgency=low
      
        * Modified the format of the orig.tar.gz file
      
      r-base (0.61.0-1) unstable; urgency=low
      
        * Initial release
      c323226e
    • Dirk Eddelbuettel's avatar
      Import Upstream version 0.61.2 · 87e1c683
      Dirk Eddelbuettel authored
      87e1c683