• Ximin Luo's avatar
    Import Debian changes 2.8.6-2 · 7ab82e9b
    Ximin Luo authored
    rpy2-2.8 (2.8.6-2) unstable; urgency=medium
    
      * Fork rpy2 source package at the last version that supported Python 2.
      * Disable python3 parts, use src:rpy2 (python3-rpy2) if you need that.
    
    rpy2 (2.8.6-1) unstable; urgency=medium
    
      * New upstream release
      
      * debian/control: Set (Build-)Depends: to current R version 
    
      * debian/python3-rpy2.lintian-overrides: Added
    
    rpy2 (2.8.5-1) unstable; urgency=medium
    
      * New upstream release
    
    rpy2 (2.8.4-1) unstable; urgency=medium
    
      * New upstream release
      
      * debian/control: Set (Build-)Depends: to current R version 
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.8.3-1) unstable; urgency=medium
    
      * New upstream release
    
    rpy2 (2.8.1-1) unstable; urgency=medium
    
      * New upstream release
    
    rpy2 (2.8.0-1) unstable; urgency=medium
    
      * New upstream release
    
      * debian/control: Set Standards-Version: to current version
     
      * debian/control: Remove Build-Depends: of libicu-dev now supplied by
        r-base-devs
    
    rpy2 (2.7.9-1) unstable; urgency=medium
    
      * New upstream release
      
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Add Build-Depends: of libicu-dev
    
    rpy2 (2.7.8-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.7.7-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.7.6-1) unstable; urgency=low
    
      * New upstream release
      
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.7.4-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.7.3-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.7.2-2) unstable; urgency=low
    
      * Applied patch by Matthias Klose to address implicit pointer
        conversion; patch has also been applied upstream (closes: #802978)
    
    rpy2 (2.7.2-1ubuntu1) xenial; urgency=medium
    
      * Avoid implicit pointer conversions.
    
    rpy2 (2.7.2-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.7.1-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.7.0-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.6.3-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.6.2-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.6.1-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.6.0-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.5.6-2) unstable; urgency=low
    
      * debian/control: Added python3-rpy2 entry and Build-Depends
      						      	(Closes: #782958)
      * debian/rules: Rewritten / simplified for current debhelper 9 scheme
      
      * debian/control: Removed unused Build-Depends for sphinx and latex
    
    rpy2 (2.5.6-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.5.5-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.5.4-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.5.3-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.5.1-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.5.0-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.4.4-1) unstable; urgency=low
    
      * New upstream release
      
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.4.3-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.4.2-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.4.1-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.4.0-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
      * debian/control: Added python-setuptools to Build-Depends
    
    rpy2 (2.3.10-1) unstable; urgency=low
    
      * New upstream release
      
      * debian/control: Updated homepage URL to bitbucket repo 
    
    rpy2 (2.3.9-3) unstable; urgency=low
    
      * setup.py: Improved approach for dealing with the more verbose string
        returned from R CMD config --ldflags; a new upstream release is
        pending too
    
    rpy2 (2.3.9-2) unstable; urgency=low
    
      * setup.py: Adapted to copy with more verbose string returned from
        R CMD config --ldflags following the change made in the r-base-core
        package; this way require additional work
    
    rpy2 (2.3.9-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.3.8-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.3.7-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version 
    
    rpy2 (2.3.6-1) unstable; urgency=low
    
      * New upstream version released today
    
    rpy2 (2.3.5-1) unstable; urgency=low
    
      * New upstream version released today
    
      * debian/control: Set (Build-)Depends: to current R version 
      
      * Building with R 3.0.0
    
    rpy2 (2.3.4-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.3.3-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
    
    rpy2 (2.3.1-2) unstable; urgency=low
    
      * debian/control: Adjust 'XS-Python-Version:' from 'all' to '>= 2.7' to
        no longer build for python2.6 			(Closes: #701113)
    
    rpy2 (2.3.1-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.3.0-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
    
    rpy2 (2.2.7-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.2.6-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.2.5-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.2.4-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
    
    rpy2 (2.2.2-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
    
    rpy2 (2.2.1-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.2.0-1) unstable; urgency=low
    
      * New upstream version released today
    
    rpy2 (2.2.0~20110522-1) unstable; urgency=low
    
      * Upgraded to latest upstream release candidate for RPython 2.2.0
      
      * debian/*: Updated to use new dh_python2 scheme	 (Closes: #617057)
      * debian/control: Remove Build-Depends: on python-central
      * debian/control: Set (Build-)Depends: to current R version
    
    rpy2 (2.1.9-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.1.8-1) unstable; urgency=low
    
      * New upstream release
      
      * debian/control: Set (Build-)Depends: to current R version
      
      * debian/control: Changed to Architecture: any
      * debian/control: Added Depends: on ${shlibs:Depends}
    
    rpy2 (2.1.5-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.1.4-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Set Standards-Version: to current version 
    
    rpy2 (2.1.3-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.1.2-2) unstable; urgency=low
    
      * rpy/rinterface/rpy_interface.h: Applied patch by Danis Barbier based
        on http://www.python.org/dev/peps/pep-3123/ that helps with Python 2.5
    
      * debian/rules: Reinstate the Python 2.5 build
    
    rpy2 (2.1.2-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/rules: For the time being, and on the recommendation from the
        upstream author, we are suspending python2.5 builds. rpy2 is under
        active  development, but upstream does no longer look at python 2.4 and 
        2.5 build issues. If this of importance to users, help in debugging 
        the build issues would be appreciated upstream.	(Closes: #582505)
    
      * debian/rules: Add 'set -e;' before 'for python...'	(Closes: #582509)
    
    rpy2 (2.1.1-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.1.0-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.1.0~20100401-1) unstable; urgency=low
    
      * First rc release rpy2-2.1.0rc of upcoming 2.1.0 release
    
    rpy2 (2.1.0~20100314-1) unstable; urgency=low
    
      * Second beta release rpy2-2.1.0beta2 of upcoming 2.1.0 release
    
    rpy2 (2.1.0~20100313-1) unstable; urgency=low
    
      * Second beta release rpy2-2.1.0beta of upcoming 2.1.0 release
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Set Standards-Version: to current version 
      
      * debian/rules: Disabled building and installing documentation not 
        included in this beta release
    
    rpy2 (2.0.8-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
    
    rpy2 (2.0.7-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.0.6-2) unstable; urgency=low
    
      * Rebuilt under R 2.9.2
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Upgraded Standards-Version: to current version
    
      * debian/watch: Updated to qa.debian.org redirector for sf.net
    
    rpy2 (2.0.6-1) unstable; urgency=low
    
      * New upstream release
    
    rpy2 (2.0.5-1) unstable; urgency=low
    
      * New upstream release
    
      * debian/control: Set (Build-)Depends: to current R version
      * debian/control: Set Standards-Version: to current version 3.8.2
    
    rpy2 (2.0.4a-1) unstable; urgency=low
    
      * New upstream release correcting release errors by upstream
      * The 2.0.4a version number is Debian-specific as we cannot replace the
        tarball already uploaded as 2.0.4.
      
      * debian/control: Restored Builds-Depends for documentation
      
      * debian/control: Added graphviz to Build-Depends
    
    rpy2 (2.0.4-1) unstable; urgency=low
    
      * New upstream release
      
      * Documentation building is no longer supported upstream, but another
        tarball of html source is on sourceforge.  
    
      * Hence removed python-sphinx (>= 0.4.3), texlive-base,
        texlive-latex-base, texlive-latex-extra, texlive-latex-recommended,
        texlive-fonts-recommended from Build-Depends:
    
      * Upstream seems to have removed quite a bit of demos, examples and
        documentation.  Pity -- the sphinx-generated docs were great.
    
    rpy2 (2.0.3-2) unstable; urgency=low
    
      * Rebuilt under R 2.9.0
      
      * debian/control: Upgraded (Build-)Depends: to new R version
    
      * debian/control: Upgraded Standards-Version: 
    
    rpy2 (2.0.3-1) unstable; urgency=low
    
      * New upstream release
      
      * The tar.gz file at rpy.sf.net is incomplete, so we re-created a new tarball 
        off the repo obtained via 'hg clone http://bitbucket.org/lgautier/rpy2/'
    
      * debian/rules: Turned of 'latex' documentation build as sphinx dies.
        So sorry -- onlu html docs in this release.
    
    rpy2 (2.0.1-2) unstable; urgency=low
    
      * Second try uploading to Debian			(Closes: #507622)
    
      * debian/copyright: Added MPL as it is not in /usr/share/common-licenses
    
    rpy2 (2.0.1-1) unstable; urgency=low
    
      * New upstream version (taken as revision 712 from svn)
      
      * Initial upload to Debian 				(Closes: #507622)
    
      * debian/control: Added Build-Depends: on python-sphinx (>= 0.4.3) so that
        we can build the documentation. Thanks to Piotr for 0.4.3 in unstable!
    
    rpy2 (2.0.0-1) unstable; urgency=low
    
      * Initial Debianisation 
    7ab82e9b
Name
Last commit
Last update
..
PKG-INFO Loading commit data...
SOURCES.txt Loading commit data...
dependency_links.txt Loading commit data...
requires.txt Loading commit data...
top_level.txt Loading commit data...