Commit 383592b4 authored by Cedric Bail's avatar Cedric Bail

eo: eo is absolutely necessary by now, can't be disabled any more.

parent 0ed0d796
......@@ -25,6 +25,9 @@ EFL_API_LEGACY_DEF="#define EFL_NOLEGACY_API_SUPPORT"
EFL_API_EO_DEF="#define EFL_EO_API_SUPPORT"
efl_api="both"
#### For the moment the Eo EFL API is not ready you need to explicitely optin.
EFL_ENABLE_EO_API_SUPPORT
AC_ARG_WITH([api],
[AC_HELP_STRING([--with-api=@<:@eo/legacy/both@:>@], [Select the EFL API Model @<:@default=both@:>@])],
[efl_api=${withval}],
......
dnl use: EFL_ENABLE_EO_API_SUPPORT
AC_DEFUN([EFL_ENABLE_EO_API_SUPPORT],
[
AC_DEFINE([EFL_EO_API_SUPPORT], [1], [Enable access to unstable EFL Eo API])
])
......@@ -7,7 +7,10 @@
*/
#ifndef EFL_API_OVERRIDE
@EFL_API_LEGACY_DEF@
@EFL_API_EO_DEF@
/* You can't disable Eo API anymore as EFL use it everywhere internally
and we don't want to expose it publicly just yet, so keep it hidden
and require an explicit request to get it. */
/* @EFL_API_EO_DEF@ */
#endif
#endif
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment