Commit d4c718df authored by Florian Schlichting's avatar Florian Schlichting

armel: tremor requires disabling both vorbis and vorbisenc

parent 5ad5fe3d
mpd (0.21.5-3) unstable; urgency=medium
* armel: tremor requires disabling both vorbis and vorbisenc
-- Florian Schlichting <fsfs@debian.org> Mon, 25 Feb 2019 21:36:39 +0100
mpd (0.21.5-2) unstable; urgency=medium
* Drop checks for arm and armeb architectures, these are no longer in use
......
#!/usr/bin/make -f
include /usr/share/dpkg/architecture.mk
WITH_SHINE_VORBIS_TREMOR=-Dshine=disabled -Dvorbis=enabled -Dtremor=disabled
WITH_SHINE_VORBIS_TREMOR=-Dshine=disabled -Dvorbis=enabled -Dvorbisenc=enabled -Dtremor=disabled
ifeq ($(DEB_HOST_ARCH), armel)
WITH_SHINE_VORBIS_TREMOR=-Dshine=enabled -Dvorbis=disabled -Dtremor=enabled
WITH_SHINE_VORBIS_TREMOR=-Dshine=enabled -Dvorbis=disabled -Dvorbisenc=disabled -Dtremor=enabled
endif
# no systemd and no alsa on non-linux arches
......@@ -96,9 +96,8 @@ ENABLE_PLAYBACKS=-Dfifo=true \
-Dshout=enabled
# Streaming encoder support
# Note: FLAC and Opus enabled under file formats
# Note: FLAC and Opus enabled under file formats, vorbisenc at top (!tremor)
ENABLE_ENCODERS=-Dlame=enabled \
-Dvorbisenc=enabled \
-Dtwolame=disabled \
-Dwave_encoder=true \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment