Commit 5ff3d4a1 authored by Mattias Ellert's avatar Mattias Ellert

Switch upstream to Grid Community Toolkit

First Grid Community Toolkit release
Move VCS to salsa.debian.org
parent 8071b049
This package is part of the Grid Security Infrastructure in C (GSI C) component
of the Globus Toolkit. For more information visit:
of the Grid Community Toolkit. For more information visit:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/
https://gridcf.org/gct-docs/gsic/
Key Concepts:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/key/
https://gridcf.org/gct-docs/gsic/key/
Admin Guide:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/admin/
https://gridcf.org/gct-docs/gsic/admin/
User's Guide:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/user/
https://gridcf.org/gct-docs/gsic/user/
Developer's Guide:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/developer/
https://gridcf.org/gct-docs/gsic/developer/
Release Notes:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/rn/
https://gridcf.org/gct-docs/gsic/rn/
Public Interface Guide:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/pi/
https://gridcf.org/gct-docs/gsic/pi/
Quality Profile:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/qp/
https://gridcf.org/gct-docs/gsic/qp/
Migrating Guide:
http://toolkit.globus.org/toolkit/docs/latest-stable/gsic/mig/
https://gridcf.org/gct-docs/gsic/mig/
globus-authz-callout-error (4.0-1) unstable; urgency=medium
* Switch upstream to Grid Community Toolkit
* First Grid Community Toolkit release
* Move VCS to salsa.debian.org
-- Mattias Ellert <mattias.ellert@physics.uu.se> Sun, 16 Sep 2018 03:16:31 +0200
globus-authz-callout-error (3.6-2) unstable; urgency=medium
* Migrate to dbgsym packages
......
Source: globus-authz-callout-error
Priority: optional
Maintainer: Mattias Ellert <mattias.ellert@physics.uu.se>
Build-Depends: debhelper (>= 9), dh-autoreconf, pkg-config, libglobus-common-dev (>= 15), doxygen, graphviz
Standards-Version: 4.0.0
Build-Depends: debhelper (>= 9), dh-autoreconf, pkg-config, libglobus-common-dev (>= 15), doxygen
Standards-Version: 4.2.1
Section: net
Vcs-Browser: http://svn.nordugrid.org/trac/packaging/browser/debian/globus-authz-callout-error
Vcs-Svn: http://svn.nordugrid.org/repos/packaging/debian/globus-authz-callout-error
Homepage: http://toolkit.globus.org/
Vcs-Browser: https://salsa.debian.org/ellert/globus-authz-callout-error
Vcs-Git: https://salsa.debian.org/ellert/globus-authz-callout-error.git
Homepage: https://github.com/gridcf/gct/
Package: libglobus-authz-callout-error0
Section: libs
......@@ -14,12 +14,12 @@ Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Globus Toolkit - Globus authz error library
The Globus Toolkit is an open source software toolkit used for
building Grid systems and applications. It is being developed by the
Globus Alliance and many others all over the world. A growing number
of projects and companies are using the Globus Toolkit to unlock the
potential of grids for their cause.
Description: Grid Community Toolkit - Globus authz error library
The Grid Community Toolkit (GCT) is an open source software toolkit used for
building grid systems and applications. It is a fork of the Globus Toolkit
originally created by the Globus Alliance. It is supported by the Grid
Community Forum (GridCF) that provides community-based support for core
software packages in grid computing.
.
The libglobus-authz-callout-error0 package contains:
Globus authz error library (used by globus authz callouts)
......@@ -29,13 +29,13 @@ Section: libdevel
Architecture: any
Multi-Arch: same
Depends: libglobus-authz-callout-error0 (= ${binary:Version}), ${misc:Depends}, libglobus-common-dev (>= 15)
Recommends: libglobus-authz-callout-error-doc (= ${source:Version})
Description: Globus Toolkit - Globus authz error library Development Files
The Globus Toolkit is an open source software toolkit used for
building Grid systems and applications. It is being developed by the
Globus Alliance and many others all over the world. A growing number
of projects and companies are using the Globus Toolkit to unlock the
potential of grids for their cause.
Suggests: libglobus-authz-callout-error-doc (= ${source:Version})
Description: Grid Community Toolkit - Globus authz error library Development Files
The Grid Community Toolkit (GCT) is an open source software toolkit used for
building grid systems and applications. It is a fork of the Globus Toolkit
originally created by the Globus Alliance. It is supported by the Grid
Community Forum (GridCF) that provides community-based support for core
software packages in grid computing.
.
The libglobus-authz-callout-error-dev package contains:
Globus authz error library (used by globus authz callouts) Development Files
......@@ -46,12 +46,12 @@ Architecture: all
Multi-Arch: foreign
Pre-Depends: dpkg (>= 1.17.5)
Depends: ${misc:Depends}
Description: Globus Toolkit - Globus authz error library Documentation Files
The Globus Toolkit is an open source software toolkit used for
building Grid systems and applications. It is being developed by the
Globus Alliance and many others all over the world. A growing number
of projects and companies are using the Globus Toolkit to unlock the
potential of grids for their cause.
Description: Grid Community Toolkit - Globus authz error library Documentation Files
The Grid Community Toolkit (GCT) is an open source software toolkit used for
building grid systems and applications. It is a fork of the Globus Toolkit
originally created by the Globus Alliance. It is supported by the Grid
Community Forum (GridCF) that provides community-based support for core
software packages in grid computing.
.
The libglobus-authz-callout-error-doc package contains:
Globus authz error library (used by globus authz callouts) Documentation Files
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: globus_authz_callout_error
Upstream-Contact: http://toolkit.globus.org/
Source: https://downloads.globus.org/toolkit/gt6/packages/globus_authz_callout_error-3.6.tar.gz
Upstream-Contact: https://github.com/gridcf/gct/
Source: https://repo.gridcf.org/gct6/sources/globus_authz_callout_error-4.0.tar.gz
Files: *
Copyright:
1999-2016 University of Chicago
2018 Grid Community Forum
License: Apache-2.0
Files: debian/*
Copyright:
2008-2017 Mattias Ellert <mattias.ellert@physics.uu.se>
2008-2018 Mattias Ellert <mattias.ellert@physics.uu.se>
2010-2013 Initiative for Globus in Europe (IGE), http://www.ige-project.eu/
License: Apache-2.0
......
Document: globus-authz-callout-error
Title: Debian globus-authz-callout-error Manual
Author: Globus Alliance
Abstract: The Globus toolkit, Globus authz error library (used by globus authz callouts)
Author: Globus Alliance and Grid Community Forum
Abstract: The Grid Community Toolkit, Globus authz error library (used by globus authz callouts)
Section: Programming
Format: HTML
......
# See /usr/share/doc/doxygen/README.jquery
embedded-javascript-library usr/share/doc/*/html/jquery.js *
# The package name is given by the upstream package name
# Changing it would confuse the users
package-name-doesnt-match-sonames libglobus-gsi-authz-callout-error0
# The dependencies are not missing - there are no dependencies
# False positive
shared-lib-without-dependency-information usr/lib/*/libglobus_gsi_authz_callout_error.so.*
......@@ -11,6 +11,7 @@ INSTALLDIR = $(CURDIR)/debian/tmp
_prefix = /usr
_bindir = $(_prefix)/bin
_sbindir = $(_prefix)/sbin
_includedir = $(_prefix)/include
_libdir = $(_prefix)/lib
_datadir = $(_prefix)/share
_mandir = $(_datadir)/man
......@@ -31,9 +32,8 @@ configure-stamp:
LDFLAGS="$(LDFLAGS) -Wl,--as-needed -Wl,-z,defs" \
dh_auto_configure -- \
--disable-static \
--sharedstatedir=/var/lib \
--includedir='$${prefix}/include/globus' \
--libexecdir='$${datadir}/globus' \
--includedir=$(_includedir)/globus \
--libexecdir=$(_datadir)/globus \
--docdir=$(_docdir)
# Reduce overlinking
......@@ -110,7 +110,6 @@ binary-indep: install
dh_install -i
dh_missing -i --fail-missing
dh_installman -i
dh_lintian -i
dh_link -i
dh_compress -i
dh_fixperms -i
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment