Commit 791901b2 authored by Jonas Bernoulli's avatar Jonas Bernoulli

Release version 2.90.1

parent a0512b80
* Magit v2.90.1 Release Notes
** Changes since v2.90.0
- Added ~bug-reference-mode~ to ~git-commit-setup-hook~. e19e8fb1e
- The "Version" column in ~magit-submodule-list-mode~ and
~magit-repolist-mode~ buffers now shows when a repository is dirty.
0b86dbfd6
- Added new command ~magit-log-merged~. This command requires
~git-when-merged~ (https://github.com/mhagger/git-when-merged). It
isn't bound in ~magit-log-popup~ by default. To add it, you can use
something like
#+BEGIN_SRC emacs-lisp
(magit-define-popup-action 'magit-log-popup
?m "Log commit's merge" 'magit-log-merged)
#+END_SRC
#3657
** Fixes since v2.90.0
- Bumped the minimal required version of ~git-commit~ to the correct
version. e9bd33758
- Dropped the new "v" prefix that we started to add to release tags
starting with the previous release in places where that prefix is
undesirable. f441cf6d7
- Staging and unstaging submodules while ~diff.submodule~'s value is ~log~
broke shortly before the v2.90.0 release. #3654
* Authors
10 Jonas Bernoulli
1 Allen Li
1 Kevin Brubeck Unhammer
1 Kyle Meyer
......@@ -2,8 +2,11 @@
** Breaking changes
** Changes since v2.90.0
- Added ~bug-reference-mode~ to ~git-commit-setup-hook~. e19e8fb1e
- The "Version" column in ~magit-submodule-list-mode~ and
~magit-repolist-mode~ buffers now shows when a repository is dirty.
0b86dbfd6
- Added new command ~magit-log-merged~. This command requires
~git-when-merged~ (https://github.com/mhagger/git-when-merged). It
......@@ -15,7 +18,16 @@
?m "Log commit's merge" 'magit-log-merged)
#+END_SRC
#3657
** Fixes since v2.90.0
- Bumped the minimal required version of ~git-commit~ to the correct
version. e9bd33758
- Dropped the new "v" prefix that we started to add to release tags
starting with the previous release in places where that prefix is
undesirable. f441cf6d7
- Staging and unstaging submodules while ~diff.submodule~'s value is ~log~
broke shortly before the v2.90.0 release. #3654
......@@ -8,7 +8,7 @@
#+TEXINFO_DIR_CATEGORY: Emacs
#+TEXINFO_DIR_TITLE: Magit: (magit).
#+TEXINFO_DIR_DESC: Using Git from Emacs with Magit.
#+SUBTITLE: for version 2.90.0 (v2.90.0-4-g13b32ae1c+1)
#+SUBTITLE: for version 2.90.1
#+BIND: ox-texinfo+-before-export-hook ox-texinfo+-update-version-strings
#+TEXINFO_DEFFN: t
......@@ -23,7 +23,7 @@ directly from within Emacs. While many fine Git clients exist, only
Magit and Git itself deserve to be called porcelains.
#+TEXINFO: @noindent
This manual is for Magit version 2.90.0 (v2.90.0-4-g13b32ae1c+1).
This manual is for Magit version 2.90.1.
#+BEGIN_QUOTE
Copyright (C) 2015-2018 Jonas Bernoulli <jonas@bernoul.li>
......
......@@ -31,7 +31,7 @@ General Public License for more details.
@finalout
@titlepage
@title Magit User Manual
@subtitle for version 2.90.0 (v2.90.0-4-g13b32ae1c+1)
@subtitle for version 2.90.1
@author Jonas Bernoulli
@page
@vskip 0pt plus 1filll
......@@ -53,7 +53,7 @@ directly from within Emacs. While many fine Git clients exist, only
Magit and Git itself deserve to be called porcelains.
@noindent
This manual is for Magit version 2.90.0 (v2.90.0-4-g13b32ae1c+1).
This manual is for Magit version 2.90.1.
@quotation
Copyright (C) 2015-2018 Jonas Bernoulli <jonas@@bernoul.li>
......
Documentation/RelNotes/2.91.0.org
\ No newline at end of file
Documentation/RelNotes/2.90.1.org
\ No newline at end of file
......@@ -11,7 +11,7 @@
;; Marius Vollmer <marius.vollmer@gmail.com>
;; Maintainer: Jonas Bernoulli <jonas@bernoul.li>
;; Package-Requires: ((emacs "25.1") (dash "20180910") (with-editor "20181103"))
;; Package-Requires: ((emacs "25.1") (dash "2.14.1") (with-editor "2.8.0"))
;; Keywords: git tools vc
;; Homepage: https://github.com/magit/magit
......
(define-package "magit" "2.90.0"
(define-package "magit" "2.90.1"
"A Git porcelain inside Emacs."
'((emacs "25.1")
(async "20180527")
(dash "20180910")
(ghub "20181107")
(git-commit "20181104")
(magit-popup "20181003")
(with-editor "20181103")))
(async "1.9.3")
(dash "2.14.1")
(ghub "3.0.0")
(git-commit "2.90.0")
(magit-popup "2.12.4")
(with-editor "2.8.0")))
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment