Commit b8133ab8 authored by Jonas Bernoulli's avatar Jonas Bernoulli

magit-pkg.el: Update minimal Emacs version

Also do so in git-commit.el's header.
parent a8106b60
......@@ -190,14 +190,14 @@ define set_package_requires
(re-search-forward "^;; Package-Requires: ")
(delete-region (point) (line-end-position))
(insert (format "%S"
`((emacs "24.4") ;`
`((emacs ,emacs-version) ;`
(dash ,dash-version)
(with-editor ,with-editor-version))))
(with-temp-file "lisp/magit-pkg.el"
(insert (pp-to-string
`(define-package "magit" "$(VERSION)" ;`
"A Git porcelain inside Emacs."
'((emacs "24.4") ;'
'((emacs ,emacs-version) ;'
(async ,async-version)
(dash ,dash-version)
(ghub ,ghub-version)
......@@ -214,6 +214,7 @@ export set_package_requires
bump-versions: bump-versions-1 texi
bump-versions-1:
@$(BATCH) --eval "(let (\
(emacs-version \"$(EMACS_VERSION)\")\
(async-version \"$(ASYNC_VERSION)\")\
(dash-version \"$(DASH_VERSION)\")\
(ghub-version \"$(GHUB_VERSION)\")\
......@@ -224,6 +225,7 @@ bump-versions-1:
bump-snapshots:
@$(BATCH) --eval "(let (\
(emacs-version \"$(EMACS_VERSION)\")\
(async-version \"$(ASYNC_MELPA_SNAPSHOT)\")\
(dash-version \"$(DASH_MELPA_SNAPSHOT)\")\
(ghub-version \"$(GHUB_MELPA_SNAPSHOT)\")\
......
......@@ -11,7 +11,7 @@
;; Marius Vollmer <marius.vollmer@gmail.com>
;; Maintainer: Jonas Bernoulli <jonas@bernoul.li>
;; Package-Requires: ((emacs "24.4") (dash "20180413") (with-editor "20180414"))
;; Package-Requires: ((emacs "25.1") (dash "20180413") (with-editor "20180414"))
;; Keywords: git tools vc
;; Homepage: https://github.com/magit/magit
......
(define-package "magit" "2.13.0"
"A Git porcelain inside Emacs."
'((emacs "24.4")
'((emacs "25.1")
(async "20180527")
(dash "20180413")
(ghub "20180417")
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment