Commit 94b52030 authored by USAMI Kenta's avatar USAMI Kenta

Bump up version 1.22.0

parent 5bea485a
......@@ -2,6 +2,54 @@
All notable changes of the PHP Mode 1.19.1 release series are documented in this file using the [Keep a CHANGELOG](https://keepachangelog.com/) principles.
## [1.22.0] - 2019-09-27
This release is positioned as the last minor version of the PHP Mode 1.x series.
PHP Mode 2.0 is planned to be released in January 2020.
### Added
* Improve PHP 7 and PHPDoc support
* Highlighting typed property ([#545])
* Highlighting `{@inheritdoc}` tag ([#566])
* Highlighting multiple `catch` ([#567])
* Add new `php-class` face ([#545])
* Add new `php-run-builtin-web-server` command for invoke `php -S` buitin server ([#548])
* Add new `php-copyit-fqsen` command for kill current method FQSEN ([#561])
* Apply lineup cascaded call (method chain separated by new line) for all styles ([#563], [#572])
### Changed
* Loose HTML template detection algorithm ([#558])
* Move php-mode-test.el into tests directory ([#559])
* `php-mode-autoloads.el` no longer includes `php-mode-test`
* Modify syntax-entry `$` to `"_"` from `"'"` ([#565])
* Make `php-set-style` display only styles that inherited "php" ([#573])
### Fixed
* Fix default major mode for `*.phpt` file as `php-default-major-mode` ([#542])
* prevent recursion in `php-syntax-propertize-extend-region` ([$556], thanks [Herbert Jones][@herbertjones])
* Fix call `run-hooks` in `set-style` ([#571])
[#542]: https://github.com/emacs-php/php-mode/pull/542
[#545]: https://github.com/emacs-php/php-mode/pull/545
[#548]: https://github.com/emacs-php/php-mode/pull/548
[#556]: https://github.com/emacs-php/php-mode/pull/556
[#558]: https://github.com/emacs-php/php-mode/pull/558
[#559]: https://github.com/emacs-php/php-mode/pull/559
[#561]: https://github.com/emacs-php/php-mode/pull/561
[#563]: https://github.com/emacs-php/php-mode/issues/563
[#565]: https://github.com/emacs-php/php-mode/pull/565
[#566]: https://github.com/emacs-php/php-mode/pull/566
[#567]: https://github.com/emacs-php/php-mode/pull/567
[#571]: https://github.com/emacs-php/php-mode/pull/571
[#572]: https://github.com/emacs-php/php-mode/pull/572
[#572]: https://github.com/emacs-php/php-mode/pull/572
[#573]: https://github.com/emacs-php/php-mode/pull/573
[#556]: https://github.com/emacs-php/php-mode/pull/556
[@herbertjones]: https://github.com/herbertjones
## [1.21.4] - 2019-05-29
This version contains unobtrusive changes for future compatibility. Also, `forward-page` /` backward-page` may improve your operation. Thank you [@takeokunn].
......
(package "php-mode" "1.21.3" "Major mode for editing PHP code")
(package "php-mode" "1.22.0" "Major mode for editing PHP code")
(source melpa)
(package-file "php.el")
......
......@@ -4,7 +4,7 @@
;; Author: USAMI Kenta <tadsan@zonu.me>
;; Created: 5 May 2019
;; Version: 1.21.4
;; Version: 1.22.0
;; Keywords: faces, php
;; Homepage: https://github.com/emacs-php/php-mode
;; Package-Requires: ((emacs "24.3"))
......
......@@ -5,7 +5,7 @@
;; Author: USAMI Kenta <tadsan@zonu.me>
;; URL: https://github.com/emacs-php/php-mode
;; Keywords: maint
;; Version: 1.21.4
;; Version: 1.22.0
;; Package-Requires: ((emacs "24.3"))
;; License: GPL-3.0-or-later
......
......@@ -9,11 +9,11 @@
;; Maintainer: USAMI Kenta <tadsan@zonu.me>
;; URL: https://github.com/emacs-php/php-mode
;; Keywords: languages php
;; Version: 1.21.4
;; Version: 1.22.0
;; Package-Requires: ((emacs "24.3"))
;; License: GPL-3.0-or-later
(defconst php-mode-version-number "1.21.4"
(defconst php-mode-version-number "1.22.0"
"PHP Mode version number.")
(defconst php-mode-modified "2019-05-29"
......
......@@ -5,7 +5,7 @@
;; Author: USAMI Kenta <tadsan@zonu.me>
;; Keywords: tools, files
;; URL: https://github.com/emacs-php/php-mode
;; Version: 1.21.4
;; Version: 1.22.0
;; Package-Requires: ((emacs "24.3"))
;; License: GPL-3.0-or-later
......
......@@ -4,7 +4,7 @@
;; Author: USAMI Kenta <tadsan@zonu.me>
;; Created: 5 Dec 2018
;; Version: 1.21.4
;; Version: 1.22.0
;; Keywords: languages, php
;; Homepage: https://github.com/emacs-php/php-mode
;; Package-Requires: ((emacs "24.3"))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment