...
 
Commits (9)
dnscrypt-proxy (2.0.19+ds1-2) unstable; urgency=medium
* debhelper-compat = 12
* Add standard ci file for salsa gitlab
* Add Rules-Requires-Root: no
* Remove article from package description
* Add version to dnscrypt-proxy-plugins Breaks
* Standards-Version to 4.3.0.1
* Add not-installed file for usr/share/gocode/src/*
* Disable dh_dwz since it fails
-- Eric Dorland <eric@debian.org> Thu, 17 Jan 2019 02:24:45 -0500
dnscrypt-proxy (2.0.19+ds1-1) unstable; urgency=medium
* New upstream release
......
......@@ -2,7 +2,7 @@ Source: dnscrypt-proxy
Section: net
Priority: optional
Maintainer: Eric Dorland <eric@debian.org>
Build-Depends: debhelper (>= 11),
Build-Depends: debhelper-compat (= 12),
dh-golang,
golang-ed25519-dev,
golang-github-aead-chacha20-dev,
......@@ -31,7 +31,8 @@ Build-Depends: debhelper (>= 11),
golang-golang-x-sys-dev,
golang-golang-x-text-dev,
golang-gopkg-natefinch-lumberjack.v2-dev
Standards-Version: 4.1.5
Standards-Version: 4.3.0.1
Rules-Requires-Root: no
Homepage: https://github.com/jedisct1/dnscrypt-proxy
Vcs-Git: https://salsa.debian.org/eric/dnscrypt-proxy.git
Vcs-Browser: https://salsa.debian.org/eric/dnscrypt-proxy
......@@ -42,7 +43,7 @@ Multi-Arch: foreign
Depends: adduser, lsb-base (>= 3.0-6), ${misc:Depends}, ${shlibs:Depends}
Built-Using: ${misc:Built-Using}
Suggests: resolvconf
Breaks: dnscrypt-proxy-plugins
Description: A flexible DNS proxy, with support for encrypted DNS protocols
Breaks: dnscrypt-proxy-plugins (<< 2)
Description: Flexible DNS proxy, with support for encrypted DNS protocols
dnscrypt-proxy is a flexible DNS proxy, with support for modern encrypted DNS
protocols such as DNSCrypt v2 and DNS-over-HTTPS.
include: https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/salsa-ci.yml
build:
extends: .build-unstable
reprotest:
extends: .test-reprotest
lintian:
extends: .test-lintian
autopkgtest:
extends: .test-autopkgtest
piuparts:
extends: .test-piuparts
usr/share/gocode/src/*
......@@ -21,3 +21,5 @@ override_dh_auto_install:
# Tests may fail on build servers and aren't useful in release builds anyway
override_dh_auto_test:
# dwz appears to choke on dnscrypt-proxy at the moment
override_dh_dwz: