Commit 1264f038 authored by felix s's avatar felix s

Muntze changelog more.

parent 216f66cb
......@@ -3,13 +3,15 @@ gnucap (1:0.36~20171003-1) unstable; urgency=medium
* Split gnucap package into several packages
This is required, as gnucap now provides a shared library.
* libgnucap0 + libgnucap-dev (Closes: #224467)
These packages contain the shared library and provide the files neccesary
These packages contain the shared library and provide the files neccesary
to build/link against it, respectively. For example users can create their
own binary programs to subtitute the "gnucap" example executable provided
in the "gnucap" package. Other packages may depend on libgnucap-dev, if
they make use ob the gnucap library.
* split off gnucap-default-plugins0 package
The plugins that were linked into the main executable previously are now
they make use of the gnucap library, which will provide most gnucap
functionality without the need to install all gnucap packages and files.
(Closes: #224467)
* Introduce gnucap-default-plugins0 package
The plugins that were linked into the main executable previously are now
shipped as a separate (optional) binary, the "default plugins". These are
loaded by "gnucap", unless overridden in /etc/gnucap.rc (which is does not
exist by default). This package must hence be installed, if the
......@@ -17,10 +19,10 @@ gnucap (1:0.36~20171003-1) unstable; urgency=medium
The binary plugin is installed in a directory depending on the
architecture and on the library soname it has been tested against. Further
binary plugins should also be installed into this directory. The default
command for loading plugins uses the GNUCAP_PLUGPATH environment
command for loading plugins uses the GNUCAP_PLUGPATH environment
variable to locate plugins, a colon separated list of paths.
* gnucap-common package (Closes: #693267)
The headers are required, if plugins need to be compiled from within a
The headers are required, if plugins need to be compiled from within a
gnucap session, also for the purpose of libgnucap-dev, above. Further, these
headers are architecture independent. Hence this additional package.
None of the functionality supplied was present in previous packages.
......@@ -28,7 +30,7 @@ gnucap (1:0.36~20171003-1) unstable; urgency=medium
upstream project makes no attempt in providing these, hence they are
maintained here.
* get-orig-source target, snapshotting upstream git
There are no release tarballs, just tags, nowadays. these are equivalent
There are no release tarballs, just tags, nowadays. these are equivalent
to releases ("development snapshots"). This is new and was not required for
previous tarball releases.
* set sysconfdir to /etc, equivalent to --sysconfdir in autotools.
......@@ -55,7 +57,7 @@ gnucap (1:0.36~20171003-1) unstable; urgency=medium
(Closes: #759987, #831480)
* adding a lintian override for http URL in watch file
Lintian is complaining about the usage of http:// instead of https:// on
the URL http://gnucap.org/archive/ in watch, a file for automatic checking
the URL http://gnucap.org/archive/ in watch, a file for automatic checking
for new upstream versions.
gnucap.org isn't using the https protocol (yet or never will) and we need
to use http here. Note that tarball releases are currently suspended, and
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment