Commit 9ed33fd0 authored by Gaurav Mishra's avatar Gaurav Mishra 🐼

Merge branch 'chore/ci/drop-jessie' into 'master'

chore(ci): Drop builds for Jessie

See merge request !23
parents e3734916 7a252535
Pipeline #50364 passed with stages
in 28 minutes and 24 seconds
......@@ -74,42 +74,42 @@ stages:
mkdir packages
cp ../*.deb packages/
.jessie_services: &jessie_services
services:
- name: postgres:9.4
alias: localhost
.stretch_services: &stretch_services
services:
- name: postgres:9.6
alias: localhost
ctest:jessie:
image: registry.salsa.debian.org/salsa-ci-team/images/base:jessie
<<: *jessie_services
<<: *c_test_template
.unstable_services: &unstable_services
services:
- name: postgres:11
alias: localhost
ctest:stretch:
image: registry.salsa.debian.org/salsa-ci-team/images/base:stretch
<<: *stretch_services
<<: *c_test_template
phptest:jessie:
image: registry.salsa.debian.org/salsa-ci-team/images/base:jessie
<<: *jessie_services
<<: *php_test_template
ctest:unstable:
image: registry.salsa.debian.org/salsa-ci-team/images/base:unstable
<<: *unstable_services
<<: *c_test_template
phptest:stretch:
image: registry.salsa.debian.org/salsa-ci-team/images/base:stretch
<<: *stretch_services
<<: *php_test_template
build:jessie:
image: registry.salsa.debian.org/salsa-ci-team/images/dockerbuilder:jessie
phptest:unstable:
image: registry.salsa.debian.org/salsa-ci-team/images/base:unstable
<<: *unstable_services
<<: *php_test_template
build:unstable:
image: registry.salsa.debian.org/salsa-ci-team/images/dockerbuilder:unstable
<<: *build_template
script:
- git pull -q --no-edit origin chore/ppa-changes
- git pull -q --no-edit origin chore/debian/jessie
- git pull -q --no-edit origin chore/debian/unstable
- *build_scripts
build:stretch:
......
......@@ -68,7 +68,7 @@ fi
# figure out what distro we're on
DISTRO=$(lsb_release --id --short)
CODENAME=$(lsb_release --codename --short)
CODENAME=$(get_lsb_codename)
########################################################################
......
......@@ -68,7 +68,7 @@ fi
# figure out what distro we're on
DISTRO=$(lsb_release --id --short)
CODENAME=$(lsb_release --codename --short)
CODENAME=$(get_lsb_codename)
########################################################################
......
......@@ -89,7 +89,7 @@ fi
# figure out what distro we're on
DISTRO=$(lsb_release --id --short)
CODENAME=$(lsb_release --codename --short)
CODENAME=$(get_lsb_codename)
########################################################################
......@@ -106,10 +106,8 @@ if [[ $BUILDTIME ]]; then
case "$CODENAME" in
xenial)
apt-get $YesOpt install php-mbstring php7.0-zip;;
stretch|buster|sid)
apt-get $YesOpt install php-mbstring php7.0-xml php7.0-zip;;
bionic)
apt-get $YesOpt install php-mbstring php7.2-xml php7.2-zip;;
stretch|buster|sid|bionic)
apt-get $YesOpt install php-mbstring php-xml php-zip;;
esac
if ! dpkg --get-selections | grep -q postgresql-server-dev; then ## if postgresql-server-dev is not installed
case "$CODENAME" in
......@@ -117,10 +115,12 @@ if [[ $BUILDTIME ]]; then
apt-get $YesOpt install postgresql-server-dev-9.4;;
xenial)
apt-get $YesOpt install postgresql-server-dev-9.5;;
stretch|buster|sid)
stretch|buster)
apt-get $YesOpt install postgresql-server-dev-9.6;;
bionic)
apt-get $YesOpt install postgresql-server-dev-10;;
sid)
apt-get $YesOpt install postgresql-server-dev-11;;
*) echo "ERROR: Unknown or Unsupported $DISTRO $CODENAME release, please report to the mailing list"; exit 1;;
esac
fi
......@@ -168,10 +168,12 @@ if [[ $RUNTIME ]]; then
apt-get $YesOpt install postgresql-9.4 libapache2-mod-php5 php5 php5-pgsql php5-cli php5-curl heirloom-mailx libboost-program-options1.55.0 libboost-regex1.55.0;;
xenial)
apt-get $YesOpt install postgresql-9.5 php7.0 libapache2-mod-php7.0 php7.0-pgsql php7.0-cli php7.0-curl php7.0-mbstring php7.0-zip s-nail libboost-program-options1.58.0 libboost-regex1.58.0;;
stretch|buster|sid)
stretch|buster)
apt-get $YesOpt install postgresql-9.6 php7.0 php7.0-pgsql php7.0-cli php7.0-curl php7.0-xml php7.0-zip php-mbstring s-nail libboost-program-options1.62.0 libboost-regex1.62.0;;
bionic)
apt-get $YesOpt install postgresql-10 php7.2 php7.2-pgsql php7.2-cli php7.2-curl php7.2-xml php7.2-zip php7.2-mbstring s-nail libboost-program-options1.65.1 libboost-regex1.65.1;;
sid)
apt-get $YesOpt install postgresql-11 php7.3 php-pgsql php-cli php-curl php-xml php-zip php-mbstring s-nail libboost-program-options1.67.0 libboost-regex1.67.0;;
*) echo "ERROR: Unknown or Unsupported $DISTRO $CODENAME release, please report to the mailing list"; exit 1;;
esac
;;
......
......@@ -51,3 +51,11 @@ Usage: mod_deps [options]
-h or --help : this help text
EOF
}
get_lsb_codename() {
if egrep -q "^deb https?:\/\/.* (unstable|sid) .*$" /etc/apt/sources.list; then
echo "sid"
else
echo $(lsb_release --codename --short)
fi
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment