Commit 0a28894d authored by Joey Hess's avatar Joey Hess

releasing dtsa 14


git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@1957 e39458fd-73e7-0310-bf30-c45bca0a0e42
parent 0f0fc54e
......@@ -40,3 +40,6 @@
{CAN-2005-1751 CAN-2005-1921 CAN-2005-2498 }
- php4 4.3.10-16etch1
TODO: unreleased
[September 13th, 2005] DTSA-14-1 mozilla - several
{CAN-2004-0718 CAN-2005-1937 CAN-2005-2260 CAN-2005-2261 CAN-2005-2263 CAN-2005-2265 CAN-2005-2266 CAN-2005-2268 CAN-2005-2269 CAN-2005-2270 }
- mozilla 1.7.8-1sarge2
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head><meta http-equiv="Content-Type" content="text/html; charset=iso8859-1">
<title>Debian testing security team - Advisory</title>
<link type="text/css" rel="stylesheet" href="../style.css">
<link rel="shortcut icon" href="http://www.debian.org/favicon.ico">
</head>
<body>
<div align="center">
<a href="http://www.debian.org/">
<img src="http://www.debian.org/logos/openlogo-nd-50.png" border="0" hspace="0" vspace="0" alt=""></a>
<a href="http://www.debian.org/">
<img src="http://www.debian.org/Pics/debian.png" border="0" hspace="0" vspace="0" alt="Debian Project"></a>
</div>
<br />
<table class="reddy" width="100%">
<tr>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-upperleft.png" align="left" border="0" hspace="0" vspace="0"
alt="" width="15" height="16"></td>
<td rowspan="2" class="reddy">Debian testing security team - Advisory</td>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-upperright.png" align="right" border="0" hspace="0" vspace="0"
alt="" width="16" height="16"></td>
</tr>
<tr>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-lowerleft.png" align="left" border="0" hspace="0" vspace="0"
alt="" width="16" height="16"></td>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-lowerright.png" align="right" border="0" hspace="0" vspace="0"
alt="" width="15" height="16"></td>
</tr>
</table>
<!-- header -->
<h2>DTSA-14-1</h2>
<dl>
<dt>Date Reported:</dt>
<dd>September 13th, 2005</dd>
<dt>Affected Package:</dt>
<dd><a href='http://packages.debian.org/src:mozilla'>mozilla</a></dd>
<dt>Vulnerability:</dt>
<dd>several</dd>
<dt>Problem-Scope:</dt>
<dd>remote</dd>
<dt>Debian-specific:</dt>
<dd>No<br></dd>
<dt>CVE:</dt>
<dd>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0718'>CAN-2004-0718</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1937'>CAN-2005-1937</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2260'>CAN-2005-2260</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2261'>CAN-2005-2261</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2263'>CAN-2005-2263</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2265'>CAN-2005-2265</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2266'>CAN-2005-2266</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2268'>CAN-2005-2268</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2269'>CAN-2005-2269</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2270'>CAN-2005-2270</a>
<br></dd>
<br><dt>More information:</dt>
<dd>Several problems have been discovered in Mozilla. Since the usual praxis of&nbsp;<br>
backporting apparently does not work for this package, this update is&nbsp;<br>
basically version 1.7.10 with the version number rolled back, and hence still&nbsp;<br>
named 1.7.8. The Common Vulnerabilities and Exposures project identifies the&nbsp;<br>
following problems:&nbsp;<br>
&nbsp;<br>
CAN-2004-0718, CAN-2005-1937&nbsp;<br>
&nbsp;<br>
A vulnerability has been discovered in Mozilla that allows remote&nbsp;<br>
attackers to inject arbitrary Javascript from one page into the&nbsp;<br>
frameset of another site.&nbsp;<br>
&nbsp;<br>
CAN-2005-2260&nbsp;<br>
&nbsp;<br>
The browser user interface does not properly distinguish between&nbsp;<br>
user-generated events and untrusted synthetic events, which makes&nbsp;<br>
it easier for remote attackers to perform dangerous actions that&nbsp;<br>
normally could only be performed manually by the user.&nbsp;<br>
&nbsp;<br>
CAN-2005-2261&nbsp;<br>
&nbsp;<br>
XML scripts ran even when Javascript disabled.&nbsp;<br>
&nbsp;<br>
CAN-2005-2263&nbsp;<br>
&nbsp;<br>
It is possible for a remote attacker to execute a callback&nbsp;<br>
function in the context of another domain (i.e. frame).&nbsp;<br>
&nbsp;<br>
CAN-2005-2265&nbsp;<br>
&nbsp;<br>
Missing input sanitising of InstallVersion.compareTo() can cause&nbsp;<br>
the application to crash.&nbsp;<br>
&nbsp;<br>
CAN-2005-2266&nbsp;<br>
&nbsp;<br>
Remote attackers could steal sensitive information such as cookies&nbsp;<br>
and passwords from web sites by accessing data in alien frames.&nbsp;<br>
&nbsp;<br>
CAN-2005-2268&nbsp;<br>
&nbsp;<br>
It is possible for a Javascript dialog box to spoof a dialog box&nbsp;<br>
from a trusted site and facilitates phishing attacks.&nbsp;<br>
&nbsp;<br>
CAN-2005-2269&nbsp;<br>
&nbsp;<br>
Remote attackers could modify certain tag properties of DOM nodes&nbsp;<br>
that could lead to the execution of arbitrary script or code.&nbsp;<br>
&nbsp;<br>
CAN-2005-2270&nbsp;<br>
&nbsp;<br>
The Mozilla browser family does not properly clone base objects,&nbsp;<br>
which allows remote attackers to execute arbitrary code.&nbsp;<br>
&nbsp;<br>
Note that this is the same update contained in DSA-810-1 for Debian stable.&nbsp;<br>
</dd>
<br><dt>For the testing distribution (etch) this is fixed in version 1.7.8-1sarge2</dt>
<dt>For the unstable distribution (sid) this is fixed in version 1.7.10-1</dt>
<br><dt>This upgrade is recommended if you use mozilla.<dt>
<br><dt>If you have the secure testing lines in your sources.list, you can update by running this command as root:</dt>
<dd>apt-get update && apt-get install mozilla</dd>
<br>
<br>
<dt>To use the Debian testing security archive, add the following lines to your /etc/apt/sources.list:<dt>
<br>
<dd>deb http://secure-testing-mirrors.debian.net/debian-secure-testing etch-proposed-updates/security-updates main contrib non-free</dd>
<dd>deb-src http://secure-testing-mirrors.debian.net/debian-secure-testing etch-proposed-updates/security-updates main contrib non-free</dd>
<br>
<dt>The archive signing key can be downloaded from<dt>
<dd><a href='http://secure-testing.debian.net/ziyi-2005-7.asc'>http://secure-testing.debian.net/ziyi-2005-7.asc</a><dd>
<br>
<!-- footer -->
<hr>
<a href="http://validator.w3.org/check?uri=referer">
<img border="0" src="http://www.w3.org/Icons/valid-html401" alt="Valid HTML 4.01!" height="31" width="88"></a>
<a href="http://jigsaw.w3.org/css-validator/check/referer">
<img border="0" src="http://jigsaw.w3.org/css-validator/images/vcss" alt="Valid CSS!"
height="31" width="88"></a>
</body></html>
......@@ -63,6 +63,8 @@
<dd>modeline exploits</dd>
<dt>[September 8th, 2005] <a href='DTSA/DTSA-13-1.html'>DTSA-13-1 evolution</a></dt>
<dd>format string vulnerabilities</dd>
<dt>[September 13th, 2005] <a href='DTSA/DTSA-14-1.html'>DTSA-14-1 mozilla</a></dt>
<dd>several</dd>
</dl>
<!-- footer -->
<hr>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment