Commit b0c9fad7 authored by Neil McGovern's avatar Neil McGovern

Release wordpress/DTSA-33-1


git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@5445 e39458fd-73e7-0310-bf30-c45bca0a0e42
parent 94675879
......@@ -86,3 +86,10 @@
- hyperestraier 1.0.6-1.1etch1
[February 1st, 2007] DTSA-32-1 bcfg2 - programming error
- bcfg2 0.8.6.1-1.1etch1
[February 12th, 2007] DTSA-33-1 wordpress - multiple vulnerabilities
{}
- wordpress 2.0.8-1
TODO: unreleased
[February 12th, 2007] DTSA-33-1 wordpress - multiple vulnerabilities
{CVE-2007-0262 CVE-2007-0539 CVE-2007-0541 }
- wordpress 2.0.8-1
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head><meta http-equiv="Content-Type" content="text/html; charset=iso8859-1">
<title>Debian testing security team - Advisory</title>
<link type="text/css" rel="stylesheet" href="../style.css">
<link rel="shortcut icon" href="http://www.debian.org/favicon.ico">
</head>
<body>
<div align="center">
<a href="http://www.debian.org/">
<img src="http://www.debian.org/logos/openlogo-nd-50.png" border="0" hspace="0" vspace="0" alt=""></a>
<a href="http://www.debian.org/">
<img src="http://www.debian.org/Pics/debian.png" border="0" hspace="0" vspace="0" alt="Debian Project"></a>
</div>
<br />
<table class="reddy" width="100%">
<tr>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-upperleft.png" align="left" border="0" hspace="0" vspace="0"
alt="" width="15" height="16"></td>
<td rowspan="2" class="reddy">Debian testing security team - Advisory</td>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-upperright.png" align="right" border="0" hspace="0" vspace="0"
alt="" width="16" height="16"></td>
</tr>
<tr>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-lowerleft.png" align="left" border="0" hspace="0" vspace="0"
alt="" width="16" height="16"></td>
<td class="reddy">
<img src="http://www.debian.org/Pics/red-lowerright.png" align="right" border="0" hspace="0" vspace="0"
alt="" width="15" height="16"></td>
</tr>
</table>
<!-- header -->
<h2>DTSA-33-1</h2>
<dl>
<dt>Date Reported:</dt>
<dd>February 12th, 2007</dd>
<dt>Affected Package:</dt>
<dd><a href='http://packages.debian.org/src:wordpress'>wordpress</a></dd>
<dt>Vulnerability:</dt>
<dd>multiple vulnerabilities</dd>
<dt>Problem-Scope:</dt>
<dd>remote</dd>
<dt>Debian-specific:</dt>
<dd>No<br></dd>
<dt>CVE:</dt>
<dd>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0262'>CVE-2007-0262</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0539'>CVE-2007-0539</a>
<a href='http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0541'>CVE-2007-0541</a>
<br></dd>
<br><dt>More information:</dt>
<dd>Various issues have been discovered in wordpress:&nbsp;<br>
&nbsp;<br>
CVE-2007-0262&nbsp;<br>
wordpress does not properly verify that the m parameter value has the string&nbsp;<br>
data type, which allows remote attackers to obtain sensitive information via&nbsp;<br>
an invalid m[] parameter, as demonstrated by obtaining the path, and&nbsp;<br>
obtaining certain SQL information such as the table prefix.&nbsp;<br>
&nbsp;<br>
CVE-2007-0539&nbsp;<br>
WordPress before 2.1 allows remote attackers to cause a denial of service&nbsp;<br>
(bandwidth or thread consumption) via pingback service calls with a source&nbsp;<br>
URI that corresponds to a large file, which triggers a long download session&nbsp;<br>
without a timeout constraint.&nbsp;<br>
&nbsp;<br>
CVE-2007-0541&nbsp;<br>
WordPress allows remote attackers to determine the existence of arbitrary&nbsp;<br>
files, and possibly read portions of certain files, via pingback service&nbsp;<br>
calls with a source URI that corresponds to a local pathname, which triggers&nbsp;<br>
different fault codes for existing and non-existing files, and in certain&nbsp;<br>
configurations causes a brief file excerpt to be published as a blog comment.&nbsp;<br>
&nbsp;<br>
Please note that wordpress is not present in sarge.&nbsp;<br>
</dd>
<br><dt>For the testing distribution (etch) this is fixed in version 2.0.8-1</dt>
<dt>For the unstable distribution (sid) this is fixed in version 2.1.0-1</dt>
<br><dt>This upgrade is recommended if you use wordpress.<dt>
<br><dt>If you have the secure testing lines in your sources.list, you can update by running this command as root:</dt>
<dd>apt-get update && apt-get install wordpress</dd>
<br>
<br>
<dt>To use the Debian testing security archive, add the following lines to your /etc/apt/sources.list:<dt>
<br>
<dd>deb http://security.debian.org/ testing/updates main contrib non-free</dd>
<dd>deb-src http://security.debian.org/ testing/updates main contrib non-free</dd>
<br>
<dt>The archive signing key can be downloaded from<dt>
<dd><a href='http://secure-testing.debian.net/ziyi-2005-7.asc'>http://secure-testing.debian.net/ziyi-2005-7.asc</a><dd>
<br>
<!-- footer -->
<hr>
<a href="http://validator.w3.org/check?uri=referer">
<img border="0" src="http://www.w3.org/Icons/valid-html401" alt="Valid HTML 4.01!" height="31" width="88"></a>
<a href="http://jigsaw.w3.org/css-validator/check/referer">
<img border="0" src="http://jigsaw.w3.org/css-validator/images/vcss" alt="Valid CSS!"
height="31" width="88"></a>
</body></html>
......@@ -97,6 +97,8 @@
<dd>cross-site request forgery (CSRF) vulnerability</dd>
<dt>[February 1st, 2007] <a href='DTSA/DTSA-32-1.html'>DTSA-32-1 bcfg2</a></dt>
<dd>programming error</dd>
<dt>[February 12th, 2007] <a href='DTSA/DTSA-33-1.html'>DTSA-33-1 wordpress</a></dt>
<dd>multiple vulnerabilities</dd>
</dl>
<!-- footer -->
<hr>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment