...
 
Commits (5)
epiphany (0.7.0+0-5) unstable; urgency=medium
* debian/control, debian/compat, debian/rules
- Update debhelper compat level to 12 and remove unnecessary
dependencies and dh flags
* debian/control
- Update Standards-Version to 4.3.0
* debian/copyright
- Update format URL protocol and year
* debian/watch
- Update file format to version 4 and unmangle debian version
-- Ricardo Mones <mones@debian.org> Wed, 09 Jan 2019 23:20:31 +0100
epiphany (0.7.0+0-4) unstable; urgency=medium
* debian/control
......@@ -114,7 +128,7 @@ epiphany (0.7.0-1) unstable; urgency=low
* Fixed obsolete Source-Version usage to binary:Version
* Updated to newer Standards-Version
* Changed section to Games/Action according menu policy
* Fixed watch file (Closes: #449955)
* Fixed watch file (Closes: #449955)
from patch by Raphael Geissert <atomo64@gmail.com>
-- Ricardo Mones <mones@debian.org> Fri, 28 Dec 2007 10:43:35 +0100
......@@ -122,13 +136,13 @@ epiphany (0.7.0-1) unstable; urgency=low
epiphany (0.5.1-5) unstable; urgency=low
* Add icon name to desktop file (Closes: #407356)
Original patch by Mark Purcell <msp@debian.org>
Original patch by Mark Purcell <msp@debian.org>
-- Ricardo Mones <mones@debian.org> Sat, 20 Jan 2007 12:32:59 +0100
epiphany (0.5.1-4) unstable; urgency=low
* Add desktop file used by Ubuntu from the original patch sent
* Add desktop file used by Ubuntu from the original patch sent
by Sarah Hobbs <hobbsee@kubuntu.org>
-- Ricardo Mones <mones@debian.org> Wed, 23 Aug 2006 14:29:40 +0200
......@@ -169,7 +183,7 @@ epiphany (0.5.1-1) unstable; urgency=low
* Acknowledge NMU and include Build-Depends Changes into my source.. (Closes: #178446)
* New Upstream Version
* Newer Standards-Version
* Bug fix: "epiphany: name clase with epiphany-browser", rename it to epiphany-game
* Bug fix: "epiphany: name clase with epiphany-browser", rename it to epiphany-game
to fix it. Gnome-Upstream is unable to rename their (younger) browser (Closes: #216489)
-- Joerg Jaspert <joerg@debian.org> Sat, 1 Nov 2003 11:46:21 +0100
......@@ -206,7 +220,7 @@ epiphany (0.3.0-1) unstable; urgency=low
epiphany (0.2.6-1) unstable; urgency=low
* New upstream release
* New upstream release
* Changed needs?text to needs=X11 in the Menufile. (closes: #144459)
-- Joerg Jaspert <joerg@debian.org> Thu, 25 Apr 2002 20:54:09 +0200
......
......@@ -3,9 +3,9 @@ Section: games
Priority: optional
Maintainer: Joerg Jaspert <joerg@debian.org>
Uploaders: Ricardo Mones <mones@debian.org>
Build-Depends: debhelper (>= 11), automake, libsdl1.2-dev (>= 1.2.13-4),
libsdl-mixer1.2-dev, libtinyxml-dev, dh-autoreconf
Standards-Version: 4.2.1
Build-Depends: debhelper (>= 12), automake, libsdl1.2-dev (>= 1.2.13-4),
libsdl-mixer1.2-dev, libtinyxml-dev
Standards-Version: 4.3.0
Homepage: http://epiphany.sourceforge.net/site/
Vcs-Git: https://salsa.debian.org/games-team/epiphany.git
Vcs-Browser: https://salsa.debian.org/games-team/epiphany
......
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: Epiphany
Upstream-Contact: Giuseppe D'Aqui' <kumber@tiscalinet.it>
Source: http://epiphany.sourceforge.net/
......@@ -13,7 +13,7 @@ License: GPL-2+
Files: debian/*
Copyright: 2002-2014 by Joerg Jaspert <joerg@debian.org>
2006-2014 by Ricardo Mones <mones@debian.org>
2006-2019 by Ricardo Mones <mones@debian.org>
License: GPL-2+
License: GPL-2
......@@ -30,4 +30,3 @@ License: GPL-2+
(at your option) any later version.
Comment: On Debian systems, the complete text of the GNU General Public
License version 2 can be found in '/usr/share/common-licenses/GPL-2' file.
......@@ -6,7 +6,7 @@ UPSTREAM_VERSION := $(shell /bin/bash ${TOP}/debian/get-ups-ver.sh ${TOP})
export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
%:
dh $@ --with autoreconf
dh $@
override_dh_install:
rm -f data/maps/.cvsignore data/gfx/.cvsignore data/sfx/.cvsignore
......@@ -14,4 +14,3 @@ override_dh_install:
override_dh_gencontrol:
dh_gencontrol -- -VUpstream-Version=$(UPSTREAM_VERSION)
version=3
http://sf.net/epiphany/epiphany-src-([\d\.]+)\.tar\.gz debian uupdate
version=4
opts="dversionmangle=s/\+\d$//" \
http://sf.net/@PACKAGE@/@PACKAGE@-src-@ANY_VERSION@@ARCHIVE_EXT@ \
debian uupdate