Commit d6e01ea0 authored by Bruno Kleinert's avatar Bruno Kleinert

Switch to python-support (Closes: #616877)

Use python-support instead of python-central. I followed the
instructions on http://wiki.debian.org/Python/PyCentral2DhPython2
parent 4b89b7ac
londonlaw (0.2.1-14) unstable; urgency=low
* Use dh_python2 instead of python-central in debian/rules. (Closes: #616877)
* Drop build-dependency on python-central
* Remove XB-Python-Version from debian/control
* Bump versioned build-dependency of cdbs to 0.4.90
* Remove DEB_PYTHON_SYSTEM variable from debian/rules
* Make python2.6 a versioned build-dependency and require at least
python2.6 2.6.6-3
* Add python-support as build-dependency
-- Bruno "Fuddl" Kleinert <fuddl@debian.org> Thu, 10 Mar 2011 18:49:05 +0100
londonlaw (0.2.1-13) unstable; urgency=low
* Acknowledge cleanung up the package by Jonas Smedegaard
......
......@@ -3,7 +3,7 @@ Section: games
Priority: extra
Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Uploaders: Bruno "Fuddl" Kleinert <fuddl@debian.org>
Build-Depends: cdbs (>= 0.4.43), debhelper (>= 5.0.37.1), python-central (>= 0.5), texlive-fonts-recommended, python2.6
Build-Depends: cdbs (>= 0.4.90), debhelper (>= 5.0.37.1), texlive-fonts-recommended, python2.6 (>= 2.6.6-3), python-support
Build-Depends-Indep: hevea, texlive-latex-extra
Standards-Version: 3.9.1
XS-Python-Version: all
......@@ -14,7 +14,6 @@ Vcs-Browser: http://git.debian.org/?p=pkg-games/londonlaw.git
Package: londonlaw
Architecture: all
Depends: python-wxgtk2.6, ${python:Depends}, python-twisted-core, python-zopeinterface, ${misc:Depends}
XB-Python-Version: ${python:Versions}
Description: Scotland Yard board game with network support
London Law is an online multiplayer adaptation of the classic Scotland Yard
board game (also see Wikipedia), first published by Ravensburger in 1983. The
......
#!/usr/bin/make -f
DEB_PYTHON_SYSTEM=pycentral
DEB_PYTHON_SYSTEM=pysupport
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment