Commit 18ebb02a authored by Markus Koschany's avatar Markus Koschany

Add initial debian directory

parents
This game is unsuitable for Debian because the etmain directory is still
covered by the original EULA license of Wolfenstein: Enemy Territory which does
not allow redistribution. The engine and UI won't work without those assets. In
addition pak0.pk3, pak1.pk3 and pak2.pk3 are still required to play the game.
See also
http://dev.etlegacy.com/issues/900
Perhaps this will change in the future, so consider this package to be
preliminary work. Building the game itself works.
2015/12/07
etlegacy (2.74+dfsg-1) UNRELEASED; urgency=low
* Initial release.
-- Markus Koschany <apo@debian.org> Thu, 03 Dec 2015 18:17:59 +0100
Source: etlegacy
Section: contrib/games
Priority: optional
Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Uploaders:
Markus Koschany <apo@debian.org>
Build-Depends:
cmake,
debhelper (>= 9),
libcurl4-gnutls-dev,
libfreetype6-dev,
libglew-dev,
libjpeg-dev,
liblua5.3-dev,
libminizip-dev,
libogg-dev,
libsdl2-dev,
libvorbis-dev,
pkg-config,
zip,
zlib1g-dev
Standards-Version: 3.9.6
Homepage: http://www.etlegacy.com/
Vcs-Git: git://anonscm.debian.org/pkg-games/etlegacy.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-games/etlegacy.git
Package: etlegacy
Architecture: any
Depends:
etlegacy-mod (>= ${source:Version}),
${misc:Depends},
${shlibs:Depends}
Recommends:
enemy-territory-data | game-data-packager
Description: Wolfenstein: Enemy Territory compatible client
Enemy Territory: Legacy aims to create a fully compatible client and server
for the popular online FPS game Wolfenstein: Enemy Territory, a first-person
shooter set during World War II which focuses heavily on team work and whose
gameplay is still considered unmatched by many, despite its great age.
.
This package contains the etlegacy engine for playing multiplayer online
games. You must install the original game data of Wolfenstein: Enemy Territory
in order to play the game. The necessary files can be legally obtained with
game-data-packager.
Package: etlegacy-server
Architecture: any
Depends:
adduser,
etlegacy-mod (>= ${source:Version}),
${misc:Depends},
${shlibs:Depends}
Recommends:
enemy-territory-data | game-data-packager
Description: Wolfenstein: Enemy Territory compatible dedicated server
Enemy Territory: Legacy aims to create a fully compatible client and server
for the popular online FPS game Wolfenstein: Enemy Territory, a first-person
shooter set during World War II which focuses heavily on team work and whose
gameplay is still considered unmatched by many, despite its great age.
.
This package contains the dedicated game server for Enemy Territory: Legacy
suitable for permanent internet game servers. You do not need to install this
package if you want to host a listen or LAN server with the etlegacy client.
Package: etlegacy-mod
Architecture: any
Depends:
etlegacy-mod-data (>= ${source:Version}),
${misc:Depends},
${shlibs:Depends}
Description: Enemy Territory: Legacy mod
Enemy Territory: Legacy aims to create a fully compatible client and server
for the popular online FPS game Wolfenstein: Enemy Territory, a first-person
shooter set during World War II which focuses heavily on team work and whose
gameplay is still considered unmatched by many, despite its great age.
.
This package contains the Enemy Territory Legacy mod which is compatible with
64bit clients and servers.
Package: etlegacy-mod-data
Architecture: all
Multi-Arch: foreign
Depends:
${misc:Depends}
Description: Enemy Territory: Legacy mod -- data
Enemy Territory: Legacy aims to create a fully compatible client and server
for the popular online FPS game Wolfenstein: Enemy Territory, a first-person
shooter set during World War II which focuses heavily on team work and whose
gameplay is still considered unmatched by many, despite its great age.
.
This package contains all arch-independent data files for the Enemy Territory
Legacy mod.
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: ETLegacy
Source: https://github.com/etlegacy/etlegacy
Files-Excluded:
*.ttf
misc/wininstaller/*
src/minizip/*
src/zlib/*
misc/ETLegacy.dmgCanvas/*
Comment:
The fonts are non-free because users are not allowed to modify them. The
embedded libraries were replaced by Debian's system libraries. Windows and
MacOS specific files, which are useless for Debian users, were also removed.
.
All files in etmain are still covered by the original Wolfenstein: Enemy
Territory EULA and thus they are non-distributable for Debian. Without them
the game would be unusable hence there is no way this game can be packaged for
Debian at the present time.
Files: *
Copyright: 1999-2010 id Software LLC, a ZeniMax Media company.
2012 Stephen Larroque <lrq3000@gmail.com>
2012 ET:L dev team <mail@etlegacy.com>
2011 Dusan Jocic
2010-2011 Robert Beckebans <trebor_7@users.sourceforge.net>
2012 Jan Simek <mail@etlegacy.com>
License: GPL-3+
Files:
src/tinygettext/dictionary.cpp
src/tinygettext/dictionary.hpp
src/tinygettext/dictionary_manager.cpp
src/tinygettext/dictionary_manager.hpp
src/tinygettext/file_system.hpp
src/tinygettext/iconv.cpp
src/tinygettext/language.cpp
src/tinygettext/language.hpp
src/tinygettext/log.cpp
src/tinygettext/log.hpp
src/tinygettext/log_stream.hpp
src/tinygettext/plural_forms.cpp
src/tinygettext/plural_forms.hpp
src/tinygettext/po_parser.cpp
src/tinygettext/po_parser.hpp
src/tinygettext/tinygettext.cpp
src/tinygettext/tinygettext.hpp
src/tinygettext/unix_file_system.cpp
src/tinygettext/unix_file_system.hpp
Copyright: 2006-2009 Ingo Ruhnke <grumbel@gmx.de>
License: GPL-2+
Files:
cmake/GetGitRevisionDescription.cmake
cmake/GetGitRevisionDescription.cmake.in
Copyright: 2009-2010 Iowa State University
License: BSL-1.0
Files: src/game/g_mdx.h
src/game/g_mdx_lut.h
Copyright: 2003-2005 Christopher Lais (aka "Zinx Verituse")
License: Lais-License
This software is provided 'as-is', without any express or implied
warranty. In no event will the authors be held liable for any damages
arising from the use of this software.
.
Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:
.
1. The origin of this software must not be misrepresented; you must not
claim that you wrote the original software.
.
2. Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.
.
3. Modified source for this software, as used in any binaries you have
distributed, must be provided on request, free of charge and/or penalty.
.
4. This notice may not be removed or altered from any source distribution.
Files: cmake/FindLua.cmake
cmake/FindSDL2.cmake
Copyright: 2003-2009 Kitware, Inc.
2012 2007-2009 Kitware, Inc. Modified to support Lua 5.2 by LuaDist
License: BSD-3-clause
Files: src/server/sv_wallhack.c
Copyright: 2012 Laszlo Menczel
License: GPL-2+
Files: src/sys/con_curses.c
Copyright: 2008 Amanieu d'Antras
License: GPL-2+
Files: src/tinygettext/iconv.hpp
Copyright: 2006 Ingo Ruhnke <grumbel@gmx.de>
License: GPL-3+
Files: src/qcommon/crypto/sha-1/*
Copyright: 1998 Paul E. Jones <paulej@arid.us>
License: Freeware-Public-License-(FPL)
All Rights Reserved.
.
This software is licensed as "freeware." Permission to distribute
this software in source and binary forms is hereby granted without
a fee. THIS SOFTWARE IS PROVIDED 'AS IS' AND WITHOUT ANY EXPRESSED
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
THE AUTHOR SHALL NOT BE HELD LIABLE FOR ANY DAMAGES RESULTING
FROM THE USE OF THIS SOFTWARE, EITHER DIRECTLY OR INDIRECTLY, INCLUDING,
BUT NOT LIMITED TO, LOSS OF DATA OR DATA BEING RENDERED INACCURATE.
Comment:
See also https://bugs.debian.org/730758 for a clarification of Paul E.
Jones.
Files: src/game/g_mdx.c
Copyright: 2003-2005 Christopher Lais (aka "Zinx Verituse")
modified by NQ & ET
License: Lais-License-modified
This software is provided 'as-is', without any express or implied
warranty. In no event will the authors be held liable for any damages
arising from the use of this software.
.
Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:
.
1. The origin of this software must not be misrepresented; you must not
claim that you wrote the original software.
.
2. Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.
.
3. Modified source for this software, as used in any binaries you have
distributed, must be provided on request, free of charge and/or penalty.
.
4. This notice may not be removed or altered from any source distribution.
.
5. This software has been altered by NQ & ET: Legacy team and must not be
misrepresented as being the original software.
Files: debian/*
Copyright: 2015, Markus Koschany <apo@debian.org>
License: GPL-3+
License: GPL-3+
This program is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free Software
Foundation; either version 3 of the License, or (at your option) any later
version.
.
This program is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License along with
this package; if not, write to the Free Software Foundation, Inc., 51 Franklin
St, Fifth Floor, Boston, MA 02110-1301 USA
.
On Debian systems, the complete text of the GNU General Public License version
3 can be found in `/usr/share/common-licenses/GPL-3'.
License: GPL-2+
This program is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free Software
Foundation; either version 2 of the License, or (at your option) any later
version.
.
This program is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License along with
this package; if not, write to the Free Software Foundation, Inc., 51 Franklin
St, Fifth Floor, Boston, MA 02110-1301 USA
.
On Debian systems, the complete text of the GNU General Public License version
2 can be found in `/usr/share/common-licenses/GPL-2'.
License: BSL-1.0
Boost Software License - Version 1.0 - August 17th, 2003
.
Permission is hereby granted, free of charge, to any person or organization
obtaining a copy of the software and accompanying documentation covered by
this license (the "Software") to use, reproduce, display, distribute,
execute, and transmit the Software, and to prepare derivative works of the
Software, and to permit third-parties to whom the Software is furnished to
do so, all subject to the following:
.
The copyright notices in the Software and this entire statement, including
the above license grant, this restriction and the following disclaimer,
must be included in all copies of the Software, in whole or in part, and
all derivative works of the Software, unless such copies or derivative
works are solely in the form of machine-executable object code generated by
a source language processor.
.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.
License: BSD-3-clause
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
* Neither the name of Kitware, Inc nor the names of its contributors may be
used to endorse or promote products derived from this software without
specific prior written permission.
.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL KITWARE, INC BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
usr/lib/etlegacy/legacy/pak3_* usr/share/games/etlegacy/legacy
usr/lib/etlegacy/etmain/*.cfg etc/etlegacy
etc/etlegacy/campaigncycle.cfg usr/lib/etlegacy/etmain/campaigncycle.cfg
etc/etlegacy/etl_server.cfg usr/lib/etlegacy/etmain/etl_server.cfg
etc/etlegacy/legacy.cfg usr/lib/etlegacy/etmain/legacy.cfg
etc/etlegacy/lmscycle.cfg usr/lib/etlegacy/etmain/lmscycle.cfg
etc/etlegacy/mapvotecycle.cfg usr/lib/etlegacy/etmain/mapvotecycle.cfg
etc/etlegacy/objectivecycle.cfg usr/lib/etlegacy/etmain/objectivecycle.cfg
usr/share/games/etlegacy/legacy/pak3_2.73-dirty.pk3 usr/lib/etlegacy/legacy/pak3_2.73-dirty.pk3
usr/lib/etlegacy/legacy/*.so
usr/lib/etlegacy/legacy/etl_bin*
usr/games/etlded
usr/share/man/man6/etlded.6
etlegacy-server: init.d-script-not-included-in-package
etlegacy-server: init.d-script-not-marked-as-conffile
#!/bin/sh
set -e
case "$1" in
configure)
if ! getent passwd _etlegacy >/dev/null; then
adduser --disabled-password --quiet --system \
--home /var/games/etlegacy-server --no-create-home \
--gecos "Enemy Territory Legacy dedicated server" \
--ingroup games --force-badname _etlegacy
fi
install -d /var/games
install -d /var/games/etlegacy-server
chown _etlegacy:games /var/games/etlegacy-server
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
;;
esac
#DEBHELPER#
#!/bin/sh
set -e
if [ "$1" = "purge" ] ; then
rm -r /var/games/etlegacy-server
rmdir --ignore-fail-on-non-empty /var/games
fi
#DEBHELPER#
[Unit]
Description=Enemy Territory Legacy dedicated server
Documentation=man:etlded(6)
After=network.target
RequiresMountsFor=/var/games/etlegacy-server
[Service]
User=_etlegacy
Group=games
ExecStart=/usr/games/etlded +set fs_basepath /usr/lib/etlegacy +set fs_homepath /var/games/etlegacy-server +set fs_game legacy +exec etl_server.cfg
[Install]
WantedBy=multi-user.target
usr/games/etl
usr/lib/etlegacy/*.so
usr/share/applications/etlegacy.desktop
usr/share/icons/hicolor/scalable/apps/etl.svg
usr/share/mime/packages/etlegacy.xml
usr/share/man/man6/etl.6
From: Markus Koschany <apo@debian.org>
Date: Thu, 3 Dec 2015 19:01:55 +0100
Subject: cmake use sdl2 2.0.2
At the moment Debian has only version 2.0.2 of SDL2.
Forwarded: not-needed
---
cmake/ETLSetupFeatures.cmake | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cmake/ETLSetupFeatures.cmake b/cmake/ETLSetupFeatures.cmake
index 2669b42..d699607 100644
--- a/cmake/ETLSetupFeatures.cmake
+++ b/cmake/ETLSetupFeatures.cmake
@@ -41,7 +41,7 @@ if(BUILD_CLIENT)
endif()
if(NOT BUNDLED_SDL)
- find_package(SDL2 2.0.3 REQUIRED) # FindSDL doesn't detect 32bit lib when crosscompiling
+ find_package(SDL2 2.0.2 REQUIRED) # FindSDL doesn't detect 32bit lib when crosscompiling
list(APPEND SDL_LIBRARIES ${SDL2_LIBRARY})
include_directories(SYSTEM ${SDL2_INCLUDE_DIR})
else() # BUNDLED_SDL
From: Markus Koschany <apo@debian.org>
Date: Sat, 5 Dec 2015 13:55:44 +0100
Subject: keywords
Forwarded: http://dev.etlegacy.com/issues/896
---
misc/etlegacy.desktop | 1 +
1 file changed, 1 insertion(+)
diff --git a/misc/etlegacy.desktop b/misc/etlegacy.desktop
index 14739a5..d19dc7a 100644
--- a/misc/etlegacy.desktop
+++ b/misc/etlegacy.desktop
@@ -9,4 +9,5 @@ Terminal=false
MimeType=x-scheme-handler/et;
Categories=Game;ActionGame;
StartupNotify=false
+Keywords=first-person;shooter;tactical;WWII;multiplayer;enemy;territory;
From: Markus Koschany <apo@debian.org>
Date: Sat, 5 Dec 2015 13:50:13 +0100
Subject: man page
Forwarded: http://dev.etlegacy.com/issues/897
---
docs/linux/man/man6/etl.6 | 6 +++---
docs/linux/man/man6/etlded.6 | 6 +++---
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/docs/linux/man/man6/etl.6 b/docs/linux/man/man6/etl.6
index 42f1e52..9a81198 100644
--- a/docs/linux/man/man6/etl.6
+++ b/docs/linux/man/man6/etl.6
@@ -1,9 +1,9 @@
-.TH etl 1 "9 January 2013" "" "ET: Legacy client and listen server man page"
+.TH etl 6 "9 January 2013" "" "ET: Legacy client and listen server man page"
.SH NAME
etl \- ET: Legacy client and listen server
-..SH SYNOPSIS
+.SH SYNOPSIS
.B etl
.RI [ options ]
.br
@@ -38,4 +38,4 @@ ET: Legacy Team
.SH COPYRIGHT
-ET: Legacy is distributed under the GNU GENERAL PUBLIC LICENSE Version 3, 29 June 2007
\ No newline at end of file
+ET: Legacy is distributed under the GNU GENERAL PUBLIC LICENSE Version 3, 29 June 2007
diff --git a/docs/linux/man/man6/etlded.6 b/docs/linux/man/man6/etlded.6
index 44d835e..09222a8 100644
--- a/docs/linux/man/man6/etlded.6
+++ b/docs/linux/man/man6/etlded.6
@@ -1,9 +1,9 @@
-.TH etlded 1 "9 January 2013" "" "ET: Legacy server man page"
+.TH etlded 6 "9 January 2013" "" "ET: Legacy server man page"
.SH NAME
etlded \- ET: Legacy dedicated server
-..SH SYNOPSIS
+.SH SYNOPSIS
.B etlded
.RI [ options ]
.br
@@ -38,4 +38,4 @@ ET: Legacy Team
.SH COPYRIGHT
-ET: Legacy is distributed under the GNU GENERAL PUBLIC LICENSE Version 3, 29 June 2007
\ No newline at end of file
+ET: Legacy is distributed under the GNU GENERAL PUBLIC LICENSE Version 3, 29 June 2007
cmake-use-sdl2-2.0.2.patch
use-system-minizip.patch
man-page.patch
keywords.patch
spelling.patch
From: Markus Koschany <apo@debian.org>
Date: Sat, 5 Dec 2015 13:58:36 +0100
Subject: spelling
Forwarded: http://dev.etlegacy.com/issues/898
---
src/botlib/l_script.c | 2 +-
src/server/sv_ccmds.c | 2 +-
src/server/sv_main.c | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/botlib/l_script.c b/src/botlib/l_script.c
index 564af42..6de5c92 100644
--- a/src/botlib/l_script.c
+++ b/src/botlib/l_script.c
@@ -183,7 +183,7 @@ char *PunctuationFromNum(script_t *script, int num)
return script->punctuations[i].p;
}
}
- return "unkown punctuation";
+ return "unknown punctuation";
}
void QDECL ScriptError(script_t *script, char *str, ...)
diff --git a/src/server/sv_ccmds.c b/src/server/sv_ccmds.c
index 730113e..0aa0e15 100644
--- a/src/server/sv_ccmds.c
+++ b/src/server/sv_ccmds.c
@@ -485,7 +485,7 @@ static void SV_Status_f(void)
Sys_Milliseconds(),
sv_mapname->string);
- // FIXME: extend player name lenght (>16 chars) ? - they are printed!
+ // FIXME: extend player name length (>16 chars) ? - they are printed!
// FIXME: do a Com_Printf per line! ... create the row at first
for (i = 0, cl = svs.clients ; i < sv_maxclients->integer ; i++, cl++)
{
diff --git a/src/server/sv_main.c b/src/server/sv_main.c
index 288c823..2a76774 100644
--- a/src/server/sv_main.c
+++ b/src/server/sv_main.c
@@ -748,7 +748,7 @@ static void SVC_Status(netadr_t from, qboolean force)
// A maximum challenge length of 128 should be more than plenty.
if (strlen(Cmd_Argv(1)) > 128)
{
- SV_WriteAttackLog(va("SVC_Status: challenge lenght exceeded from %s, dropping request\n", NET_AdrToString(from)));
+ SV_WriteAttackLog(va("SVC_Status: challenge length exceeded from %s, dropping request\n", NET_AdrToString(from)));
return;
}
@@ -821,7 +821,7 @@ void SVC_Info(netadr_t from)
// A maximum challenge length of 128 should be more than plenty.
if (strlen(Cmd_Argv(1)) > 128)
{
- SV_WriteAttackLog(va("SVC_Info: challenge lenght from %s exceeded, dropping request\n", NET_AdrToString(from)));
+ SV_WriteAttackLog(va("SVC_Info: challenge length from %s exceeded, dropping request\n", NET_AdrToString(from)));
return;
}
From: Markus Koschany <apo@debian.org>
Date: Fri, 4 Dec 2015 00:18:38 +0100
Subject: use system minizip
Forwarded: http://dev.etlegacy.com/issues/899
---
cmake/ETLBuildClient.cmake | 6 ++++++
cmake/ETLBuildServer.cmake | 6 ++++++
2 files changed, 12 insertions(+)
diff --git a/cmake/ETLBuildClient.cmake b/cmake/ETLBuildClient.cmake
index 3e71808..22441be 100644
--- a/cmake/ETLBuildClient.cmake
+++ b/cmake/ETLBuildClient.cmake
@@ -37,8 +37,14 @@ if(BUNDLED_OGG_VORBIS)
add_dependencies(etl bundled_ogg bundled_ogg_vorbis bundled_ogg_vorbis_file)
endif(BUNDLED_OGG_VORBIS)
+INCLUDE (FindPkgConfig)
+if (PKG_CONFIG_FOUND)
+ PKG_CHECK_MODULES(UNZIP minizip)
+endif (PKG_CONFIG_FOUND)
+
target_link_libraries(etl
${CLIENT_LIBRARIES}
+ ${UNZIP_LIBRARIES}
${SDL_LIBRARIES}
${OS_LIBRARIES} # Has to go after cURL and SDL
)
diff --git a/cmake/ETLBuildServer.cmake b/cmake/ETLBuildServer.cmake
index 2ac24e5..c467a9a 100644
--- a/cmake/ETLBuildServer.cmake
+++ b/cmake/ETLBuildServer.cmake
@@ -1,7 +1,13 @@
+INCLUDE (FindPkgConfig)
+if (PKG_CONFIG_FOUND)
+ PKG_CHECK_MODULES(UNZIP minizip)
+endif (PKG_CONFIG_FOUND)
+
add_executable(etlded ${COMMON_SRC} ${MINIZIP_SRC} ${ZLIB_SRC} ${SERVER_SRC} ${PLATFORM_SRC} ${PLATFORM_SERVER_SRC})
target_link_libraries(etlded
${SERVER_LIBRARIES}
${OS_LIBRARIES}
+ ${UNZIP_LIBRARIES}
)
set_target_properties(etlded
#!/usr/bin/make -f
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --parallel
override_dh_auto_configure:
dh_auto_configure -- \
-DCMAKE_BUILD_TYPE=Release \
-DCROSS_COMPILE32=0 \
-DBUILD_SERVER=1 \
-DBUILD_CLIENT=1 \
-DBUILD_MOD=1 \
-DBUILD_MOD_PK3=1 \
-DBUILD_PAK3_PK3=1 \
-DBUNDLED_LIBS=0 \
-DBUNDLED_SDL=0 \
-DBUNDLED_JPEG=0 \
-DBUNDLED_LUA=0 \
-DBUNDLED_CURL=0 \
-DBUNDLED_OGG_VORBIS=0 \
-DBUNDLED_GLEW=0 \
-DBUNDLED_FREETYPE=0 \
-DBUNDLED_JANSSON=0 \
-DFEATURE_CURL=1 \
-DFEATURE_OGG_VORBIS=1 \
-DFEATURE_OPENAL=0 \
-DFEATURE_FREETYPE=1 \
-DFEATURE_TRACKER=0 \
-DFEATURE_LUA=1 \
-DFEATURE_MULTIVIEW=0 \
-DFEATURE_ANTICHEAT=0 \
-DFEATURE_GETTEXT=1 \
-DFEATURE_JANSSON=0 \
-DFEATURE_LIVEAUTH=1 \
-DFEATURE_RENDERER2=1 \
-DFEATURE_AUTOUPDATE=0 \
-DRENDERER_DYNAMIC=1 \
-DFEATURE_OMNIBOT=0 \
-DINSTALL_OMNIBOT=0 \
-DCMAKE_LIBRARY_PATH=/usr/lib \
-DCMAKE_LIBRARY_PATH=/usr \
-DINSTALL_DEFAULT_BASEDIR=/usr/lib/etlegacy \
-DINSTALL_DEFAULT_MODDIR=lib/etlegacy \
-DINSTALL_DEFAULT_BINDIR=games
get-orig-source:
uscan --verbose --download-current-version --force-download
version=3
opts=filenamemangle=s/.+\/v?(\d\S*)\.tar\.gz/etlegacy-$1\.tar\.gz/,\
dversionmangle=s/(\da?)[\+\.\-~](?:dfsg|debian|ds|repack|repacked)\.?\d*$/$1/\
https://github.com/etlegacy/etlegacy/tags .*/v?(\d\S*)\.tar\.gz
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment