Commit 10b63fa6 authored by Sake Blok's avatar Sake Blok Committed by Sake Blok

Fix and update the vagrant build system

Fix a dependency issue for the vagrant build system and update
it to the latest Ubuntu LTS release (16.04 LTS). Also give it
more vCPU's and RAM by default.

Change-Id: I058e6a05356dba57a55ada7fe84f959e227a04b4
Reviewed-on: https://code.wireshark.org/review/26541Reviewed-by: 's avatarSake Blok <sake.blok@SYN-bit.nl>
parent acba1785
......@@ -6,13 +6,13 @@ VAGRANTFILE_API_VERSION = "2"
Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
# Base box is Ubuntu 14.04
config.vm.box = "ubuntu/trusty64"
# Base box is Ubuntu 16.04
config.vm.box = "ubuntu/xenial64"
# Bump the default resources as building is expensive
config.vm.provider "virtualbox" do |v|
v.memory = 1024
v.cpus = 2
v.memory = 2048
v.cpus = 4
end
# Permit X11 forwarding so running the graphical Wireshark works
......
......@@ -15,4 +15,4 @@ grep -q WIRESHARK_BIN_DIR ~/.profile || echo "export WIRESHARK_BIN_DIR=~/build/r
mkdir -p build
cd build
cmake /vagrant/
make -j3
make -j6
......@@ -12,6 +12,6 @@ set -e
apt-get update
apt-get build-dep -y wireshark
apt-get install -y cmake valgrind qt5-default \
apt-get install -y git cmake valgrind qt5-default \
libqt5multimedia5 qtmultimedia5-dev \
qttools5-dev qttools5-dev-tools
libqt5svg5-dev qttools5-dev qttools5-dev-tools
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment