Commit d3995b52 authored by Gerald Combs's avatar Gerald Combs Committed by Jörg Mayer

Disable GTK+ by default.

I suggested disabling GTK+ by default at Sharkfest EU and no one
objected, hence this patch.

Disable it by default in both Autotools and CMake. Make sure it's
enabled for Debian packaging. The RPM packaging enables GTK3 explicitly
so no change appears to be necessary there.

Change-Id: If5daeaef4bb26cf60006bc8883be15b2cf6c6ae4
Reviewed-on: https://code.wireshark.org/review/18256Reviewed-by: Peter Wu's avatarPeter Wu <peter@lekensteyn.nl>
Petri-Dish: Gerald Combs <gerald@wireshark.org>
Tested-by: 's avatarPetri Dish Buildbot <buildbot-no-reply@wireshark.org>
Reviewed-by: 's avatarJörg Mayer <jmayer@loplof.de>
parent 5ab49c62
......@@ -10,6 +10,8 @@ compiler:
env:
- BUILD_CMAKE=no
- BUILD_CMAKE=yes
- CMAKE_GTK_OPTS="-DBUILD_wireshark_gtk=ON"
- AUTOTOOLS_GTK_OPTS="--with-gtk=3"
matrix:
exclude:
......@@ -35,6 +37,6 @@ before_install:
# - sudo apt-get -qq install qt5-default qttools5-dev qttools5-dev-tools
- $CC --version
before_script:
if [ ${BUILD_CMAKE} == "yes" ]; then mkdir build && cd build && cmake ..; else ./autogen.sh && ./configure ; fi
if [ ${BUILD_CMAKE} == "yes" ]; then mkdir build && cd build && cmake ${CMAKE_GTK_OPTS} ..; else ./autogen.sh && ./configure ${AUTOTOOLS_GTK_OPTS} ; fi
script:
- make
# Build options for use by CMake
option(BUILD_wireshark "Build Wireshark" ON)
option(BUILD_wireshark_gtk "Build Wireshark (GTK+ UI)" ON)
option(BUILD_wireshark_gtk "Build Wireshark (GTK+ UI)" OFF)
option(BUILD_tshark "Build tshark" ON)
option(BUILD_tfshark "Build tfshark" ON)
option(BUILD_rawshark "Build rawshark" ON)
......
......@@ -256,14 +256,14 @@ AC_ARG_WITH([qt],
AC_ARG_WITH([gtk],
AC_HELP_STRING( [--with-gtk=@<:@yes/no/2/3@:>@],
[use GTK+ @<:@default=yes, if available@:>@]),
[use GTK+ @<:@default=no@:>@]),
AS_CASE([$withval],
[yes], [with_gtk="3 2 fail"],
[no], [with_gtk="no"],
[3], [with_gtk="3 fail3"],
[2], [with_gtk="2 fail2"],
[AC_MSG_ERROR([--with-gtk must be one of yes/no/2/3])]),
with_gtk="3 2")
with_gtk="no")
# GnuTLS
# Version 3.0 switched from LGPLv2.1+ to LGPLv3+, then switched back to
......
......@@ -28,6 +28,7 @@ export docdir = /usr/share/doc/wireshark-doc
override_dh_auto_configure:
dh_auto_configure -- -DENABLE_HTML_GUIDES=ON -DCMAKE_INSTALL_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
-DBUILD_wireshark_gtk=ON \
# -DENABLE_QT5=OFF
override_dh_auto_build:
......
......@@ -32,6 +32,7 @@ since version 2.2.0:
That is, you should make sure the NSIS package is completely uninstalled before
installing the Windows Installer package and vice-versa.
* Source packages are now compressed using xz instead of bzip2.
* GTK+ is disabled by default in Autotools and CMake.
//=== Removed Dissectors
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment