...
 
Commits (19)
linux (4.16.5-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.1
- Revert changes to use gcc-7 compiler, not found in stretch
- [x86] Add versioned (build-)dependencies on gcc-6 for retpoline support
-- Ben Hutchings <ben@decadent.org.uk> Sun, 06 May 2018 16:09:33 +0100
linux (4.16.5-1) unstable; urgency=medium
* New upstream stable update:
......@@ -714,6 +723,15 @@ linux (4.15.17-1) unstable; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Thu, 19 Apr 2018 11:13:03 +0100
linux (4.15.11-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.2
- Revert changes to use gcc-7 compiler, not found in stretch
- [x86] Add versioned (build-)dependencies on gcc-6 for retpoline support
-- Ben Hutchings <ben@decadent.org.uk> Sat, 07 Apr 2018 14:21:48 +0100
linux (4.15.11-1) unstable; urgency=medium
* New upstream stable update:
......@@ -2211,6 +2229,14 @@ linux (4.14.17-1) unstable; urgency=medium
-- Salvatore Bonaccorso <carnil@debian.org> Wed, 14 Feb 2018 06:56:06 +0100
linux (4.14.13-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.3
- Revert changes to use gcc-7 compiler, not found in stretch
-- Ben Hutchings <ben@decadent.org.uk> Sun, 14 Jan 2018 23:48:54 +0000
linux (4.14.13-1) unstable; urgency=medium
* New upstream stable update:
......@@ -2352,6 +2378,14 @@ linux (4.14.12-1) unstable; urgency=medium
-- Salvatore Bonaccorso <carnil@debian.org> Fri, 05 Jan 2018 21:20:26 +0100
linux (4.14.7-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.2
- Revert changes to use gcc-7 compiler, not found in stretch
-- Ben Hutchings <ben@decadent.org.uk> Fri, 22 Dec 2017 16:39:10 +0000
linux (4.14.7-1) unstable; urgency=medium
* New upstream stable update:
......@@ -3040,6 +3074,13 @@ linux (4.14~rc3-1~exp1) experimental; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Mon, 02 Oct 2017 04:47:08 +0100
linux (4.13.13-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.1
-- Ben Hutchings <ben@decadent.org.uk> Wed, 22 Nov 2017 01:51:52 +0000
linux (4.13.13-1) unstable; urgency=medium
* New upstream stable update:
......@@ -3604,6 +3645,13 @@ linux (4.13.10-1) unstable; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Mon, 30 Oct 2017 15:32:11 +0000
linux (4.13.4-2~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.1
-- Ben Hutchings <ben@decadent.org.uk> Tue, 17 Oct 2017 17:18:02 +0100
linux (4.13.4-2) unstable; urgency=medium
[ Ben Hutchings ]
......@@ -3739,6 +3787,13 @@ linux (4.13~rc5-1~exp1) experimental; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Mon, 14 Aug 2017 23:20:50 +0100
linux (4.12.13-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.2
-- Ben Hutchings <ben@decadent.org.uk> Thu, 28 Sep 2017 12:29:04 +0100
linux (4.12.13-1) unstable; urgency=medium
* New upstream stable update:
......@@ -4072,6 +4127,15 @@ linux (4.12.12-1) unstable; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Sun, 10 Sep 2017 19:42:51 +0100
linux (4.12.6-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.1
* cpupower: Add/update definition of MSRHEADER macro for turbostat and
x86_energy_perf_policy (Closes: #872414)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 27 Aug 2017 20:57:40 +0100
linux (4.12.6-1) unstable; urgency=medium
* New upstream stable update:
......@@ -4446,6 +4510,13 @@ linux (4.11.11-1) unstable; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Mon, 17 Jul 2017 03:01:21 +0100
linux (4.11.6-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports:
- Change ABI number to 0.bpo.1
-- Ben Hutchings <ben@decadent.org.uk> Sun, 09 Jul 2017 19:22:15 +0100
linux (4.11.6-1) unstable; urgency=medium
* New upstream stable update:
......@@ -15,8 +15,8 @@ install-stem: vmlinuz
breaks: xserver-xorg-input-vmmouse (<< 1:13.0.99)
[relations]
gcc-7: gcc-7 (>= 7.2.0-20~) <!stage1 !cross>, gcc-7-x86-64-linux-gnu (>= 7.2.0-20~) <!stage1 cross>
headers%gcc-7: linux-compiler-gcc-7-x86 (>= 4.14.17-1~)
gcc-6: gcc-6 (>= 6.3.0-18+deb9u1~) <!stage1 !cross>, gcc-6-@gnu-type-package@ (>= 6.3.0-18+deb9u1~) <!stage1 cross>
headers%gcc-6: linux-compiler-gcc-6-x86 (>= 4.14.17-1~)
[amd64_description]
hardware: 64-bit PCs
......
......@@ -12,7 +12,7 @@ uncompressed-image-file: arch/arm/boot/Image
install-stem: vmlinuz
[relations]
headers%gcc-7: linux-compiler-gcc-7-arm
headers%gcc-6: linux-compiler-gcc-6-arm
[marvell_description]
hardware: Marvell Kirkwood/Orion
......
......@@ -12,7 +12,7 @@ vdso: true
install-stem: vmlinuz
[relations]
headers%gcc-7: linux-compiler-gcc-7-arm
headers%gcc-6: linux-compiler-gcc-6-arm
[armmp_description]
hardware: ARMv7 multiplatform compatible SoCs
......
[abi]
abiname: 1
abiname: 0.bpo.1
ignore-changes:
__cpuhp_*
__xive_vm_h_*
......@@ -102,7 +102,7 @@ arches:
sparc64
tilegx
x32
compiler: gcc-7
compiler: gcc-6
featuresets:
none
rt
......@@ -125,7 +125,7 @@ recommends: apparmor
[relations]
# compilers
gcc-7: gcc-7 <!stage1 !cross>, gcc-7-@gnu-type-package@ <!stage1 cross>
gcc-6: gcc-6 <!stage1 !cross>, gcc-6-@gnu-type-package@ <!stage1 cross>
# initramfs-generators
initramfs-fallback: linux-initramfs-tool
......
......@@ -27,5 +27,5 @@ hardware: multiprocessor 64-bit PA-RISC
hardware-long: HP PA-RISC 64-bit SMP systems with support for more than 4 GB RAM
[relations]
gcc-7: gcc-7 <!stage1 !cross>, binutils-hppa64-linux-gnu <!stage1 !cross>, gcc-7-hppa64-linux-gnu <!stage1 !cross>, gcc-7-hppa-linux-gnu <!stage1 cross>, binutils-hppa64-linux-gnu <!stage1 cross>, gcc-7-hppa64-linux-gnu <!stage1 cross>
gcc-6: gcc-6 <!stage1 !cross>, binutils-hppa64-linux-gnu <!stage1 !cross>, gcc-6-hppa64-linux-gnu <!stage1 !cross>, gcc-6-hppa-linux-gnu <!stage1 cross>, binutils-hppa64-linux-gnu <!stage1 cross>, gcc-6-hppa64-linux-gnu <!stage1 cross>
......@@ -20,8 +20,8 @@ install-stem: vmlinuz
breaks: xserver-xorg-input-vmmouse (<< 1:13.0.99)
[relations]
gcc-7: gcc-7 (>= 7.2.0-20~) <!stage1 !cross>, gcc-7-i686-linux-gnu (>= 7.2.0-20~) <!stage1 cross>
headers%gcc-7: linux-compiler-gcc-7-x86 (>= 4.14.17-1~)
gcc-6: gcc-6 (>= 6.3.0-18+deb9u1~) <!stage1 !cross>, gcc-6-@gnu-type-package@ (>= 6.3.0-18+deb9u1~) <!stage1 cross>
headers%gcc-6: linux-compiler-gcc-6-x86 (>= 4.14.17-1~)
[686_description]
hardware: older PCs
......
......@@ -12,7 +12,7 @@ bootloaders: s390-tools
install-stem: vmlinuz
[relations]
headers%gcc-7: linux-compiler-gcc-7-s390
headers%gcc-6: linux-compiler-gcc-6-s390
[s390x_build]
debug-info: true
......
Package: linux-compiler-gcc-7-arm
Package: linux-compiler-gcc-6-arm
Build-Profiles: <!stage1>
Depends: gcc-7, ${misc:Depends}
Depends: gcc-6, ${misc:Depends}
Architecture: armel armhf
Multi-Arch: foreign
Description: Compiler for Linux on ARM (meta-package)
This package depends on GCC of the appropriate version and architecture
for Linux on armel and armhf.
Package: linux-compiler-gcc-7-s390
Package: linux-compiler-gcc-6-s390
Build-Profiles: <!stage1>
Depends: gcc-7, ${misc:Depends}
Depends: gcc-6, ${misc:Depends}
Architecture: s390 s390x
Multi-Arch: foreign
Description: Compiler for Linux on IBM zSeries (meta-package)
This package depends on GCC of the appropriate version and architecture
for Linux on s390 and s390x.
Package: linux-compiler-gcc-7-x86
Package: linux-compiler-gcc-6-x86
Build-Profiles: <!stage1>
Depends: gcc-7 (>= 7.2.0-20~), ${misc:Depends}
Depends: gcc-6 (>= 6.3.0-18+deb9u1~), ${misc:Depends}
Architecture: amd64 i386 x32
Multi-Arch: foreign
Description: Compiler for Linux on x86 (meta-package)
......