...
 
Commits (2)
......@@ -45,6 +45,12 @@ glibc (2.29-0experimental0) UNRELEASED; urgency=medium
* debian/testsuite-xfail-debian.mk: Clean out test build failures, they are
now handled upstream. Clean out now-fixed tests.
[ Aurelien Jarno ]
* debian/patches/git-updates.diff: update from upstream stable branch:
- debian/patches/any/git-libio-stdout-putc.diff: rebased.
* debian/control.in/main, debian/rules: drop the multiarch-support package.
Closes: #910669.
-- Adam Conrad <adconrad@0c3.net> Wed, 20 Feb 2019 01:22:52 -0700
glibc (2.28-8) UNRELEASED; urgency=medium
......
......@@ -139,25 +139,6 @@ Description: GNU C Library: Name Service Cache Daemon
query. You should install this package only if you use
slow services like LDAP, NIS or NIS+.
Package: multiarch-support
Architecture: any
Section: oldlibs
Multi-Arch: foreign
Depends: ${misc:Depends},
libc6 (>= 2.3.6-2) [!any-i386 !alpha !armhf !hurd-any !ia64 !kfreebsd-any],
libc6.1 (>= 2.3.6-2) [alpha ia64],
libc0.3 (>= 2.3.6-2) [!linux-any !kfreebsd-any !hurd-i386],
libc0.1 (>= 2.3.6-2) [!linux-any !hurd-any !kfreebsd-i386],
libc6 (>= 2.13-5) [armhf i386],
libc0.3 (>= 2.13-5) [hurd-i386],
libc0.1 (>= 2.13-5) [kfreebsd-i386],
Priority: optional
Build-Profiles: <!stage1>
Description: Transitional package to ensure multiarch compatibility
This is a transitional package used to ensure multiarch support is present
in ld.so before unpacking libraries to the multiarch directories. It can
be removed once nothing on the system depends on it.
Package: libc6
Architecture: amd64 arm64 armel armhf hppa i386 m68k mips mipsel mipsn32 mipsn32el mips64 mips64el mipsr6 mipsr6el mipsn32r6 mipsn32r6el mips64r6 mips64r6el nios2 powerpc powerpcspe ppc64 ppc64el riscv64 sparc sparc64 s390x sh3 sh4 x32
Section: libs
......
......@@ -139,22 +139,3 @@ Description: GNU C Library: Name Service Cache Daemon
query. You should install this package only if you use
slow services like LDAP, NIS or NIS+.
Package: multiarch-support
Architecture: any
Section: oldlibs
Multi-Arch: foreign
Depends: ${misc:Depends},
libc6 (>= 2.3.6-2) [!any-i386 !alpha !armhf !hurd-any !ia64 !kfreebsd-any],
libc6.1 (>= 2.3.6-2) [alpha ia64],
libc0.3 (>= 2.3.6-2) [!linux-any !kfreebsd-any !hurd-i386],
libc0.1 (>= 2.3.6-2) [!linux-any !hurd-any !kfreebsd-i386],
libc6 (>= 2.13-5) [armhf i386],
libc0.3 (>= 2.13-5) [hurd-i386],
libc0.1 (>= 2.13-5) [kfreebsd-i386],
Priority: optional
Build-Profiles: <!stage1>
Description: Transitional package to ensure multiarch compatibility
This is a transitional package used to ensure multiarch support is present
in ld.so before unpacking libraries to the multiarch directories. It can
be removed once nothing on the system depends on it.
......@@ -13,12 +13,12 @@
--- a/libio/Makefile
+++ b/libio/Makefile
@@ -64,7 +64,7 @@
@@ -65,7 +65,7 @@
tst-setvbuf1 tst-popen1 tst-fgetwc bug-wsetpos tst-fseek \
tst-fwrite-error tst-ftell-partial-wide tst-ftell-active-handler \
tst-ftell-append tst-fputws tst-bz22415 tst-fgetc-after-eof \
- tst-sprintf-ub tst-sprintf-chk-ub
+ tst-sprintf-ub tst-sprintf-chk-ub tst-bz24051
- tst-sprintf-ub tst-sprintf-chk-ub tst-wfile-sync
+ tst-sprintf-ub tst-sprintf-chk-ub tst-wfile-sync tst-bz24051
tests-internal = tst-vtables tst-vtables-interposed tst-readline
......
This diff is collapsed.
......@@ -136,7 +136,7 @@ ifneq ($(filter stage1,$(DEB_BUILD_PROFILES)),)
DEB_BUILD_OPTIONS+=nocheck
endif
else
DEB_ARCH_REGULAR_PACKAGES = $(libc) $(libc)-dev $(libc)-dbg $(libc)-pic libc-bin libc-dev-bin multiarch-support
DEB_ARCH_REGULAR_PACKAGES = $(libc) $(libc)-dev $(libc)-dbg $(libc)-pic libc-bin libc-dev-bin
DEB_INDEP_REGULAR_PACKAGES = glibc-doc glibc-source libc-l10n locales
DEB_UDEB_PACKAGES = $(libc)-udeb
## Locales can only be pre-generated during native compiles
......