Commit 0ec450e2 authored by Jackson Doak's avatar Jackson Doak

* New upstream release

* Sync packaging from ubuntu.
* Refresh patch
parent 63799ebb
accerciser (3.4.1-2) UNRELEASED; urgency=low
accerciser (3.8.2-1) UNRELEASED; urgency=low
[ Jeremy Bicha ]
* Update homepage
[ Jackson Doak ]
* Update debian/watch
* New upstream release
* Sync packaging from ubuntu.
* Refresh patch
-- Jackson Doak <noskcaj@ubuntu.com> Fri, 20 Dec 2013 07:16:33 +1100
-- Jackson Doak <noskcaj@ubuntu.com> Fri, 20 Dec 2013 07:18:03 +1100
accerciser (3.4.1-1) unstable; urgency=low
......
......@@ -2,7 +2,6 @@
#
# Modifications should be made to debian/control.in instead.
# This file is regenerated automatically in the clean target.
Source: accerciser
Section: gnome
Priority: extra
......@@ -11,15 +10,17 @@ Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.o
Build-Depends: cdbs (>= 0.4.90~),
debhelper (>= 9),
gnome-pkg-tools (>= 0.10)
Build-Depends-Indep: gnome-doc-utils (>= 0.17.3),
Build-Depends-Indep: yelp-tools,
gsettings-desktop-schemas-dev,
intltool (>= 0.35.0),
libatspi2.0-dev (>= 2.1.5),
libgtk-3-dev (>= 3.1.13),
pkg-config,
python-gi-dev (>= 2.90.3),
python-pyatspi2 (>= 2.1.5),
python3 (>= 3.2),
python-gi-dev (>= 3.4.2),
python3-pyatspi2 (>= 2.1.5),
python-support
X-Python-Version: >= 3.2
Standards-Version: 3.9.3
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/desktop/unstable/accerciser
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/accerciser
......@@ -29,15 +30,15 @@ Package: accerciser
Architecture: all
Depends: ${shlibs:Depends},
${misc:Depends},
${python:Depends},
ipython (>= 0.12),
${python3:Depends},
ipython3 (>= 0.12),
gir1.2-atk-1.0,
gir1.2-gdkpixbuf-2.0,
gir1.2-gtk-3.0,
gir1.2-pango-1.0,
gir1.2-wnck-3.0,
python-cairo,
python-pyatspi2 (>= 2.1.5)
python3-cairo,
python3-pyatspi (>= 2.1.5)
Description: interactive Python accessibility explorer for the GNOME desktop
It uses AT-SPI to inspect and control widgets, allowing you to check if
an application is providing correct information to assistive technologies
......
......@@ -6,15 +6,17 @@ Uploaders: @GNOME_TEAM@
Build-Depends: cdbs (>= 0.4.90~),
debhelper (>= 9),
gnome-pkg-tools (>= 0.10)
Build-Depends-Indep: gnome-doc-utils (>= 0.17.3),
Build-Depends-Indep: yelp-tools,
gsettings-desktop-schemas-dev,
intltool (>= 0.35.0),
libatspi2.0-dev (>= 2.1.5),
libgtk-3-dev (>= 3.1.13),
pkg-config,
python-gi-dev (>= 2.90.3),
python-pyatspi2 (>= 2.1.5),
python3 (>= 3.2),
python-gi-dev (>= 3.4.2),
python3-pyatspi2 (>= 2.1.5),
python-support
X-Python3-Version: >= 3.2
Standards-Version: 3.9.3
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/desktop/unstable/accerciser
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/accerciser
......@@ -24,15 +26,15 @@ Package: accerciser
Architecture: all
Depends: ${shlibs:Depends},
${misc:Depends},
${python:Depends},
ipython (>= 0.12),
${python3:Depends},
ipython3 (>= 0.12),
gir1.2-atk-1.0,
gir1.2-gdkpixbuf-2.0,
gir1.2-gtk-3.0,
gir1.2-pango-1.0,
gir1.2-wnck-3.0,
python-cairo,
python-pyatspi2 (>= 2.1.5)
python3-cairo,
python3-pyatspi (>= 2.1.5)
Description: interactive Python accessibility explorer for the GNOME desktop
It uses AT-SPI to inspect and control widgets, allowing you to check if
an application is providing correct information to assistive technologies
......
---
src/accerciser.in | 4 ----
1 file changed, 4 deletions(-)
--- a/src/accerciser.in
+++ b/src/accerciser.in
@@ -20,10 +20,6 @@
@@ -35,10 +35,6 @@ sys.path.append(os.path.join(GLib.get_us
# We can't rely on prefix if we're installed by relocated RPM. Instead, we
# use __file__ and for now hope that lib is relative to bin.
sys.prefix = '@prefix@'
......@@ -8,6 +12,6 @@
- 'python@PYTHON_VERSION@', 'site-packages')
-# point to the proper site-packages path
-sys.path.insert(1, libs)
# TODO: Remove completely gnome dependency
# make this program accessible
......@@ -10,7 +10,7 @@ include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
dh_pysupport -p$(cdbs_curpkg)
dh_python3 -p$(cdbs_curpkg)
binary-post-install/accerciser::
# force executable bit on files looking like python scripts
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment