Commit 86d5953d authored by Michael Biebl's avatar Michael Biebl

libgdict now builds against GTK3, which changes its ABI, but hasn't

changed the SONAME. As a workaround, bump the versions in
libgdict-1.0-6.symbols to 3.0.0 and add Breaks against
gnome-dictionary (<< 3.0.0) and gtranslator (<< 2.90.0).
parent fb46d58a
......@@ -19,6 +19,10 @@ gnome-utils (3.0.1-1) UNRELEASED; urgency=low
* debian/rules
- Remove --enable-gdict-applet=no configure option, obsolete.
* Add new gnome-font-viewer package.
* libgdict now builds against GTK3, which changes its ABI, but hasn't
changed the SONAME. As a workaround, bump the versions in
libgdict-1.0-6.symbols to 3.0.0 and add Breaks against
gnome-dictionary (<< 3.0.0) and gtranslator (<< 2.90.0).
-- Michael Biebl <biebl@debian.org> Tue, 14 Jun 2011 01:14:12 +0200
......
......@@ -53,6 +53,8 @@ Depends: ${shlibs:Depends},
gnome-utils-common (<< ${gnome:NextVersion})
Replaces: gnome-utils (<< 2.23.90-1)
Conflicts: gnome-utils (<< 2.23.90-1)
Breaks: gnome-dictionary (<< 3.0.0),
gtranslator (<< 2.90.0)
Description: GNOME Dictionary base library - runtime
This package contains the library used by the GNOME dictionary
utility, and other applications providing similar functionality.
......
......@@ -48,6 +48,8 @@ Depends: ${shlibs:Depends},
gnome-utils-common (<< ${gnome:NextVersion})
Replaces: gnome-utils (<< 2.23.90-1)
Conflicts: gnome-utils (<< 2.23.90-1)
Breaks: gnome-dictionary (<< 3.0.0),
gtranslator (<< 2.90.0)
Description: GNOME Dictionary base library - runtime
This package contains the library used by the GNOME dictionary
utility, and other applications providing similar functionality.
......
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment