Commit e5b32724 authored by Michael Biebl's avatar Michael Biebl

Move experimental branch of gnome-utils to unstable

parents 13e3af68 86870100
gnome-utils (3.0.1-6) UNRELEASED; urgency=low
gnome-utils (3.2.1-1) experimental; urgency=low
[ Josselin Mouette ]
* Use pkexec instead of gksu for gnome-system-log.
-- Josselin Mouette <joss@debian.org> Tue, 01 Nov 2011 10:15:13 +0100
[ Jordi Mallach ]
* New upstream release.
* Drop 02_gdict-1.0_pc_requires.patch: fixed upstream.
* Drop 03-don-t-abort-if-nautilus-schema-is-not-installed.patch: obsolete.
* Bump Build-Depends to libglib2.0-dev (>= 2.29.14), as required by
configure.ac.
* Add 10_no_disable_deprecated.patch: don't set *_DISABLE_DEPRECATED,
to avoid build failures with GTK+ 3.0.x.
* Build-Depend on dh-autoreconf and include the CDBS snippet.
* Add -c4 to dh_makeshlibs call.
* Set LDFLAGS to -Wl,-z,defs -Wl,-O1 -Wl,--as-needed.
* Update Vcs-* URLs.
* Replace Conflicts with Breaks.
-- Jordi Mallach <jordi@debian.org> Sat, 12 Nov 2011 16:40:01 +0100
gnome-utils (3.0.1-5) unstable; urgency=low
......
......@@ -10,15 +10,16 @@ Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.
Uploaders: Emilio Pozuelo Monfort <pochu@debian.org>, Jordi Mallach <jordi@debian.org>, Josselin Mouette <joss@debian.org>, Michael Biebl <biebl@debian.org>, Sebastian Dröge <slomo@debian.org>
Build-Depends: cdbs,
debhelper (>= 8),
dh-autoreconf,
gnome-pkg-tools (>= 0.10),
autotools-dev,
intltool (>= 0.40.0),
libxt-dev,
libglib2.0-dev (>= 2.28.0),
libglib2.0-dev (>= 2.29.14),
libgconf2-dev,
libgtk-3-dev (>= 3.0.3),
libgtop2-dev (>= 2.12.0),
libcanberra-gtk3-dev (>= 0.26-3),
libcanberra-gtk3-dev (>= 0.26-3~),
x11proto-xext-dev,
libxext-dev,
libx11-dev,
......@@ -31,14 +32,14 @@ Build-Depends: cdbs,
gsettings-desktop-schemas-dev
Standards-Version: 3.9.2
Homepage: http://live.gnome.org/GnomeUtils
Vcs-Svn: svn://svn.debian.org/pkg-gnome/desktop/unstable/gnome-utils/
Vcs-Browser: http://svn.debian.org/viewsvn/pkg-gnome/desktop/unstable/gnome-utils/
Vcs-Svn: svn://anonscm.debian.org/svn/pkg-gnome/desktop/unstable/gnome-utils/
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/gnome-utils/
Package: gnome-utils-common
Architecture: all
Section: libs
Depends: ${misc:Depends}
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: data files for the GNOME utilities
This package contains the translation files for the GNOME utilities
......@@ -52,8 +53,8 @@ Depends: ${shlibs:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Replaces: gnome-utils (<< 2.23.90-1)
Conflicts: gnome-utils (<< 2.23.90-1)
Breaks: gnome-dictionary (<< 3.0.0),
Breaks: gnome-utils (<< 2.23.90-1),
gnome-dictionary (<< 3.0.0),
gtranslator (<< 2.90.0)
Description: GNOME Dictionary base library - runtime
This package contains the library used by the GNOME dictionary
......@@ -65,7 +66,7 @@ Architecture: any
Depends: ${misc:Depends},
libgdict-1.0-6 (= ${binary:Version}),
libgtk-3-dev (>= 3.0.3),
libglib2.0-dev (>= 2.28.0)
libglib2.0-dev (>= 2.29.14)
Replaces: gnome-utils (<< 2.24.1-3)
Description: GNOME Dictionary base library - development files
This package contains the development files for a library used by the
......@@ -79,7 +80,7 @@ Depends: ${shlibs:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Suggests: yelp
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: GNOME disk usage analyzer
Disk Usage Analyzer is a graphical, menu-driven application to analyse
......@@ -99,7 +100,7 @@ Depends: ${shlibs:Depends},
gnome-utils-common (<< ${gnome:NextVersion})
Suggests: yelp
Provides: dict-client
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: GNOME dictionary application
This program can look for the definition or translation of a word in
......@@ -113,7 +114,7 @@ Depends: ${shlibs:Depends},
${misc:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: screenshot application for GNOME
This tool takes a picture of the desktop or of a window and saves it
......@@ -126,7 +127,7 @@ Depends: ${shlibs:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Suggests: yelp
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: GNOME tool to search files
This application can search for files in a given directory, matching
......@@ -143,10 +144,10 @@ Depends: ${shlibs:Depends},
gnome-utils-common (<< ${gnome:NextVersion}),
policykit-1
Suggests: yelp
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: system log viewer for GNOME
This program displays system log files in a friendly way and allows to
This program displays system log files in a friendly way and allows one to
filter or search expressions in them.
Package: gnome-font-viewer
......
......@@ -5,15 +5,16 @@ Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.
Uploaders: @GNOME_TEAM@
Build-Depends: cdbs,
debhelper (>= 8),
dh-autoreconf,
gnome-pkg-tools (>= 0.10),
autotools-dev,
intltool (>= 0.40.0),
libxt-dev,
libglib2.0-dev (>= 2.28.0),
libglib2.0-dev (>= 2.29.14),
libgconf2-dev,
libgtk-3-dev (>= 3.0.3),
libgtop2-dev (>= 2.12.0),
libcanberra-gtk3-dev (>= 0.26-3),
libcanberra-gtk3-dev (>= 0.26-3~),
x11proto-xext-dev,
libxext-dev,
libx11-dev,
......@@ -26,14 +27,14 @@ Build-Depends: cdbs,
gsettings-desktop-schemas-dev
Standards-Version: 3.9.2
Homepage: http://live.gnome.org/GnomeUtils
Vcs-Svn: svn://svn.debian.org/pkg-gnome/desktop/unstable/gnome-utils/
Vcs-Browser: http://svn.debian.org/viewsvn/pkg-gnome/desktop/unstable/gnome-utils/
Vcs-Svn: svn://anonscm.debian.org/svn/pkg-gnome/desktop/unstable/gnome-utils/
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/gnome-utils/
Package: gnome-utils-common
Architecture: all
Section: libs
Depends: ${misc:Depends}
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: data files for the GNOME utilities
This package contains the translation files for the GNOME utilities
......@@ -47,8 +48,8 @@ Depends: ${shlibs:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Replaces: gnome-utils (<< 2.23.90-1)
Conflicts: gnome-utils (<< 2.23.90-1)
Breaks: gnome-dictionary (<< 3.0.0),
Breaks: gnome-utils (<< 2.23.90-1),
gnome-dictionary (<< 3.0.0),
gtranslator (<< 2.90.0)
Description: GNOME Dictionary base library - runtime
This package contains the library used by the GNOME dictionary
......@@ -60,7 +61,7 @@ Architecture: any
Depends: ${misc:Depends},
libgdict-1.0-6 (= ${binary:Version}),
libgtk-3-dev (>= 3.0.3),
libglib2.0-dev (>= 2.28.0)
libglib2.0-dev (>= 2.29.14)
Replaces: gnome-utils (<< 2.24.1-3)
Description: GNOME Dictionary base library - development files
This package contains the development files for a library used by the
......@@ -74,7 +75,7 @@ Depends: ${shlibs:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Suggests: yelp
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: GNOME disk usage analyzer
Disk Usage Analyzer is a graphical, menu-driven application to analyse
......@@ -94,7 +95,7 @@ Depends: ${shlibs:Depends},
gnome-utils-common (<< ${gnome:NextVersion})
Suggests: yelp
Provides: dict-client
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: GNOME dictionary application
This program can look for the definition or translation of a word in
......@@ -108,7 +109,7 @@ Depends: ${shlibs:Depends},
${misc:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: screenshot application for GNOME
This tool takes a picture of the desktop or of a window and saves it
......@@ -121,7 +122,7 @@ Depends: ${shlibs:Depends},
gnome-utils-common (>= ${gnome:Version}),
gnome-utils-common (<< ${gnome:NextVersion})
Suggests: yelp
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: GNOME tool to search files
This application can search for files in a given directory, matching
......@@ -138,10 +139,10 @@ Depends: ${shlibs:Depends},
gnome-utils-common (<< ${gnome:NextVersion}),
policykit-1
Suggests: yelp
Conflicts: gnome-utils (<< 2.30.0-2)
Breaks: gnome-utils (<< 2.30.0-2)
Replaces: gnome-utils (<< 2.30.0-2)
Description: system log viewer for GNOME
This program displays system log files in a friendly way and allows to
This program displays system log files in a friendly way and allows one to
filter or search expressions in them.
Package: gnome-font-viewer
......
Description: Don't use *_DISABLE_DEPRECATED, which breaks the build with
GLib 2.30.
Author: Jordi Mallach <jordi@debian.org>
Index: gnome-utils-3.2.1/gnome-dictionary/libgdict/Makefile.am
===================================================================
--- gnome-utils-3.2.1.orig/gnome-dictionary/libgdict/Makefile.am 2011-11-12 17:47:18.000000000 +0100
+++ gnome-utils-3.2.1/gnome-dictionary/libgdict/Makefile.am 2011-11-12 18:03:30.811008960 +0100
@@ -8,10 +8,6 @@
-DGNOMELOCALEDIR=\""$(gnomeutilslocaledir)"\" \
-DGDICTSOURCESDIR=\""$(datadir)/gdict-1.0/sources"\" \
-DGDICT_ENABLE_INTERNALS=1 \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -UGTK_DISABLE_DEPRECATED \
- -DPANGO_DISABLE_DEPRECATED \
-DG_DISABLE_SINGLE_INCLUDES \
-DGTK_DISABLE_SINGLE_INCLUDES \
$(NULL)
Index: gnome-utils-3.2.1/gsearchtool/libgnomeui-deprecated/Makefile.am
===================================================================
--- gnome-utils-3.2.1.orig/gsearchtool/libgnomeui-deprecated/Makefile.am 2011-11-12 17:47:18.000000000 +0100
+++ gnome-utils-3.2.1/gsearchtool/libgnomeui-deprecated/Makefile.am 2011-11-12 18:03:30.811008960 +0100
@@ -1,8 +1,3 @@
-INCLUDES = \
- -DGTK_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DG_DISABLE_DEPRECATED
-
noinst_LTLIBRARIES = libgnomeui-deprecated.la
libgnomeui_deprecated_la_CFLAGS = \
Index: gnome-utils-3.2.1/libeggsmclient/Makefile.am
===================================================================
--- gnome-utils-3.2.1.orig/libeggsmclient/Makefile.am 2011-11-12 17:47:18.000000000 +0100
+++ gnome-utils-3.2.1/libeggsmclient/Makefile.am 2011-11-12 18:03:30.819008962 +0100
@@ -1,7 +1,3 @@
-INCLUDES = -DGTK_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DG_DISABLE_DEPRECATED
-
noinst_LTLIBRARIES = libeggsmclient.la
libeggsmclient_la_LIBADD = $(LIBEGGSMCLIENT_LIBS) \
Index: gnome-utils-3.2.1/gsearchtool/Makefile.am
===================================================================
--- gnome-utils-3.2.1.orig/gsearchtool/Makefile.am 2011-09-27 23:27:36.000000000 +0200
+++ gnome-utils-3.2.1/gsearchtool/Makefile.am 2011-11-12 18:06:54.483013588 +0100
@@ -5,7 +5,6 @@
INCLUDES = \
-I$(srcdir)/libgnomeui-deprecated \
-I$(top_srcdir)/libeggsmclient \
- -DG_DISABLE_DEPRECATED \
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
-DLOCALEDIR=\"$(datadir)/locale\" \
-DDATADIR=\""$(datadir)"\" \
01_logview_gksu.patch
02_gdict-1.0_pc_requires.patch
03-don-t-abort-if-nautilus-schema-is-not-installed.patch
10_no_disable_deprecated.patch
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/autoreconf.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
include /usr/share/cdbs/1/rules/utils.mk
......@@ -10,6 +11,10 @@ include /usr/share/gnome-pkg-tools/1/rules/gnome-version.mk
DEB_CONFIGURE_EXTRA_FLAGS := --enable-ipv6=yes \
--disable-scrollkeeper
LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
DEB_DH_MAKESHLIBS_ARGS_libgdict-1.0-6 += -- -c4
clean::
rm -f po/.intltool-merge-cache
rm -f intltool-extract intltool-merge intltool-update
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment