Commit 944d1d51 authored by Laurent Bigonville's avatar Laurent Bigonville

[svn-buildpackage] Tagging brasero 3.11.4-1

parent 6bc2d798
usr/bin
usr/share/appdata
usr/share/applications
usr/share/man
usr/lib/nautilus/*/*.so
desktop-command-not-in-package usr/share/applications/brasero-nautilus.desktop nautilus
desktop-mime-but-no-exec-code usr/share/applications/brasero-nautilus.desktop
brasero (3.11.4-1) unstable; urgency=medium
* New upstream release
- Fix segfault at startup (Closes: #762453)
- Drop debian/patches/01_tracker-1.0.patch: Applied upstream
- Bump intltool build-dependency to 0.50
* debian/control.in:
- Update Homepage URL
- Bump Standards-Version to 3.9.6 (no further changes)
* debian/brasero.install: Install appdata file
* Add debian/brasero.lintian-overrides: Override warnings regarding
brasero-nautilus.desktop file, it's used for the nautilus extension
* Add d/p/01_fix-plugin-dialog-segfault.patch: Fix segfault when displaying
the plugin dialog
-- Laurent Bigonville <bigon@debian.org> Sat, 04 Oct 2014 15:48:52 +0200
brasero (3.10.0-2) unstable; urgency=medium
* Install typelib files into MA libdir.
......
......@@ -6,7 +6,7 @@ Source: brasero
Section: gnome
Priority: optional
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: Josselin Mouette <joss@debian.org>, Michael Biebl <biebl@debian.org>
Uploaders: Josselin Mouette <joss@debian.org>, Laurent Bigonville <bigon@debian.org>, Michael Biebl <biebl@debian.org>
Build-Depends: debhelper (>= 8),
autotools-dev,
dh-autoreconf,
......@@ -33,11 +33,11 @@ Build-Depends: debhelper (>= 8),
libtotem-plparser-dev (>= 2.32),
gobject-introspection (>= 0.6.3),
libgirepository1.0-dev (>= 0.6.3),
intltool (>= 0.35.0),
intltool (>= 0.50),
libglib2.0-doc,
libgtk-3-doc
Standards-Version: 3.9.5
Homepage: http://www.gnome.org/projects/brasero/
Standards-Version: 3.9.6
Homepage: https://wiki.gnome.org/Apps/Brasero
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/desktop/unstable/brasero/
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/brasero/
......
......@@ -29,11 +29,11 @@ Build-Depends: debhelper (>= 8),
libtotem-plparser-dev (>= 2.32),
gobject-introspection (>= 0.6.3),
libgirepository1.0-dev (>= 0.6.3),
intltool (>= 0.35.0),
intltool (>= 0.50),
libglib2.0-doc,
libgtk-3-doc
Standards-Version: 3.9.5
Homepage: http://www.gnome.org/projects/brasero/
Standards-Version: 3.9.6
Homepage: https://wiki.gnome.org/Apps/Brasero
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/desktop/unstable/brasero/
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/brasero/
......
From 492d99443a76e02ff16d128779fefc8083eb82ab Mon Sep 17 00:00:00 2001
From: Laurent Bigonville <bigon@bigon.be>
Date: Sat, 4 Oct 2014 15:31:19 +0200
Subject: [PATCH] Fix segfault when displaying the plugin dialog
This partially revert changes from
426841b445f8f62191f2b0569088e0da15c42068
https://bugzilla.gnome.org/show_bug.cgi?id=728376
---
src/brasero-plugin-manager-ui.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/src/brasero-plugin-manager-ui.c b/src/brasero-plugin-manager-ui.c
index bca5fd4..9fde757 100644
--- a/src/brasero-plugin-manager-ui.c
+++ b/src/brasero-plugin-manager-ui.c
@@ -241,16 +241,12 @@ plugin_manager_ui_view_icon_cell_cb (GtkTreeViewColumn *tree_column,
GtkTreeIter *iter,
gpointer data)
{
- BraseroPlugin *plugin;
g_return_if_fail (tree_model != NULL);
g_return_if_fail (tree_column != NULL);
- gtk_tree_model_get (tree_model, iter, PLUGIN_COLUMN, &plugin, -1);
-
g_object_set (G_OBJECT (cell),
"visible", FALSE,
- "sensitive", brasero_plugin_get_gtype (plugin) != G_TYPE_NONE && !brasero_plugin_get_compulsory (plugin),
NULL);
return;
/*
@@ -271,7 +267,7 @@ plugin_manager_ui_view_icon_cell_cb (GtkTreeViewColumn *tree_column,
"icon-name",
brasero_plugin_get_icon_name (plugin),
"sensitive",
- brasero_plugin_get_gtype (plugin) != G_TYPE_NONE,
+ brasero_plugin_get_gtype (plugin) != G_TYPE_NONE && !brasero_plugin_get_compulsory (plugin),
NULL);
*/
}
--
2.1.1
Index: brasero-3.10.0/configure.ac
===================================================================
--- brasero-3.10.0.orig/configure.ac 2013-11-25 17:10:50.000000000 +0100
+++ brasero-3.10.0/configure.ac 2014-05-10 01:21:24.465053883 +0200
@@ -388,7 +388,7 @@
if test x"$enable_search" != "xno"; then
# Try to figure out the tracker API version to use
tracker_api="0.10"
- m4_foreach([VERSION], [[0.10], [0.12], [0.14], [0.16]],
+ m4_foreach([VERSION], [[0.10], [0.12], [0.14], [0.16], [1.0]],
[PKG_CHECK_EXISTS([tracker-sparql-VERSION >= $TRACKER_REQUIRED],
[tracker_api="VERSION"])
])
01_tracker-1.0.patch
01_fix-plugin-dialog-segfault.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment