Commit a34904f1 authored by Jeremy Bicha's avatar Jeremy Bicha

releasing package devhelp version 3.28.0-1

parent a4b8834e
devhelp (3.28.0-1) UNRELEASED; urgency=medium
devhelp (3.28.0-1) experimental; urgency=medium
* New upstream release
* New upstream release
-- Tim Lunn <tim@feathertop.org> Sun, 11 Mar 2018 12:22:19 +1100
......@@ -235,7 +235,7 @@ devhelp (3.8.0-2) experimental; urgency=low
[ Jeremy Bicha ]
* debian/control.in, debian/rules:
- Use dh_python3
- Use dh_python3
[ Thomas Bechtold ]
* debian/rules: build against libwebkit2gtk
......@@ -417,11 +417,11 @@ devhelp (2.27.92-1) experimental; urgency=low
- added homepage field.
- added a B-D on libunique-dev, needed to the configure run to
work properly.
- libwebkit B-D bumped to >= 1.1.14, this is a new require for
- libwebkit B-D bumped to >= 1.1.14, this is a new require for
the new upstream release. (we need to upload this package to
experimental cause of this)
- added a B-D on libsoup2.4-0 (>= 2.27.92) to fix a FTBFS cause
a broken dependency on the webkit shared library.
a broken dependency on the webkit shared library.
- bumped libdevhelp binary to libdevhelp-1-1 to prevent a breakage
after the soname change.
- changed libdevhelp-1-dev dependency on libdevhelp-1-0 to
......@@ -597,16 +597,16 @@ devhelp (0.19-2) experimental; urgency=low
* Target to experimental; include check-dist.mk.
* Switch to quilt for patch handling; build-depend on quilt.
* Build-depend on xulrunner-dev and make libdevhelp depend on
* Build-depend on xulrunner-dev and make libdevhelp depend on
xulrunner-1.9.
* 02_gecko_1.9.patch:
* 02_gecko_1.9.patch:
+ Patch from Christian Kirbach to get devhelp to build against
libxul-embedding.
+ Modified to strip the -R flags from Makefile.am.
+ Augmented with the xpcomglue patch from Ubuntu.
+ Also include the prefs patch from Ubuntu to display colors
+ Also include the prefs patch from Ubuntu to display colors
correctly.
+ Modified to remove the libcppwrapper hack, which doesn't work
+ Modified to remove the libcppwrapper hack, which doesn't work
anymore because the dependency on libstdc++ is missing.
* Pass --with-gecko=libxul-embedding to use it. Closes: #480792.
* 70_autoconf.patch: run the autotools on top of that.
......@@ -653,7 +653,7 @@ devhelp (0.16.1-3) unstable; urgency=low
devhelp (0.16.1-2) unstable; urgency=low
* Orphaning the package
* Orphaning the package
-- Gustavo Noronha Silva <kov@debian.org> Sun, 11 Nov 2007 18:15:41 -0200
......@@ -931,7 +931,7 @@ devhelp (0.9.1-1) unstable; urgency=low
* debian/patches/04book_search_path_fix.patch:
- this came from upstream's CVS, and is in this release
so no longer needed
-- Gustavo Noronha Silva <kov@debian.org> Sat, 31 Jul 2004 12:54:20 -0300
devhelp (0.9-8) unstable; urgency=low
......@@ -997,7 +997,7 @@ devhelp (0.9-5) experimental; urgency=low
- libdevhelp-1-0 Replaces devhelp << 0.9-5 (this revision)
* debian/pacthes/01relibtoolize.diff:
- relibtoolize devhelp to remove uneeded dependencies
-- Gustavo Noronha Silva <kov@debian.org> Mon, 19 Apr 2004 19:07:03 -0300
devhelp (0.9-4) experimental; urgency=low
......@@ -1046,7 +1046,7 @@ devhelp (0.9-1) experimental; urgency=low
mozilla-dev >= 1.6
+ debian/devhelp.postinst:
- install the devhelp's schema file correctly
-- Gustavo Noronha Silva <kov@debian.org> Tue, 23 Mar 2004 18:30:30 -0300
devhelp (0.8.1-4) unstable; urgency=low
......@@ -1144,7 +1144,7 @@ devhelp (0.7-2) unstable; urgency=low
- adopting cdbs
- install all scripts from misc/ (Closes: #200055)
* debian/patches/00install-devhelp-el:
- edited misc/devhelp.el to enable the 'f7' keybinding
- edited misc/devhelp.el to enable the 'f7' keybinding
by default
* debian/copyright:
- updated information on author/site
......@@ -1155,7 +1155,7 @@ devhelp (0.7-1) unstable; urgency=low
* New upstream release
* debian/rules:
- does not install emacs and vim stuff myself, as upstream
- does not install emacs and vim stuff myself, as upstream
is taking care of that himself
- added aditional clean stuff to remove the marshallers
files that are auto-generated during the build
......@@ -1208,7 +1208,7 @@ devhelp (0.5.0-1) unstable; urgency=low
* New upstream release
* debian/rules:
- support nostrip on DEB_BUILD_OPTIONS
- support nostrip on DEB_BUILD_OPTIONS
-- Gustavo Noronha Silva <kov@debian.org> Sat, 12 Apr 2003 03:39:22 -0300
......@@ -1265,7 +1265,7 @@ devhelp (0.4-1) unstable; urgency=low
-- Gustavo Noronha Silva <kov@debian.org> Tue, 7 May 2002 21:55:29 +0000
devhelp (0.3-10) unstable; urgency=low
* Added entry to devhelp on the Debian menu system
(Closes: #141133)
......@@ -1347,17 +1347,17 @@ devhelp (0.3-3) unstable; urgency=low
-- Gustavo Noronha Silva <kov@debian.org> Thu, 28 Feb 2002 02:59:52 -0300
devhelp (0.3-2) unstable; urgency=low
* Built against latest libraries in unstable
-- Johan Dahlin <jdahlin@telia.com> Tue, 15 Jan 2002 16:38:30 -0400
devhelp (0.3-1) unstable; urgency=low
* New upstream release.
-- Johan Dahlin <jdahlin@telia.com> Sun, 1 Dec 2001 20:20:13 -0400
devhelp (0.2.0.99-1) unstable; urgency=low
* Initial release.
......
# This file is autogenerated. DO NOT EDIT!
#
#
# Modifications should be made to debian/control.in instead.
# This file is regenerated automatically in the clean target.
Source: devhelp
Section: devel
Priority: optional
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: Emilio Pozuelo Monfort <pochu@debian.org>, Jeremy Bicha <jbicha@debian.org>, Michael Biebl <biebl@debian.org>
Uploaders: Jeremy Bicha <jbicha@debian.org>, Michael Biebl <biebl@debian.org>, Tim Lunn <tim@feathertop.org>
Build-Depends: appstream-util,
autoconf-archive,
debhelper (>= 11),
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment