Commit 31fa93a5 authored by Laurent Bigonville's avatar Laurent Bigonville

* Add libgfbgraph-doc package to match what's existing in Ubuntu

* debian/control.in:
  - Use dh_autoreconf instead of autotools_dev
  - Fix GObject capitalisation in the descriptions
  - Add missing ${misc:Depends}, ${shlibs:Depends}
  - Add the Vcs-* fields
* debian/gir1.2-gfbgraph-0.2.install: Do not install .typelib file in
  multi-arch path
* debian/rules: Re-enable the tests but does not make their failure fatal
parent c788bf2e
gfbgraph (0.2.2-1) unstable; urgency=low
gfbgraph (0.2.2-1) UNRELEASED; urgency=low
[ Andreas Henriksson ]
* Initial release
* Disable tests as they try to access your facebook session
-- Andreas Henriksson <andreas@fatal.se> Fri, 07 Mar 2014 23:07:06 +0100
[ Laurent Bigonville ]
* Add libgfbgraph-doc package to match what's existing in Ubuntu
* debian/control.in:
- Use dh_autoreconf instead of autotools_dev
- Fix GObject capitalisation in the descriptions
- Add missing ${misc:Depends}, ${shlibs:Depends}
- Add the Vcs-* fields
* debian/gir1.2-gfbgraph-0.2.install: Do not install .typelib file in
multi-arch path
* debian/rules: Re-enable the tests but does not make their failure fatal
-- Laurent Bigonville <bigon@debian.org> Sat, 26 Apr 2014 13:01:17 +0200
......@@ -5,9 +5,10 @@
Source: gfbgraph
Priority: optional
Section: libs
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: Andreas Henriksson <andreas@fatal.se>
Build-Depends: autotools-dev,
Uploaders: Laurent Bigonville <bigon@debian.org>
Build-Depends: dh-autoreconf,
debhelper (>= 9),
gnome-pkg-tools,
gobject-introspection (>= 1.30.0),
......@@ -19,8 +20,18 @@ Build-Depends: autotools-dev,
librest-dev,
libsoup2.4-dev
Standards-Version: 3.9.5
Section: libs
Homepage: https://wiki.gnome.org/Projects/GFBGraph
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/packages/unstable/gfbgraph
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/packages/unstable/gfbgraph
Package: libgfbgraph-0.2-0
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
Multi-Arch: same
Description: GObject library for Facebook Graph API
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the actual library.
Package: libgfbgraph-0.2-dev
Section: libdevel
......@@ -31,27 +42,27 @@ Depends: libgfbgraph-0.2-0 (= ${binary:Version}),
libjson-glib-dev,
librest-dev,
libsoup2.4-dev,
gir1.2-gfbgraph-0.2
gir1.2-gfbgraph-0.2 (= ${binary:Version}),
${misc:Depends}
Description: GObject library for Facebook Graph API - development files
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the development files used when building
software that utilizes the library and API documentation.
This package contains the development files.
Package: libgfbgraph-0.2-0
Section: libs
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
Description: GObject library for Facebook Graph API
Package: libgfbgraph-doc
Architecture: all
Section: doc
Depends: ${misc:Depends}
Description: GObject library for Facebook Graph API - documentation
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the actual library.
This package contains the API documentation.
Package: gir1.2-gfbgraph-0.2
Section: introspection
Architecture: any
Depends: ${gir:Depends}, ${misc:Depends}
Description: GObject library for Facebook Graph API - gobject introspection
Depends: ${gir:Depends}, ${misc:Depends}, ${shlibs:Depends}
Description: GObject library for Facebook Graph API - GObject introspection
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the gobject introspection typelib.
This package contains the GObject introspection typelib.
Source: gfbgraph
Priority: optional
Section: libs
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: @GNOME_TEAM@
Build-Depends: autotools-dev,
Build-Depends: dh-autoreconf,
debhelper (>= 9),
gnome-pkg-tools,
gobject-introspection (>= 1.30.0),
......@@ -14,8 +15,18 @@ Build-Depends: autotools-dev,
librest-dev,
libsoup2.4-dev
Standards-Version: 3.9.5
Section: libs
Homepage: https://wiki.gnome.org/Projects/GFBGraph
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/packages/unstable/gfbgraph
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/packages/unstable/gfbgraph
Package: libgfbgraph-0.2-0
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
Multi-Arch: same
Description: GObject library for Facebook Graph API
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the actual library.
Package: libgfbgraph-0.2-dev
Section: libdevel
......@@ -26,27 +37,27 @@ Depends: libgfbgraph-0.2-0 (= ${binary:Version}),
libjson-glib-dev,
librest-dev,
libsoup2.4-dev,
gir1.2-gfbgraph-0.2
gir1.2-gfbgraph-0.2 (= ${binary:Version}),
${misc:Depends}
Description: GObject library for Facebook Graph API - development files
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the development files used when building
software that utilizes the library and API documentation.
This package contains the development files.
Package: libgfbgraph-0.2-0
Section: libs
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
Description: GObject library for Facebook Graph API
Package: libgfbgraph-doc
Architecture: all
Section: doc
Depends: ${misc:Depends}
Description: GObject library for Facebook Graph API - documentation
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the actual library.
This package contains the API documentation.
Package: gir1.2-gfbgraph-0.2
Section: introspection
Architecture: any
Depends: ${gir:Depends}, ${misc:Depends}
Description: GObject library for Facebook Graph API - gobject introspection
Depends: ${gir:Depends}, ${misc:Depends}, ${shlibs:Depends}
Description: GObject library for Facebook Graph API - GObject introspection
GFBGraph is a GLib/GObject wrapper for the Facebook API.
.
This package contains the gobject introspection typelib.
This package contains the GObject introspection typelib.
......@@ -5,11 +5,25 @@ Source: http://download.gnome.org/sources/gfbgraph/
Files: *
Copyright: 2013 Álvaro Peña <alvaropg@gmail.com>
License: LGPL-2.1+
On Debian systems, the complete text of the GNU Lesser General
Public License can be found in `/usr/share/common-licenses/LGPL-2.1'.
Files: debian/*
Copyright: 2014 Andreas Henriksson <andreas@fatal.se>
2014 Rico Tzschichholz <ricotz@ubuntu.com>
License: LGPL-2.1+
License: LGPL-2.1+
This package is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version.
.
This package is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
.
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
.
On Debian systems, the complete text of the GNU Lesser General
Public License can be found in `/usr/share/common-licenses/LGPL-2.1'.
Public License can be found in "/usr/share/common-licenses/LGPL-2.1".
usr/lib/*/girepository-1.0
usr/lib/*/girepository-1.0/* usr/lib/girepository-1.0
......@@ -3,4 +3,3 @@ usr/lib/*/lib*.a
usr/lib/*/lib*.so
usr/lib/*/pkgconfig/*
usr/share/gir-1.0
usr/share/gtk-doc
......@@ -3,7 +3,15 @@ include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
-include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk
%:
dh $@ --with autotools-dev,gir
dh $@ --with autoreconf,gir
override_dh_auto_configure:
dh_auto_configure -- \
--enable-gtk-doc \
--enable-introspection
override_dh_install:
dh_install -X.la --list-missing
override_dh_auto_test:
true
dh_auto_test || true
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment