...
 
Commits (2)
gnome-builder (3.31.91-2) experimental; urgency=medium
* Update dependencies for vala 0.44 series
-- Jeremy Bicha <jbicha@debian.org> Fri, 22 Feb 2019 08:09:49 -0500
gnome-builder (3.31.91-1) experimental; urgency=medium
* New upstream development release
......@@ -17,6 +23,15 @@ gnome-builder (3.31.90-1) experimental; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Thu, 07 Feb 2019 17:01:40 -0500
gnome-builder (3.30.3-2) unstable; urgency=medium
* Explicitly use vala 0.42 instead of virtual packages for dependencies:
- using virtual packages allows for no-longer-built-from-source (and
therefore unsupportable) versions to satisfy the dependency
* Update Vcs fields for debian/buster
-- Jeremy Bicha <jbicha@debian.org> Fri, 22 Feb 2019 07:48:45 -0500
gnome-builder (3.30.3-1) unstable; urgency=medium
* New upstream release
......
......@@ -37,7 +37,7 @@ Build-Depends: appstream-util,
libpcre3-dev,
libpeas-dev (>= 1.22.0),
libtemplate-glib-1.0-dev (>= 3.28.0),
libvala-dev,
libvala-0.44-dev,
libvte-2.91-dev (>= 0.46),
libwebkit2gtk-4.0-dev (>= 2.22),
libxml2-dev (>= 2.9.0),
......@@ -46,7 +46,7 @@ Build-Depends: appstream-util,
meson (>= 0.48.0),
mm-common,
sysprof (>= 3.31.90) [amd64 arm64 armel armhf i386 mips64el mipsel ppc64el alpha powerpcspe x32],
valac (>= 0.39.7),
valac (>= 0.43),
xauth <!nocheck>,
xvfb <!nocheck>,
# Don't (re)build libide api docs for now:
......@@ -69,8 +69,8 @@ Depends: exuberant-ctags,
gir1.2-peas-1.0 (>= 1.22.0),
gir1.2-webkit2-4.0 (>= 2.8.4),
python3-gi,
valac-vapi,
libvala-dev,
valac-0.44-vapi,
libvala-0.44-dev,
clang,
${gir:Depends},
${misc:Depends},
......
......@@ -33,7 +33,7 @@ Build-Depends: appstream-util,
libpcre3-dev,
libpeas-dev (>= 1.22.0),
libtemplate-glib-1.0-dev (>= 3.28.0),
libvala-dev,
libvala-0.44-dev,
libvte-2.91-dev (>= 0.46),
libwebkit2gtk-4.0-dev (>= 2.22),
libxml2-dev (>= 2.9.0),
......@@ -42,7 +42,7 @@ Build-Depends: appstream-util,
meson (>= 0.48.0),
mm-common,
sysprof (>= 3.31.90) [amd64 arm64 armel armhf i386 mips64el mipsel ppc64el alpha powerpcspe x32],
valac (>= 0.39.7),
valac (>= 0.43),
xauth <!nocheck>,
xvfb <!nocheck>,
# Don't (re)build libide api docs for now:
......@@ -65,8 +65,8 @@ Depends: exuberant-ctags,
gir1.2-peas-1.0 (>= 1.22.0),
gir1.2-webkit2-4.0 (>= 2.8.4),
python3-gi,
valac-vapi,
libvala-dev,
valac-0.44-vapi,
libvala-0.44-dev,
clang,
${gir:Depends},
${misc:Depends},
......