• Debarshi Ray's avatar
    Upgrade license to GNU General Public License version 3 or later · 78ea329f
    Debarshi Ray authored
    Even though the individual source files in this repository are under
    GNU General Public License version 2 or later, the final binaries were
    being implicitly upgraded to version 3 or later of the license by
    virtue of linking against libraries like Babl and GEGL that are under
    GNU Lesser General Public License version 3 or later. Since GPLv2 does
    not permit combinations with LGPLv3, the only way to distribute the
    combined work was under GPLv3+.
    
    See: https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility
    
    Let's clarify this by explicitly stating that this project is under
    GPLv3+ instead of pushing the burden of understanding how the code is
    linked together, and the licenses involved, on individual distributors.
    78ea329f
This project is licensed under the GNU General Public License v3.0. Learn more