Commit 11d1c9b3 authored by Debarshi Ray's avatar Debarshi Ray

build: Require newer Cairo for HiDpi support

We now have a Cairo release with HiDpi support. Let's just require it
instead of depending on distributions to ship snapshots.

Original patch from Bastien Nocera for totem.
parent bbf71a0e
......@@ -24,6 +24,7 @@ AC_SUBST(LIBM)
GLIB_GSETTINGS
CAIRO_MIN_VERSION=1.14.0
EXEMPI_MIN_VERSION=1.99.5
GDATA_MIN_VERSION=0.15.2
GFBGRAPH_MIN_VERSION=0.2.1
......@@ -82,7 +83,7 @@ fi
PKG_CHECK_MODULES(BABL, [babl])
PKG_CHECK_MODULES(CAIRO, [cairo cairo-gobject])
PKG_CHECK_MODULES(CAIRO, [cairo >= $CAIRO_MIN_VERSION cairo-gobject])
AC_DEFINE([HAVE_CAIRO_GOBJECT], [], [We want gegl-gtk to use the cairo-gobject code path])
PKG_CHECK_MODULES(EXEMPI, [exempi-2.0 >= $EXEMPI_MIN_VERSION])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment