Commit fb0ae296 authored by Debarshi Ray's avatar Debarshi Ray

configure: Bump minimum GLib version to 2.28

We want to use latest goodies like g_clear_object.
parent a3f89f3e
......@@ -22,6 +22,8 @@ AC_HEADER_STDC
AC_CHECK_LIBM
AC_SUBST(LIBM)
GLIB_MIN_VERSION=2.28
GNOME_COMMON_INIT
GNOME_COMPILE_WARNINGS([maximum])
GNOME_DEBUG_CHECK
......@@ -39,7 +41,7 @@ LT_INIT
PKG_CHECK_MODULES(CLUTTER, [clutter-1.0])
PKG_CHECK_MODULES(CLUTTER_GTK, [clutter-gtk-1.0])
PKG_CHECK_MODULES(GLIB, [glib-2.0])
PKG_CHECK_MODULES(GLIB, [glib-2.0 >= $GLIB_MIN_VERSION])
PKG_CHECK_MODULES(GIO, [gio-2.0])
PKG_CHECK_MODULES(GTK, [gtk+-3.0])
PKG_CHECK_MODULES(TRACKER, [tracker-sparql-0.14])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment