• Debarshi Ray's avatar
    build: Unbreak by adding missing definition of AX_APPEND_LINK_FLAGS · 0e546cda
    Debarshi Ray authored
    The second attempt at updating the AX_* macros in commit
    7ae86729 seem to have again broken the build:
      autoreconf: running: aclocal --force -I m4 -I libgd ${ACLOCAL_FLAGS}
      configure.ac:21: error: macro AX_APPEND_LINK_FLAGS is not defined;
        is a m4 file missing?
      m4/ax_require_defined.m4:35: AX_REQUIRE_DEFINED is expanded from...
      m4/ax_compiler_flags_ldflags.m4:30: AX_COMPILER_FLAGS_LDFLAGS is
        expanded from...
      m4/ax_compiler_flags.m4:113: AX_COMPILER_FLAGS is expanded from...
      configure.ac:21: the top level
    
    It is not clear why the build didn't break while testing commit
    7ae86729 or any of the subsequent ones after that. Continuous
    and the nightly Flatpak builds have also been chugging along without
    any problems. It's a mystery.
    
    Anyway, including the definition of AX_APPEND_LINK_FLAGS seems like
    the obvious thing to do.
    0e546cda
Name
Last commit
Last update
data Loading commit data...
flatpak Loading commit data...
help Loading commit data...
libgd @ 6085c294 Loading commit data...
m4 Loading commit data...
po Loading commit data...
src Loading commit data...
tests Loading commit data...
.gitmodules Loading commit data...
ARTISTS Loading commit data...
COPYING Loading commit data...
ChangeLog Loading commit data...
Makefile.am Loading commit data...
NEWS Loading commit data...
README Loading commit data...
autogen.sh Loading commit data...
configure.ac Loading commit data...
git.mk Loading commit data...
glib-tap.mk Loading commit data...
gnome-photos.doap Loading commit data...