INSTALL 1.28 KB
Newer Older
1 2 3 4 5 6
Prerequisites
=============

GTK+ requires the following packages:

 - The GLib, Pango, GdkPixbuf, ATK and cairo libraries, available at
7
   the same location as GTK+. GTK+ 3.24.10 requires at least
8
   GLib 2.53.4, Pango 1.41.0,
9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
   GdkPixbuf 2.30.0, ATK 2.15.1
   and cairo 1.14.0.

 - libepoxy, for cross-platform OpenGL support.
   It can be found here: https://github.com/anholt/libepoxy

 - Each GDK backend has its own backend-specific requirements. For
   the X11 backend, X11 R6 and XInput version 2 (as well as a number
   of other extensions) are required. The Wayland backend requires
   (obviously) the Wayland libraries.

 - gobject-introspection 1.39.0 or newer.

Simple install procedure
========================

25 26
  % tar xf gtk+-3.24.10.tar.xz          # unpack the sources
  % cd gtk+-3.24.10                     # change to the toplevel directory
27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
  % ./configure                        # run the `configure' script
  % make                               # build GTK+
  [ Become root if necessary ]
  % make install                       # install GTK+

The Details
===========

Complete information about installing GTK+ and related libraries
can be found in the file:

 docs/reference/gtk/html/gtk-building.html

Or online at:

 http://library.gnome.org/devel/gtk/stable/gtk-building.html