Commit 2dcd9457 authored by Jordi Mallach's avatar Jordi Mallach 🐗

* New upstream stable release.

* Enable GObject introspection support.
* Change section to gnome.
* Add the GTK+ version packages correspond to to the short description.
* Add trivial patch to fix a spelling fix in libgucharmap.
* Bump Standards-Version to 3.9.1 (no changes needed).
parent 8c3f7f4d
gucharmap (1:3.0.0-1) experimental; urgency=low
* New upstream stable release.
* Enable GObject introspection support.
* Change section to gnome.
* Add the GTK+ version packages correspond to to the short description.
* Add trivial patch to fix a spelling fix in libgucharmap.
* Bump Standards-Version to 3.9.1 (no changes needed).
-- Jordi Mallach <jordi@debian.org> Tue, 05 Apr 2011 20:17:32 +0200
gucharmap (1:2.33.2-1) experimental; urgency=low gucharmap (1:2.33.2-1) experimental; urgency=low
* New upstream development release. * New upstream development release.
......
...@@ -4,14 +4,18 @@ ...@@ -4,14 +4,18 @@
# This file is regenerated automatically in the clean target. # This file is regenerated automatically in the clean target.
Source: gucharmap Source: gucharmap
Section: x11 Section: gnome
Priority: optional Priority: optional
Maintainer: Sebastien Bacher <seb128@debian.org> Maintainer: Sebastien Bacher <seb128@debian.org>
Uploaders: David Weinehall <tao@debian.org>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Josselin Mouette <joss@debian.org>, Luca Falavigna <dktrkranz@debian.org> Uploaders: David Weinehall <tao@debian.org>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Jordi Mallach <jordi@debian.org>, Josselin Mouette <joss@debian.org>, Luca Falavigna <dktrkranz@debian.org>
Build-Depends: cdbs (>= 0.2.6), Build-Depends: cdbs (>= 0.2.6),
debhelper (>= 5), debhelper (>= 5),
gobject-introspection (>= 0.9.0),
libgirepository1.0-dev (>= 0.9.0),
gir1.2-pango-1.0,
gir1.2-gtk-3.0,
libgtk2.0-dev (>= 2.14.0), libgtk2.0-dev (>= 2.14.0),
libgtk-3-dev (>= 2.91.0), libgtk-3-dev (>= 3.0.0),
libglib2.0-dev (>= 2.16.3), libglib2.0-dev (>= 2.16.3),
libgconf2-dev, libgconf2-dev,
libpopt-dev, libpopt-dev,
...@@ -23,7 +27,7 @@ Build-Depends: cdbs (>= 0.2.6), ...@@ -23,7 +27,7 @@ Build-Depends: cdbs (>= 0.2.6),
gconf2, gconf2,
libglib2.0-doc, libglib2.0-doc,
libgtk2.0-doc libgtk2.0-doc
Standards-Version: 3.8.4 Standards-Version: 3.9.1
Vcs-Svn: svn://svn.debian.org/svn/pkg-gnome/desktop/unstable/gucharmap Vcs-Svn: svn://svn.debian.org/svn/pkg-gnome/desktop/unstable/gucharmap
Vcs-Browser: http://svn.debian.org/viewsvn/pkg-gnome/desktop/unstable/gucharmap Vcs-Browser: http://svn.debian.org/viewsvn/pkg-gnome/desktop/unstable/gucharmap
Homepage: http://live.gnome.org/Gucharmap Homepage: http://live.gnome.org/Gucharmap
...@@ -51,7 +55,7 @@ Depends: libgucharmap7 (= ${binary:Version}), ...@@ -51,7 +55,7 @@ Depends: libgucharmap7 (= ${binary:Version}),
libgconf2-dev libgconf2-dev
Replaces: libgucharmap-dev Replaces: libgucharmap-dev
Conflicts: libgucharmap-dev Conflicts: libgucharmap-dev
Description: Unicode browser widget library (development headers) Description: Unicode browser widget library (development headers for GTK+ 2)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
...@@ -63,7 +67,7 @@ Section: libs ...@@ -63,7 +67,7 @@ Section: libs
Architecture: any Architecture: any
Depends: ${shlibs:Depends}, Depends: ${shlibs:Depends},
${misc:Depends} ${misc:Depends}
Description: Unicode browser widget library (shared library) Description: Unicode browser widget library (shared library for GTK+ 2)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
...@@ -74,13 +78,14 @@ Package: libgucharmap-2-90-dev ...@@ -74,13 +78,14 @@ Package: libgucharmap-2-90-dev
Section: libdevel Section: libdevel
Architecture: any Architecture: any
Depends: libgucharmap-2-90-7 (= ${binary:Version}), Depends: libgucharmap-2-90-7 (= ${binary:Version}),
gir1.2-gucharmap-2.90 (= ${binary:Version}),
${misc:Depends}, ${misc:Depends},
libgtk-3-dev, libgtk-3-dev,
libglib2.0-dev, libglib2.0-dev,
libgconf2-dev libgconf2-dev
Replaces: libgucharmap-dev Replaces: libgucharmap-dev
Conflicts: libgucharmap-dev Conflicts: libgucharmap-dev
Description: Unicode browser widget library (development headers) Description: Unicode browser widget library (development headers for GTK+ 3)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
...@@ -92,9 +97,22 @@ Section: libs ...@@ -92,9 +97,22 @@ Section: libs
Architecture: any Architecture: any
Depends: ${shlibs:Depends}, Depends: ${shlibs:Depends},
${misc:Depends} ${misc:Depends}
Description: Unicode browser widget library (shared library) Description: Unicode browser widget library (shared library for GTK+ 3)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
. .
This package contains the shared library for the GTK+ 3 version. This package contains the shared library for the GTK+ 3 version.
Package: gir1.2-gucharmap-2.90
Section: libs
Architecture: any
Depends: ${gir:Depends},
${misc:Depends}
Description: GObject introspection data for the Unicode browser widget library
The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of
the same name for more information.
.
This package contains introspection data for the Unicode browser widget
library.
Source: gucharmap Source: gucharmap
Section: x11 Section: gnome
Priority: optional Priority: optional
Maintainer: Sebastien Bacher <seb128@debian.org> Maintainer: Sebastien Bacher <seb128@debian.org>
Uploaders: @GNOME_TEAM@ Uploaders: @GNOME_TEAM@
Build-Depends: cdbs (>= 0.2.6), Build-Depends: cdbs (>= 0.2.6),
debhelper (>= 5), debhelper (>= 5),
gobject-introspection (>= 0.9.0),
libgirepository1.0-dev (>= 0.9.0),
gir1.2-pango-1.0,
gir1.2-gtk-3.0,
libgtk2.0-dev (>= 2.14.0), libgtk2.0-dev (>= 2.14.0),
libgtk-3-dev (>= 2.91.0), libgtk-3-dev (>= 3.0.0),
libglib2.0-dev (>= 2.16.3), libglib2.0-dev (>= 2.16.3),
libgconf2-dev, libgconf2-dev,
libpopt-dev, libpopt-dev,
...@@ -18,7 +22,7 @@ Build-Depends: cdbs (>= 0.2.6), ...@@ -18,7 +22,7 @@ Build-Depends: cdbs (>= 0.2.6),
gconf2, gconf2,
libglib2.0-doc, libglib2.0-doc,
libgtk2.0-doc libgtk2.0-doc
Standards-Version: 3.8.4 Standards-Version: 3.9.1
Vcs-Svn: svn://svn.debian.org/svn/pkg-gnome/desktop/unstable/gucharmap Vcs-Svn: svn://svn.debian.org/svn/pkg-gnome/desktop/unstable/gucharmap
Vcs-Browser: http://svn.debian.org/viewsvn/pkg-gnome/desktop/unstable/gucharmap Vcs-Browser: http://svn.debian.org/viewsvn/pkg-gnome/desktop/unstable/gucharmap
Homepage: http://live.gnome.org/Gucharmap Homepage: http://live.gnome.org/Gucharmap
...@@ -46,7 +50,7 @@ Depends: libgucharmap7 (= ${binary:Version}), ...@@ -46,7 +50,7 @@ Depends: libgucharmap7 (= ${binary:Version}),
libgconf2-dev libgconf2-dev
Replaces: libgucharmap-dev Replaces: libgucharmap-dev
Conflicts: libgucharmap-dev Conflicts: libgucharmap-dev
Description: Unicode browser widget library (development headers) Description: Unicode browser widget library (development headers for GTK+ 2)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
...@@ -58,7 +62,7 @@ Section: libs ...@@ -58,7 +62,7 @@ Section: libs
Architecture: any Architecture: any
Depends: ${shlibs:Depends}, Depends: ${shlibs:Depends},
${misc:Depends} ${misc:Depends}
Description: Unicode browser widget library (shared library) Description: Unicode browser widget library (shared library for GTK+ 2)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
...@@ -69,13 +73,14 @@ Package: libgucharmap-2-90-dev ...@@ -69,13 +73,14 @@ Package: libgucharmap-2-90-dev
Section: libdevel Section: libdevel
Architecture: any Architecture: any
Depends: libgucharmap-2-90-7 (= ${binary:Version}), Depends: libgucharmap-2-90-7 (= ${binary:Version}),
gir1.2-gucharmap-2.90 (= ${binary:Version}),
${misc:Depends}, ${misc:Depends},
libgtk-3-dev, libgtk-3-dev,
libglib2.0-dev, libglib2.0-dev,
libgconf2-dev libgconf2-dev
Replaces: libgucharmap-dev Replaces: libgucharmap-dev
Conflicts: libgucharmap-dev Conflicts: libgucharmap-dev
Description: Unicode browser widget library (development headers) Description: Unicode browser widget library (development headers for GTK+ 3)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
...@@ -87,9 +92,22 @@ Section: libs ...@@ -87,9 +92,22 @@ Section: libs
Architecture: any Architecture: any
Depends: ${shlibs:Depends}, Depends: ${shlibs:Depends},
${misc:Depends} ${misc:Depends}
Description: Unicode browser widget library (shared library) Description: Unicode browser widget library (shared library for GTK+ 3)
The libgucharmap library contains a Unicode browser widget; it is The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of most prominently used by the "gucharmap" program. See the package of
the same name for more information. the same name for more information.
. .
This package contains the shared library for the GTK+ 3 version. This package contains the shared library for the GTK+ 3 version.
Package: gir1.2-gucharmap-2.90
Section: libs
Architecture: any
Depends: ${gir:Depends},
${misc:Depends}
Description: GObject introspection data for the Unicode browser widget library
The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of
the same name for more information.
.
This package contains introspection data for the Unicode browser widget
library.
debian/tmp/usr/lib/girepository-1.0/Gucharmap-2.90.typelib
...@@ -2,3 +2,4 @@ debian/tmp/usr/include /usr ...@@ -2,3 +2,4 @@ debian/tmp/usr/include /usr
debian/tmp/usr/lib/libgucharmap*.so /usr/lib debian/tmp/usr/lib/libgucharmap*.so /usr/lib
debian/tmp/usr/lib/pkgconfig/ /usr/lib debian/tmp/usr/lib/pkgconfig/ /usr/lib
debian/tmp/usr/share/gtk-doc /usr/share debian/tmp/usr/share/gtk-doc /usr/share
debian/tmp/usr/share/gir-1.0 /usr/share
spelling_fixes.patch
99_ltmain_as-needed.patch 99_ltmain_as-needed.patch
Description: Fix spelling of "especially".
Author: Jordi Mallach <jordi@debian.org>
Index: gucharmap-3.0.0.obsolete.0.250812289378704/gucharmap/unicode-unihan.h
===================================================================
--- gucharmap-3.0.0.obsolete.0.250812289378704.orig/gucharmap/unicode-unihan.h 2011-04-05 20:08:55.284183165 +0200
+++ gucharmap-3.0.0.obsolete.0.250812289378704/gucharmap/unicode-unihan.h 2011-04-05 20:09:21.648183157 +0200
@@ -28472,7 +28472,7 @@
"(ancient form of 史) history; chronicles; annals\0"
"SHI3\0"
"caat3\0"
- "(same as U+5237 刷) a brush, to brush; to clean; to scrub, to print, expecially from blocks\0"
+ "(same as U+5237 刷) a brush, to brush; to clean; to scrub, to print, especially from blocks\0"
"wai2\0"
"(same as 喟) to sign; to lament, to stop, to cut off; to sever; to interrupt\0"
"KUI4\0"
@@ -31122,7 +31122,7 @@
"a peaceful or easy mood; calm at mind, to move; to turn the mind, conversion\0"
"LU4\0"
"ci2 zi3\0"
- "(ancient form of 懿) virtuous, expecially women, admirable; esteemed; excellent\0"
+ "(ancient form of 懿) virtuous, especially women, admirable; esteemed; excellent\0"
"YI4\0"
"waa4\0"
"lavish; luxurious, wasteful\0"
@@ -36302,7 +36302,7 @@
"a kind of grains, to plant; to sow; to cultivate\0"
"MAN2\0"
"hing1\0"
- "(same as 馨) fragrance or aroma (expecially that which comes from after), (same as 榖) grains and corns; cereals\0"
+ "(same as 馨) fragrance or aroma (especially that which comes from after), (same as 榖) grains and corns; cereals\0"
"GU3\0"
"sam4\0"
"starting to put forth ears, a kind of grain\0"
@@ -42043,7 +42043,7 @@
"(same as 冑) descendants; posterity, a helmet; a head-gear in ancient battles for protection\0"
"ZHOU4\0"
"pau4\0"
- "(non-classical form of 鞄) to tan and soften leather, (same as 匏) a bottle-gourd, one of the eight kinds of musical sounds, a kind of musical instrument, (interchangeable 枹) a drum-stick (interchangeable 包) handbag or purse (expecially one made of leather)\0"
+ "(non-classical form of 鞄) to tan and soften leather, (same as 匏) a bottle-gourd, one of the eight kinds of musical sounds, a kind of musical instrument, (interchangeable 枹) a drum-stick (interchangeable 包) handbag or purse (especially one made of leather)\0"
"PAO2\0"
"a saddle-flap, trappings\0"
"NIAN2 TIAN3 TIE2 WEI3\0"
...@@ -23,6 +23,7 @@ $(DEB_BUILDDIR_gucharmap)/config.status: ...@@ -23,6 +23,7 @@ $(DEB_BUILDDIR_gucharmap)/config.status:
$(cdbs_configure_flags) \ $(cdbs_configure_flags) \
$(DEB_CONFIGURE_EXTRA_FLAGS) \ $(DEB_CONFIGURE_EXTRA_FLAGS) \
--with-gtk=3.0 \ --with-gtk=3.0 \
--enable-introspection \
$(DEB_CONFIGURE_USER_FLAGS) $(DEB_CONFIGURE_USER_FLAGS)
build/gucharmap:: build/gucharmap::
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment