updated 00_relibtoolise.patch and made the changes needed by the soname bump

parent e97bc73f
......@@ -2,6 +2,7 @@ gucharmap (1:1.8.0-1) experimental; urgency=low
[ Guilherme de S. Pastore ]
* New upstream release.
- made the necessary changes for the soname bump.
* debian/control.in:
- bumped Standards-Version to 3.7.2.
......@@ -9,12 +10,14 @@ gucharmap (1:1.8.0-1) experimental; urgency=low
* debian/copyright: updated URL and list of authors.
* debian/patches/00_relibtoolise.patch: updated.
* debian/watch: updated.
[ Josselin Mouette ]
* Recommend yelp (closes: #367305).
-- Guilherme de S. Pastore <gpastore@debian.org> Fri, 22 Sep 2006 19:56:05 -0300
-- Guilherme de S. Pastore <gpastore@debian.org> Fri, 22 Sep 2006 20:38:47 -0300
gucharmap (1:1.6.0-1) unstable; urgency=low
......
......@@ -8,7 +8,7 @@ Standards-Version: 3.7.2
Package: gucharmap
Architecture: any
Depends: ${shlibs:Depends}, scrollkeeper, libgucharmap4 (= ${Source-Version}), libgtk2.0-bin
Depends: ${shlibs:Depends}, scrollkeeper, libgucharmap5 (= ${Source-Version}), libgtk2.0-bin
Recommends: yelp
Conflicts: charmap
Replaces: gnome-utils
......@@ -18,12 +18,12 @@ Description: Unicode character picker and font browser
their detailed properties. It is an easy way to find the character
you might only know by its Unicode name or code point.
Package: libgucharmap4-dev
Package: libgucharmap5-dev
Section: libdevel
Architecture: any
Depends: libgucharmap4 (= ${Source-Version}), libgtk2.0-dev (>= 2.2.0)
Replaces: libgucharmap0-dev (= 1:1.0.0-1), libgucharmap3-dev
Conflicts: libgucharmap0-dev (= 1:1.0.0-1), libgucharmap3-dev
Depends: libgucharmap5 (= ${Source-Version}), libgtk2.0-dev (>= 2.2.0)
Replaces: libgucharmap0-dev (= 1:1.0.0-1), libgucharmap3-dev, libgucharmap4-dev
Conflicts: libgucharmap0-dev (= 1:1.0.0-1), libgucharmap3-dev, libgucharmap4-dev
Description: Unicode browser widget library (development headers)
The libgucharmap library contains a Unicode browser widget; it is
most prominently used by the "gucharmap" program. See the package of
......@@ -31,7 +31,7 @@ Description: Unicode browser widget library (development headers)
.
This package contains the development headers.
Package: libgucharmap4
Package: libgucharmap5
Section: libs
Architecture: any
Depends: ${shlibs:Depends}
......
This diff is collapsed.
......@@ -2,8 +2,8 @@
# -*- mode: makefile; coding: utf-8 -*-
# Copyright © 2003 Colin Walters <walters@verbum.org>
# ensure gucharmap is built after libgucharmap4
binary/gucharmap:: binary/libgucharmap4
# ensure gucharmap is built after libgucharmap5
binary/gucharmap:: binary/libgucharmap5
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
......@@ -11,7 +11,7 @@ include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/gnome.mk
include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
DEB_SHLIBDEPS_INCLUDE_gucharmap += debian/libgucharmap4/usr/lib/
DEB_SHLIBDEPS_INCLUDE_gucharmap += debian/libgucharmap5/usr/lib/
clean::
rm -f intltool-extract intltool-merge intltool-update
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment