...
 
Commits (12)
1.2.0
=====
- Release 1.2.0
1.1.2
=====
- Use python3 in binding tool
......
gupnp (1.2.0-1) experimental; urgency=medium
* New upstream release
* Bump minimum libglib2.0-dev to 2.58
* Add include-version-in-manpage.patch:
- Needed to make the package co-installable (Closes: #923576)
-- Jeremy Bicha <jbicha@debian.org> Sun, 17 Mar 2019 08:04:12 -0400
gupnp (1.1.2-1) experimental; urgency=medium
* New upstream development release
......
......@@ -12,7 +12,7 @@ Build-Depends: debhelper (>= 11),
gnome-pkg-tools,
ca-certificates <!nocheck>,
uuid-dev,
libglib2.0-dev (>= 2.4),
libglib2.0-dev (>= 2.58),
libsoup2.4-dev (>= 2.48.0),
libxml2-dev,
libgssdp-doc,
......@@ -59,6 +59,7 @@ Architecture: any
Multi-Arch: same
Depends: libgupnp-1.2-0 (= ${binary:Version}),
gir1.2-gupnp-1.2 (= ${binary:Version}),
libglib2.0-dev (>= 2.58),
libgssdp-1.2-dev,
libsoup2.4-dev,
libxml2-dev,
......
......@@ -8,7 +8,7 @@ Build-Depends: debhelper (>= 11),
gnome-pkg-tools,
ca-certificates <!nocheck>,
uuid-dev,
libglib2.0-dev (>= 2.4),
libglib2.0-dev (>= 2.58),
libsoup2.4-dev (>= 2.48.0),
libxml2-dev,
libgssdp-doc,
......@@ -55,6 +55,7 @@ Architecture: any
Multi-Arch: same
Depends: libgupnp-1.2-0 (= ${binary:Version}),
gir1.2-gupnp-1.2 (= ${binary:Version}),
libglib2.0-dev (>= 2.58),
libgssdp-1.2-dev,
libsoup2.4-dev,
libxml2-dev,
......
From: Jeremy Bicha <jbicha@debian.org>
Date: Sun, 17 Mar 2019 07:58:26 -0400
Subject: include version in manpage
https://bugs.debian.org/923576
https://gitlab.gnome.org/GNOME/gupnp/issues/6
---
doc/gupnp-binding-tool.xml | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/doc/gupnp-binding-tool.xml b/doc/gupnp-binding-tool.xml
index 35f5dc3..48e6f8d 100644
--- a/doc/gupnp-binding-tool.xml
+++ b/doc/gupnp-binding-tool.xml
@@ -1,22 +1,22 @@
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
-<refentry id="gupnp-binding-tool" xmlns:xi="http://www.w3.org/2003/XInclude">
+<refentry id="gupnp-binding-tool-1.2" xmlns:xi="http://www.w3.org/2003/XInclude">
<refmeta>
- <refentrytitle>gupnp-binding-tool</refentrytitle>
+ <refentrytitle>gupnp-binding-tool-1.2</refentrytitle>
<manvolnum>1</manvolnum>
<refmiscinfo class="source">GUPnP</refmiscinfo>
<refmiscinfo class="version"><xi:include href="version.xml" parse="text"/></refmiscinfo>
</refmeta>
<refnamediv>
- <refname>gupnp-binding-tool</refname>
+ <refname>gupnp-binding-tool-1.2</refname>
<refpurpose>creates C convenience wrappers for UPnP services</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
- <command>gupnp-binding-tool</command>
+ <command>gupnp-binding-tool-1.2</command>
<arg choice="opt">--prefix <arg choice="req">PREFIX</arg></arg>
<arg choice="opt">--mode <arg choice="req">client|server</arg></arg>
<arg choice="req">SCPD file</arg>
@@ -26,7 +26,7 @@
<refsect1>
<title>Description</title>
<para>
- <command>gupnp-binding-tool</command> takes a <glossterm
+ <command>gupnp-binding-tool-1.2</command> takes a <glossterm
linkend="scpd">SCPD file</glossterm> and generates convenience C functions
which call the actual GUPnP functions. The client-side bindings can be seen
as a service-specific version of the GUPnPServiceProxy API and the
@@ -169,7 +169,7 @@ igd_external_ip_address_variable_notify (GUPnPService *service,
variable value.
</para>
<para>
- All of the examples were produced with <filename>gupnp-binding-tool
+ All of the examples were produced with <filename>gupnp-binding-tool-1.2
--prefix igd --mode server WANIPConnection.xml</filename>.
</para>
</refsect1>
disable-multicast-tests.patch
include-version-in-manpage.patch
......@@ -33,7 +33,7 @@ override_dh_installman:
xsltproc --novalid --nonet --xinclude -o debian/stripped-docs.xml debian/strip-manpages.xsl doc/gupnp-binding-tool.xml
xsltproc --novalid --nonet /usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl debian/stripped-docs.xml
rm -f debian/stripped-docs.xml
dh_installman -p libgupnp-1.2-dev gupnp-binding-tool.1
dh_installman -p libgupnp-1.2-dev gupnp-binding-tool-1.2.1
dh_installman --remaining-packages
override_dh_missing:
......
version=4
https://download.gnome.org/sources/@PACKAGE@/([\d\.]+)/ \
https://download.gnome.org/sources/@PACKAGE@/([\d\.]+[02468])/ \
@PACKAGE@@ANY_VERSION@\.tar\.xz
......@@ -24,7 +24,7 @@
#include <glib.h>
#include <glib-object.h>
#include <libsoup/soup-session.h>
#include <gio/gio.h>
G_BEGIN_DECLS
......
project('gupnp', 'c', version : '1.1.2')
project('gupnp', 'c', version : '1.2.0')
gnome = import('gnome')
pkg = import('pkgconfig')
......@@ -19,11 +19,11 @@ add_global_arguments('-DHAVE_CONFIG_H=1', language : 'c')
guul = subproject('guul', default_options : ['default_library=static'])
dependencies = [
dependency('glib-2.0', version : '>= 2.44'),
dependency('gio-2.0', version : '>= 2.44'),
dependency('glib-2.0', version : '>= 2.58'),
dependency('gio-2.0', version : '>= 2.58'),
dependency('gmodule-2.0', version : '>= 2.44'),
dependency('gobject-2.0', version : '>= 2.44'),
dependency('gssdp-1.2', version : '>= 1.1'),
dependency('gssdp-1.2', version : '>= 1.1.3'),
dependency('libsoup-2.4', version : '>= 2.48.0'),
dependency('libxml-2.0'),
guul.get_variable('guul')
......