Commit c421f840 authored by Michael Biebl's avatar Michael Biebl

Convert to multiarch.

parent ed14bc6f
......@@ -4,6 +4,7 @@ libxml++2.6 (2.38.0-1) UNRELEASED; urgency=medium
* Use default automake version.
* Bump shlibs version to 2.38.0.
* Bump Build-Depends on mm-common to (>= 0.9.7) as per configure.ac.
* Convert to multiarch.
-- Michael Biebl <biebl@debian.org> Tue, 19 May 2015 00:18:09 +0200
......
......@@ -10,8 +10,8 @@ Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.o
Homepage: http://libxmlplusplus.sourceforge.net/
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/packages/unstable/libxml++2.6
Vcs-Svn: svn://svn.debian.org/pkg-gnome/packages/unstable/libxml++2.6
Build-Depends: cdbs (>= 0.4.51),
debhelper (>= 8),
Build-Depends: cdbs (>= 0.4.93~),
debhelper (>= 9),
dh-autoreconf,
automake,
autotools-dev,
......@@ -25,6 +25,7 @@ Standards-Version: 3.9.4
Package: libxml++2.6-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${misc:Depends},
${shlibs:Depends},
libxml++2.6-2 (= ${binary:Version}),
......@@ -43,6 +44,8 @@ Description: C++ interface to the GNOME XML library (libxml2)
Package: libxml++2.6-2
Section: libs
Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends},
${shlibs:Depends}
Replaces: libxml++2.6c2a
......@@ -59,6 +62,7 @@ Package: libxml++2.6-dbg
Section: debug
Priority: extra
Architecture: any
Multi-Arch: same
Depends: ${misc:Depends},
${shlibs:Depends},
libxml++2.6-2 (= ${binary:Version})
......@@ -73,6 +77,7 @@ Description: C++ interface to the GNOME XML library (debug symbols)
Package: libxml++2.6-doc
Section: doc
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends},
${shlibs:Depends},
doc-base,
......
......@@ -6,8 +6,8 @@ Uploaders: @GNOME_TEAM@
Homepage: http://libxmlplusplus.sourceforge.net/
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/packages/unstable/libxml++2.6
Vcs-Svn: svn://svn.debian.org/pkg-gnome/packages/unstable/libxml++2.6
Build-Depends: cdbs (>= 0.4.51),
debhelper (>= 8),
Build-Depends: cdbs (>= 0.4.93~),
debhelper (>= 9),
dh-autoreconf,
automake,
autotools-dev,
......@@ -21,6 +21,7 @@ Standards-Version: 3.9.4
Package: libxml++2.6-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${misc:Depends},
${shlibs:Depends},
libxml++2.6-2 (= ${binary:Version}),
......@@ -39,6 +40,8 @@ Description: C++ interface to the GNOME XML library (libxml2)
Package: libxml++2.6-2
Section: libs
Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends},
${shlibs:Depends}
Replaces: libxml++2.6c2a
......@@ -55,6 +58,7 @@ Package: libxml++2.6-dbg
Section: debug
Priority: extra
Architecture: any
Multi-Arch: same
Depends: ${misc:Depends},
${shlibs:Depends},
libxml++2.6-2 (= ${binary:Version})
......@@ -69,6 +73,7 @@ Description: C++ interface to the GNOME XML library (debug symbols)
Package: libxml++2.6-doc
Section: doc
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends},
${shlibs:Depends},
doc-base,
......
usr/lib/libxml++-2.6.so.*
usr/lib/*/libxml++-2.6.so.*
usr/include
usr/lib/libxml++-2.6
usr/lib/lib*.a
usr/lib/lib*.so
usr/lib/pkgconfig
usr/lib/*/libxml++-2.6
usr/lib/*/lib*.a
usr/lib/*/lib*.so
usr/lib/*/pkgconfig
......@@ -19,7 +19,8 @@ SHVER := 2.38.0
LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
DEB_CONFIGURE_EXTRA_FLAGS += --enable-static
DEB_CONFIGURE_EXTRA_FLAGS += --enable-static \
--libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
DEB_MAKE_CHECK_TARGET := check
DEB_DH_MAKESHLIBS_ARGS_$(SHARED_PKG) += -V"$(SHARED_PKG) (>= $(SHVER))"
DEB_INSTALL_EXAMPLES_$(DOC_PKG) += -XMakefile -X.deps -X.libs -X.o
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment