Commit ce298341 authored by Murray Cumming's avatar Murray Cumming

Add -Wformat-security to --enable-warnings=fatal.

Because we use it in glibmm too. No code changes were necessary.
parent 87df2752
......@@ -44,7 +44,7 @@ MM_ARG_WITH_TAGFILE_DOC([glibmm-2.4.tag], [glibmm-2.4])
# Evaluate the --enable-warnings=level option.
MM_ARG_ENABLE_WARNINGS([LIBXMLXX_WXXFLAGS],
[-Wall],
[-pedantic -Wall -Wextra -Wshadow -Wno-long-long],
[-pedantic -Wall -Wextra -Wformat-security -Wshadow -Wno-long-long],
[G GLIBMM SIGCXX])
# Offer the ability to omit some API from the library.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment