Commit 494e0308 authored by Jeremy Bicha's avatar Jeremy Bicha

Build against tracker2

* Add 003-build-with-tracker2.patch
* debian/control.in:
  - Build-Depends on libtracker-sparql-2.0-dev instead of 1.0
parent 16bd72d8
......@@ -5,6 +5,9 @@ rygel (0.32.1-5) UNRELEASED; urgency=medium
[ Jeremy Bicha ]
* Add 002-fix-build-with-vala36.patch (Closes: #873867)
* Add 003-build-with-tracker2.patch
* debian/control.in:
- Build-Depends on libtracker-sparql-2.0-dev instead of 1.0
-- Jeremy Bicha <jbicha@debian.org> Wed, 13 Sep 2017 16:44:22 -0400
......
......@@ -6,7 +6,7 @@ Source: rygel
Section: net
Priority: extra
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: Andreas Henriksson <andreas@fatal.se>, Emilio Pozuelo Monfort <pochu@debian.org>, Laurent Bigonville <bigon@debian.org>
Uploaders: Andreas Henriksson <andreas@fatal.se>, Emilio Pozuelo Monfort <pochu@debian.org>, Jeremy Bicha <jbicha@debian.org>, Laurent Bigonville <bigon@debian.org>
Build-Depends: debhelper (>= 10),
gnome-pkg-tools,
gobject-introspection,
......@@ -25,7 +25,7 @@ Build-Depends: debhelper (>= 10),
libmediaart-2.0-dev (>= 0.7.0),
libsoup2.4-dev (>= 2.44.0),
libsqlite3-dev (>= 3.5),
libtracker-sparql-1.0-dev | libtracker-sparql-0.16-dev,
libtracker-sparql-2.0-dev,
libunistring-dev,
libxml2-dev (>= 2.7),
valac (>= 0.24.0),
......@@ -74,6 +74,7 @@ Depends: libgstreamer1.0-dev,
librygel-db-2.6-2 (= ${binary:Version}),
librygel-renderer-2.6-2 (= ${binary:Version}),
librygel-renderer-gst-2.6-2 (= ${binary:Version}),
librygel-ruih-2.0-1 (= ${binary:Version}),
librygel-server-2.6-2 (= ${binary:Version}),
${misc:Depends}
Replaces: rygel-1.0-dev, rygel-2.0-dev, rygel-2.4-dev
......
......@@ -21,7 +21,7 @@ Build-Depends: debhelper (>= 10),
libmediaart-2.0-dev (>= 0.7.0),
libsoup2.4-dev (>= 2.44.0),
libsqlite3-dev (>= 3.5),
libtracker-sparql-1.0-dev | libtracker-sparql-0.16-dev,
libtracker-sparql-2.0-dev,
libunistring-dev,
libxml2-dev (>= 2.7),
valac (>= 0.24.0),
......
From 8cfa5462bae9fce7e2abffe5d82c539e2df28897 Mon Sep 17 00:00:00 2001
From: Carlos Garnacho <carlosg@gnome.org>
Date: Wed, 28 Jun 2017 23:24:20 +0200
Subject: build: Include tracker-sparql-2.0 in checks
Checked to be compatible for rygel purposes, and expected to remain
like that.
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 20d6893..00b94da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -421,7 +421,7 @@ AS_IF([test "x$enable_tracker_plugin" = "xyes"],
[
# Search available Tracker version
trackerpkg=""
- m4_foreach([VERSION], [[1.0], [0.16], [0.15], [0.14]],
+ m4_foreach([VERSION], [[2.0], [1.0], [0.16], [0.15], [0.14]],
[PKG_CHECK_EXISTS([tracker-sparql-VERSION >= $TRACKER_SPARQL_REQUIRED_MIN],
[ trackerpkg="tracker-sparql-VERSION"
tracker_api_version="VERSION"
001-disable-rygel-media-engine-test.patcb
002-fix-build-with-vala36.patch
003-build-with-tracker2.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment