...
 
Commits (11)
......@@ -2,6 +2,8 @@
Type=Application
Version=1.0
Name=FTP
Comment=FTP client for GNUstep
Categories=FileTransfer;Network;
Keywords=ftp;transfer;
Exec=FTP
Icon=/usr/share/pixmaps/FTP.xpm
Icon=/usr/share/GNUstep/FTP.app/FTP_icon_gs.tif
ftp.app (0.6-2) UNRELEASED; urgency=medium
* Team upload.
* debian/compat: Bump to 11.
* debian/rules: Rewrite for modern dh. Don't convert/install the .xpm
icon (Closes: #897524). Use standard variables; enable all hardening.
* debian/control: Run wrap-and-sort -ast for diff-friendliness.
(Build-Depends): Drop imagemagick. Bump debhelper to >= 11. Require
gnustep-make >= 2.7.0-3 for the optim variable definition.
(Depends): Drop ${gnustep:Depends}; obsolete.
(Vcs-Git, Vcs-Browser): Switch to Salsa.
* debian/menu: Delete as per current policy requirement.
* debian/dirs: Replace usr/bin with usr/share/GNUstep.
* debian/install: New file; install the .desktop file.
* debian/preinst: Delete; no longer needed.
* debian/FTP.desktop: Use the .tif icon, add Keywords and Comment keys.
* debian/watch: Upgrade to version 4, use Savannah's mirror redirector.
-- Yavor Doganov <yavor@gnu.org> Sun, 13 May 2018 08:46:13 +0300
......
......@@ -2,16 +2,22 @@ Source: ftp.app
Section: gnustep
Priority: optional
Maintainer: Federico Gimenez Nieto <fgimenez@coit.es>
Uploaders: Debian GNUstep maintainers <pkg-gnustep-maintainers@lists.alioth.debian.org>
Build-Depends: debhelper (>= 10), libgnustep-gui-dev, gnustep-make, imagemagick
Uploaders:
Debian GNUstep maintainers <pkg-gnustep-maintainers@lists.alioth.debian.org>,
Build-Depends:
debhelper (>= 11),
gnustep-make (>= 2.7.0-3),
libgnustep-gui-dev,
Standards-Version: 4.0.0
Vcs-Git: https://anonscm.debian.org/git/pkg-gnustep/ftp.app.git
Vcs-Browser: https://anonscm.debian.org/git/pkg-gnustep/ftp.app.git
Vcs-Git: https://salsa.debian.org/gnustep-team/ftp.app.git
Vcs-Browser: https://salsa.debian.org/gnustep-team/ftp.app
Homepage: http://www.nongnu.org/gap/ftp/
Package: ftp.app
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${gnustep:Depends}
Depends:
${misc:Depends},
${shlibs:Depends},
Description: File transfer protocol application for GNUstep
This is a file transfer application (RFC 765) featuring a compact and easy
interface. As most applications in GAP it tries to work on both GNUstep and
......@@ -19,4 +25,4 @@ Description: File transfer protocol application for GNUstep
ease working in both environments.
.
FTP supports different port arbitration modes: "default", standard "PORT"
(also known as active) and standard "PASV" (also known as passive).
(also known as active) and standard "PASV" (also known as passive).
usr/bin
usr/share/GNUstep
debian/FTP.desktop usr/share/applications
?package(ftp.app):needs="X11" \
section="Applications/Network/File Transfer"\
title="FTP" \
command="/usr/bin/FTP" \
icon="/usr/share/pixmaps/FTP.xpm"
#!/bin/sh
# preinst script for preview.app, adapted from gnumail.app
#
# see: dh_installdeb(1)
set -e
# summary of how this script can be called:
# * <new-preinst> `install'
# * <new-preinst> `install' <old-version>
# * <new-preinst> `upgrade' <old-version>
# * <old-preinst> `abort-upgrade' <new-version>
#
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
PACKAGENAME=FTP.app
RESDIR=/usr/lib/GNUstep/Applications/$PACKAGENAME/Resources
case "$1" in
install|upgrade)
if [ -d $RESDIR ] && [ ! -L $RESDIR ]; then
rm -rf $RESDIR
fi
;;
abort-upgrade)
;;
*)
echo "preinst called with unknown argument \`$1'" >&2
exit 1
;;
esac
#DEBHELPER#
exit 0
version=3
http://www.nongnu.org/gap/ftp/ http://savannah.nongnu.org/download/gap/FTP-([\d.]+)\.tar.gz
version=4
https://dl.sv.gnu.org/releases/gap/FTP-([\d.]+)\.tar.gz