Commit 014ba384 authored by Colin Watson's avatar Colin Watson

Move kernel maintainer script snippets into grub2-common

Thanks, Bastian Blank.

Closes: #910959
parent ea214466
grub2 (2.02+dfsg1-7) UNRELEASED; urgency=medium
* Move kernel maintainer script snippets into grub2-common (thanks,
Bastian Blank; closes: #910959).
-- Colin Watson <cjwatson@debian.org> Fri, 26 Oct 2018 13:52:12 +0100
grub2 (2.02+dfsg1-6) unstable; urgency=medium grub2 (2.02+dfsg1-6) unstable; urgency=medium
* Only build *-signed packages on their native architecture for now, since * Only build *-signed packages on their native architecture for now, since
......
...@@ -89,9 +89,9 @@ Package: grub2-common ...@@ -89,9 +89,9 @@ Package: grub2-common
# of the package is not very useful in a utilities-only build. # of the package is not very useful in a utilities-only build.
Architecture: any-i386 any-amd64 any-powerpc any-ppc64 any-ppc64el any-sparc any-sparc64 any-mipsel any-ia64 any-arm any-arm64 Architecture: any-i386 any-amd64 any-powerpc any-ppc64 any-ppc64el any-sparc any-sparc64 any-mipsel any-ia64 any-arm any-arm64
Depends: grub-common (= ${binary:Version}), dpkg (>= 1.15.4) | install-info, ${shlibs:Depends}, ${misc:Depends} Depends: grub-common (= ${binary:Version}), dpkg (>= 1.15.4) | install-info, ${shlibs:Depends}, ${misc:Depends}
Replaces: grub, grub-legacy, ${legacy-doc-br}, grub-common (<< 1.99-1), grub-pc (<< 2.00-4), grub-ieee1275 (<< 2.00-4), grub-efi (<< 1.99-1), grub-coreboot (<< 2.00-4), grub-linuxbios (<< 1.99-1), grub-efi-ia32 (<< 2.00-4), grub-efi-amd64 (<< 2.00-4), grub-efi-ia64 (<< 2.00-4), grub-yeeloong (<< 2.00-4) Replaces: grub, grub-legacy, ${legacy-doc-br}, grub-common (<< 1.99-1), grub-pc (<< 2.02+dfsg1-7), grub-coreboot (<< 2.02+dfsg1-7), grub-efi-ia32 (<< 2.02+dfsg1-7), grub-efi-amd64 (<< 2.02+dfsg1-7), grub-efi-ia64 (<< 2.02+dfsg1-7), grub-efi-arm (<< 2.02+dfsg1-7), grub-efi-arm64 (<< 2.02+dfsg1-7), grub-ieee1275 (<< 2.02+dfsg1-7), grub-uboot (<< 2.02+dfsg1-7), grub-xen (<< 2.02+dfsg1-7), grub-yeeloong (<< 2.02+dfsg1-7)
Conflicts: grub-legacy Conflicts: grub-legacy
Breaks: grub (<< 0.97-54), ${legacy-doc-br}, shim (<< 0.9+1474479173.6c180c6-0ubuntu1~) Breaks: grub (<< 0.97-54), ${legacy-doc-br}, shim (<< 0.9+1474479173.6c180c6-0ubuntu1~), grub-pc (<< 2.02+dfsg1-7), grub-coreboot (<< 2.02+dfsg1-7), grub-efi-ia32 (<< 2.02+dfsg1-7), grub-efi-amd64 (<< 2.02+dfsg1-7), grub-efi-ia64 (<< 2.02+dfsg1-7), grub-efi-arm (<< 2.02+dfsg1-7), grub-efi-arm64 (<< 2.02+dfsg1-7), grub-ieee1275 (<< 2.02+dfsg1-7), grub-uboot (<< 2.02+dfsg1-7), grub-xen (<< 2.02+dfsg1-7), grub-yeeloong (<< 2.02+dfsg1-7)
Multi-Arch: foreign Multi-Arch: foreign
Description: GRand Unified Bootloader (common files for version 2) Description: GRand Unified Bootloader (common files for version 2)
This package contains common files shared by the distinct flavours of GRUB. This package contains common files shared by the distinct flavours of GRUB.
......
../../debian/default usr/share/grub ../../debian/default usr/share/grub
../../debian/update-grub usr/sbin ../../debian/update-grub usr/sbin
../../debian/kernel/zz-update-grub etc/kernel/postinst.d
../../debian/kernel/zz-update-grub etc/kernel/postrm.d
usr/sbin/grub-install usr/sbin/grub-install
usr/sbin/grub-reboot usr/sbin/grub-reboot
......
../../debian/kernel/zz-update-grub etc/kernel/postinst.d
../../debian/kernel/zz-update-grub etc/kernel/postrm.d
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment