changelog 5.04 KB
Newer Older
1 2 3 4 5 6
haskell-polyparse (1.12-6) unstable; urgency=medium

  * Remove build dependency on libghc-text-dev (provided by ghc-8.4.3)

 -- Ilias Tsitsimpis <iliastsi@debian.org>  Mon, 01 Oct 2018 13:47:39 +0300

7
haskell-polyparse (1.12-5) unstable; urgency=medium
8

9
  [ Clint Adams ]
10 11
  * Set Rules-Requires-Root to no.

12 13 14
  [ Ilias Tsitsimpis ]
  * Bump debhelper compat level to 10

15
 -- Ilias Tsitsimpis <iliastsi@debian.org>  Sun, 30 Sep 2018 21:17:54 +0300
16

17
haskell-polyparse (1.12-4) unstable; urgency=medium
18

19
  [ Ilias Tsitsimpis ]
20
  * Use the HTTPS form of the copyright-format URL
21
  * Modify d/watch and Source field in d/copyright to use HTTPS
22
  * Declare compliance with Debian policy 4.1.1
23
  * Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
24

25 26 27
  [ Clint Adams ]
  * Bump to Standards-Version 4.1.4.

28
 -- Clint Adams <clint@debian.org>  Mon, 09 Apr 2018 20:05:00 -0400
29

30 31 32 33 34 35
haskell-polyparse (1.12-3) unstable; urgency=medium

  * Upload to unstable as part of GHC 8 transition.

 -- Clint Adams <clint@debian.org>  Thu, 27 Oct 2016 18:35:31 -0400

36
haskell-polyparse (1.12-2) experimental; urgency=medium
37

38
  * Temporarily build-depend on ghc 8.
39

40
 -- Clint Adams <clint@debian.org>  Sat, 15 Oct 2016 02:41:20 -0400
41

42
haskell-polyparse (1.12-1) unstable; urgency=medium
43

44
  [ Dmitry Bogatov ]
45
  * Use secure (https) uri in Vcs-Git field in 'debian/control'
46
  * Bump standards version to 3.9.8 (no changes needed)
47
  * Convert `debian/copyright' to dep5 format
48

49 50 51 52
  [ Joachim Breitner ]
  * New upstream release

 -- Joachim Breitner <nomeata@debian.org>  Mon, 30 May 2016 16:59:25 +0200
53

Clint Adams's avatar
Clint Adams committed
54
haskell-polyparse (1.11-4) unstable; urgency=medium
55 56 57

  * Switch Vcs-Git/Vcs-Browser headers to new location.

Clint Adams's avatar
Clint Adams committed
58
 -- Clint Adams <clint@debian.org>  Thu, 03 Dec 2015 14:54:55 -0500
59

60
haskell-polyparse (1.11-3) experimental; urgency=medium
61 62

  * Bump standards-version to 3.9.6
63 64
  * Depend on haskell-devscripts >= 0.10 to ensure that this package
    builds against GHC in experimental
65

66
 -- Joachim Breitner <nomeata@debian.org>  Thu, 20 Aug 2015 10:28:27 +0200
67

68 69 70 71 72 73
haskell-polyparse (1.11-2) unstable; urgency=medium

  * Upload to unstable

 -- Joachim Breitner <nomeata@debian.org>  Mon, 27 Apr 2015 11:52:32 +0200

74
haskell-polyparse (1.11-1) experimental; urgency=medium
75 76 77

  * New upstream release

78
 -- Joachim Breitner <nomeata@debian.org>  Mon, 06 Apr 2015 19:09:52 +0200
79

80
haskell-polyparse (1.9-2) experimental; urgency=medium
81 82

  * Depend on haskell-devscripts 0.9, found in experimental
83
  * Use standard substvars
84

85
 -- Joachim Breitner <nomeata@debian.org>  Sun, 21 Dec 2014 13:24:52 +0100
86

87
haskell-polyparse (1.9-1) unstable; urgency=low
88

89
  [ Joachim Breitner ]
90 91
  * Adjust watch file to new hackage layout

92 93 94 95 96
  [ Raúl Benencia ]
  * New upstream release
  * Bump standards version, no change
  * Remove empty paragraph from Description fields

97
 -- Raúl Benencia <rul@kalgan.cc>  Fri, 11 Apr 2014 19:25:57 -0300
98

99
haskell-polyparse (1.7-3) unstable; urgency=low
100 101 102

  * Enable compat level 9

103
 -- Joachim Breitner <nomeata@debian.org>  Fri, 24 May 2013 12:51:41 +0200
104

105
haskell-polyparse (1.7-2) experimental; urgency=low
106 107 108

  * Depend on haskell-devscripts 0.8.13 to ensure this packages is built
    against experimental
109
  * Bump standards version, no change
110

111
 -- Joachim Breitner <nomeata@debian.org>  Sun, 14 Oct 2012 12:01:46 +0200
112

113
haskell-polyparse (1.7-1) unstable; urgency=low
114 115 116

  * New upstream release

117
 -- Joachim Breitner <nomeata@debian.org>  Sat, 04 Feb 2012 13:10:10 +0100
118

119
haskell-polyparse (1.4-1) unstable; urgency=low
120

121
  [ Marco Túlio Gontijo e Silva ]
122 123
  * debian/source/format: Use 3.0 (quilt).

124 125 126
  [ Erik de Castro Lopo ]
  * New upstream.

127 128 129
  [ Joachim Breitner ]
  * Priority: extra

130
  [ Marco Silva ]
131
  * Use ghc instead of ghc6
132

133
 -- Iain Lane <laney@ubuntu.com>  Wed, 18 May 2011 11:22:21 +0100
134

135
haskell-polyparse (1.3-2) unstable; urgency=low
136

137
  [ Erik de Castro Lopo ]
138 139 140 141 142
  * debian/control :
    - Maintainer is now Debian Haskell Group.
    - Add Vcs-Darcs.
    - Standards version 3.8.3.

143 144
  [ Marco Túlio Gontijo e Silva ]
  * debian/watch: Use format that works for --download-current-version.
145
  * debian/watch: Add .tar.gz to downloaded filename.
146
  * debian/watch: Include package name in downloaded .tar.gz.
147
  * debian/watch: Remove spaces, since they're not allowed by uscan.
148 149
  * debian/control: Add field Provides: ${haskell:Provides} to -dev and
    -prof packages.
150
  * debian/control: Use Vcs-Browser: field.
151 152
  * debian/control: Remove dependency in hscolour, since it's now a
    dependency of haskell-devscripts.
153
  * debian/control: Use comma in the beginning of the line.
154 155
  * debian/control: Remove haddock from Build-Depends:, since it's now a
    Depends: of haskell-devscripts.
156
  * debian/control: Bump Standards-Version: to 3.8.4, no changes needed.
157
  * Use debian/compat 7.
158
  * debian/control: Use more sintetic link in Homepage:.
159

160 161 162
  [ Joachim Breitner ]
  * Bump haskell-devscripts dependency to 0.7

163
 -- Joachim Breitner <nomeata@debian.org>  Sat, 20 Feb 2010 17:52:49 +0100
164 165 166 167 168 169

haskell-polyparse (1.3-1) unstable; urgency=low

  * Initial debian package. Closes: #533623.

 -- Erik de Castro Lopo <erikd@mega-nerd.com>  Fri, 19 Jun 2009 20:42:04 +1000