Commit 00164a1c authored by Mikolaj Konarski's avatar Mikolaj Konarski

haskell-lambdahack: Build-depend on sdl instead of vty, for better UI

parent 6111ec7a
haskell-lambdahack (0.7.1.0-9) UNRELEASED; urgency=medium
* Build-depend on sdl instead of vty, for better UI
-- Mikolaj Konarski <mikolaj.konarski@funktory.com> Fri, 08 Jun 2018 23:29:25 +0200
haskell-lambdahack (0.7.1.0-8) unstable; urgency=medium
[ Clint Adams ]
......
......@@ -32,8 +32,10 @@ Build-Depends: debhelper (>= 10),
libghc-pretty-show-prof,
libghc-random-dev (>= 1.1),
libghc-random-prof,
libghc-vty-dev (>= 5),
libghc-vty-prof,
libghc-sdl2-dev (>= 2),
libghc-sdl2-prof,
libghc-sdl2-ttf-dev (>= 2),
libghc-sdl2-ttf-prof,
libghc-stm-dev (>= 2.4),
libghc-stm-prof,
libghc-text-dev (>= 0.11.2.3),
......@@ -58,7 +60,8 @@ Build-Depends-Indep: ghc-doc,
libghc-optparse-applicative-doc,
libghc-pretty-show-doc,
libghc-random-doc,
libghc-vty-doc,
libghc-sdl2-doc,
libghc-sdl2-ttf-doc,
libghc-stm-doc,
libghc-text-doc,
libghc-unordered-containers-doc,
......
......@@ -4,7 +4,6 @@ DEB_ENABLE_TESTS = yes
DEB_SETUP_BIN_NAME = debian/hlibrary.setup
DEB_CABAL_PACKAGE = lambdahack
DEB_DEFAULT_COMPILER = ghc
DEB_SETUP_GHC_CONFIGURE_ARGS += --flags=vty
ifneq (,$(filter $(DEB_BUILD_ARCH),armel armhf))
DEB_SETUP_GHC_CONFIGURE_ARGS += --ghc-options="-O0"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment