Commit 1678fac7 authored by Ilias Tsitsimpis's avatar Ilias Tsitsimpis

glirc: Newer build-deps from hackage

parent 1f69d267
glirc (2.26-3) unstable; urgency=medium
* Newer build-deps from hackage
-- Ilias Tsitsimpis <iliastsi@debian.org> Thu, 01 Nov 2018 15:16:06 +0200
glirc (2.26-2) unstable; urgency=medium
[ Clint Adams ]
......
......@@ -22,7 +22,7 @@ Build-Depends: debhelper (>= 10),
libghc-config-value-dev (>= 0.6),
libghc-config-value-dev (<< 0.7),
libghc-free-dev (>= 4.12),
libghc-free-dev (<< 5.1),
libghc-free-dev (<< 5.2),
libghc-free-prof,
libghc-gitrev-dev (>= 1.2),
libghc-gitrev-dev (<< 1.4),
......@@ -35,17 +35,17 @@ Build-Depends: debhelper (>= 10),
libghc-irc-core-dev (>= 2.3),
libghc-irc-core-dev (<< 2.4),
libghc-kan-extensions-dev (>= 5.0),
libghc-kan-extensions-dev (<< 5.2),
libghc-kan-extensions-dev (<< 5.3),
libghc-kan-extensions-prof,
libghc-lens-dev (>= 4.14),
libghc-lens-dev (<< 4.17),
libghc-lens-dev (<< 4.18),
libghc-lens-prof,
libghc-network-dev (>= 2.6.2),
libghc-network-dev (<< 2.7),
libghc-network-dev (<< 2.8),
libghc-regex-tdfa-dev (>= 1.2),
libghc-regex-tdfa-dev (<< 1.3),
libghc-semigroupoids-dev (>= 5.1),
libghc-semigroupoids-dev (<< 5.3),
libghc-semigroupoids-dev (<< 5.4),
libghc-socks-dev (>= 0.5.5),
libghc-socks-dev (<< 0.6),
libghc-split-dev (>= 0.2),
......@@ -55,10 +55,9 @@ Build-Depends: debhelper (>= 10),
libghc-vector-dev (>= 0.11),
libghc-vector-dev (<< 0.13),
libghc-vty-dev (>= 5.11.1),
libghc-vty-dev (<< 5.22),
libghc-vty-dev (<< 5.23),
libghc-vty-prof,
libghc-lens-dev,
libghc-vty-dev,
libghc-hunit-dev (>= 1.3),
libghc-hunit-dev (<< 1.7),
Standards-Version: 4.1.4
......
Index: b/glirc.cabal
===================================================================
--- a/glirc.cabal
+++ b/glirc.cabal
@@ -1,5 +1,6 @@
name: glirc
version: 2.26
+x-revision: 6
synopsis: Console IRC client
description: Console IRC client
.
@@ -132,20 +133,20 @@ library
bytestring >=0.10.8 && <0.11,
config-schema >=0.4 && <0.6,
config-value >=0.6 && <0.7,
- containers >=0.5.7 && <0.6,
+ containers >=0.5.7 && <0.7,
directory >=1.2.6 && <1.4,
filepath >=1.4.1 && <1.5,
- free >=4.12 && <5.1,
+ free >=4.12 && <5.2,
gitrev >=1.2 && <1.4,
hashable >=1.2.4 && <1.3,
hookup >=0.2 && <0.3,
irc-core >=2.3 && <2.4,
- kan-extensions >=5.0 && <5.2,
- lens >=4.14 && <4.17,
- network >=2.6.2 && <2.7,
+ kan-extensions >=5.0 && <5.3,
+ lens >=4.14 && <4.18,
+ network >=2.6.2 && <2.8,
process >=1.4.2 && <1.7,
regex-tdfa >=1.2 && <1.3,
- semigroupoids >=5.1 && <5.3,
+ semigroupoids >=5.1 && <5.4,
socks >=0.5.5 && <0.6,
split >=0.2 && <0.3,
stm >=2.4 && <2.5,
@@ -156,7 +157,7 @@ library
unix >=2.7 && <2.8,
unordered-containers >=0.2.7 && <0.3,
vector >=0.11 && <0.13,
- vty >=5.11.1 && <5.22
+ vty >=5.11.1 && <5.23
test-suite test
type: exitcode-stdio-1.0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment