Commit 22f6a3fe authored by Clint Adams's avatar Clint Adams

pqueue: switch from dh-haskell to cdbs, since dh-haskell is still mishandling substvars

parent d8e86e0c
haskell-pqueue (1.3.2.2-4) unstable; urgency=medium
* Switch from dh-haskell to cdbs, since dh-haskell is still
mishandling substvars.
-- Clint Adams <clint@debian.org> Fri, 23 Jun 2017 08:40:23 -0400
haskell-pqueue (1.3.2.2-3) unstable; urgency=medium
* Re-add dh-haskell to Build-Depends. closes: #865089.
......
......@@ -5,14 +5,13 @@ Priority: extra
Section: haskell
Build-Depends: debhelper (>= 10),
haskell-devscripts-minimal | haskell-devscripts (>= 0.8),
dh-haskell (>= 0.1),
cdbs,
ghc,
ghc-prof,
libghc-quickcheck2-dev (>= 2.5),
libghc-quickcheck2-dev (<< 3),
Build-Depends-Indep: ghc-doc,
Standards-Version: 3.9.8
Standards-Version: 4.0.0
Homepage: http://hackage.haskell.org/package/pqueue
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/tree/p/haskell-pqueue
Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git
......
#!/usr/bin/make -f
%:
dh $@ --with haskell --buildsystem=haskell
DEB_ENABLE_TESTS = yes
DEB_CABAL_PACKAGE = pqueue
DEB_DEFAULT_COMPILER = ghc
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment