Commit 396d9095 authored by Clint Adams's avatar Clint Adams

feed: build with ghc 8 in experimental

parent de592d89
haskell-feed (0.3.11.1-2) UNRELEASED; urgency=medium haskell-feed (0.3.11.1-2) experimental; urgency=medium
* Fix VCS fields * Temporarily build-depend on ghc 8.
-- Gianfranco Costamagna <locutusofborg@debian.org> Thu, 02 Jun 2016 19:12:30 +0200 -- Clint Adams <clint@debian.org> Sun, 16 Oct 2016 00:45:57 -0400
haskell-feed (0.3.11.1-1) unstable; urgency=medium haskell-feed (0.3.11.1-1) unstable; urgency=medium
......
Source: haskell-feed Source: haskell-feed
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org> Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Uploaders: Giovanni Mascellani <gio@debian.org> Uploaders:
Giovanni Mascellani <gio@debian.org>,
Priority: extra Priority: extra
Section: haskell Section: haskell
Build-Depends: debhelper (>= 9), Build-Depends:
haskell-devscripts (>= 0.10),
cdbs, cdbs,
ghc, debhelper (>= 9),
ghc (>= 8),
ghc-prof, ghc-prof,
libghc-old-locale-dev (>= 1.0), haskell-devscripts (>= 0.10),
libghc-old-locale-dev (<< 1.1), libghc-old-locale-dev (<< 1.1),
libghc-old-locale-dev (>= 1.0),
libghc-old-locale-prof, libghc-old-locale-prof,
libghc-old-time-dev (>= 1),
libghc-old-time-dev (<< 1.2), libghc-old-time-dev (<< 1.2),
libghc-old-time-dev (>= 1),
libghc-old-time-prof, libghc-old-time-prof,
libghc-time-locale-compat-dev (>= 0.1),
libghc-time-locale-compat-dev (<< 0.2), libghc-time-locale-compat-dev (<< 0.2),
libghc-time-locale-compat-dev (>= 0.1),
libghc-time-locale-compat-prof, libghc-time-locale-compat-prof,
libghc-utf8-string-dev (<< 1.1), libghc-utf8-string-dev (<< 1.1),
libghc-utf8-string-prof, libghc-utf8-string-prof,
libghc-xml-dev (>= 1.2.6),
libghc-xml-dev (<< 1.3.15), libghc-xml-dev (<< 1.3.15),
libghc-xml-dev (>= 1.2.6),
libghc-xml-prof, libghc-xml-prof,
Build-Depends-Indep: ghc-doc, Build-Depends-Indep:
ghc-doc,
libghc-old-locale-doc, libghc-old-locale-doc,
libghc-old-time-doc, libghc-old-time-doc,
libghc-time-locale-compat-doc, libghc-time-locale-compat-doc,
...@@ -30,17 +33,21 @@ Build-Depends-Indep: ghc-doc, ...@@ -30,17 +33,21 @@ Build-Depends-Indep: ghc-doc,
libghc-xml-doc, libghc-xml-doc,
Standards-Version: 3.9.8 Standards-Version: 3.9.8
Homepage: https://github.com/bergmark/feed Homepage: https://github.com/bergmark/feed
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/ Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/tree/p/haskell-feed
Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git
Package: libghc-feed-dev Package: libghc-feed-dev
Architecture: any Architecture: any
Depends: ${haskell:Depends}, Depends:
${haskell:Depends},
${misc:Depends}, ${misc:Depends},
${shlibs:Depends}, ${shlibs:Depends},
Recommends: ${haskell:Recommends}, Recommends:
Suggests: ${haskell:Suggests}, ${haskell:Recommends},
Provides: ${haskell:Provides}, Suggests:
${haskell:Suggests},
Provides:
${haskell:Provides},
Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb} Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb}
This library provides tools for RSS (version 0.9x, 2.x, 1.0) and Atom This library provides tools for RSS (version 0.9x, 2.x, 1.0) and Atom
feeds, allowing both importing and exporting them. feeds, allowing both importing and exporting them.
...@@ -49,11 +56,15 @@ Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb} ...@@ -49,11 +56,15 @@ Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb}
Package: libghc-feed-prof Package: libghc-feed-prof
Architecture: any Architecture: any
Depends: ${haskell:Depends}, Depends:
${haskell:Depends},
${misc:Depends}, ${misc:Depends},
Recommends: ${haskell:Recommends}, Recommends:
Suggests: ${haskell:Suggests}, ${haskell:Recommends},
Provides: ${haskell:Provides}, Suggests:
${haskell:Suggests},
Provides:
${haskell:Provides},
Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb} Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb}
This library provides tools for RSS (version 0.9x, 2.x, 1.0) and Atom This library provides tools for RSS (version 0.9x, 2.x, 1.0) and Atom
feeds, allowing both importing and exporting them. feeds, allowing both importing and exporting them.
...@@ -63,10 +74,13 @@ Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb} ...@@ -63,10 +74,13 @@ Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb}
Package: libghc-feed-doc Package: libghc-feed-doc
Architecture: all Architecture: all
Section: doc Section: doc
Depends: ${haskell:Depends}, Depends:
${haskell:Depends},
${misc:Depends}, ${misc:Depends},
Recommends: ${haskell:Recommends}, Recommends:
Suggests: ${haskell:Suggests}, ${haskell:Recommends},
Suggests:
${haskell:Suggests},
Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb} Description: Haskell interface to RSS and Atom feeds${haskell:ShortBlurb}
This library provides tools for RSS (version 0.9x, 2.x, 1.0) and Atom This library provides tools for RSS (version 0.9x, 2.x, 1.0) and Atom
feeds, allowing both importing and exporting them. feeds, allowing both importing and exporting them.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment