Commit 5ae61315 authored by Joachim Breitner's avatar Joachim Breitner

upgrade.sh: Refuse to upgrade to the same version

parent 93954a3f
......@@ -34,7 +34,13 @@ version=$(grep "^$cabal_name " ../../../package-plan/packages.txt|cut -d\ -f2)
if [ -z "$version" ]
then
echo "could not detect version to upgrade to"
echo "could not detect version to upgrade to."
exit 1
fi
if [ "$version" = "$old_version" ]
then
echo "No new version to upgrade to."
exit 1
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment