Commit 74f0ede5 authored by Clint Adams's avatar Clint Adams

taffybar: Upgrading from 0.4.6 to 1.0.0

parent c460050e
taffybar (0.4.6-8) UNRELEASED; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
taffybar (1.0.0-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
-- Clint Adams <clint@debian.org> Sun, 06 May 2018 22:11:06 -0400
[ Clint Adams ]
* Set Rules-Requires-Root to no.
* "New" upstream release. closes: #895264.
-- Clint Adams <clint@debian.org> Mon, 05 Nov 2018 17:33:47 -0500
taffybar (0.4.6-7) unstable; urgency=medium
......
......@@ -11,31 +11,40 @@ Build-Depends:
ghc (>= 8),
ghc-prof,
haskell-devscripts (>= 0.13),
libghc-configfile-dev,
libghc-configfile-prof,
libghc-hstringtemplate-dev (>= 0.8),
libghc-hstringtemplate-dev (<< 0.9),
libghc-hstringtemplate-prof,
libghc-http-dev,
libghc-http-prof,
libghc-x11-dev (>= 1.5.0.1),
libghc-x11-prof,
libghc-alsa-mixer-dev (>= 0.2.0),
libghc-alsa-mixer-prof,
libghc-cairo-dev,
libghc-cairo-prof,
libghc-dbus-dev (>= 0.10.1),
libghc-dbus-dev (<< 1.0),
libghc-dbus-dev (>= 1.0.0),
libghc-dbus-dev (<< 2.0.0),
libghc-dbus-prof,
libghc-dyre-dev (>= 0.8.6),
libghc-dyre-dev (<< 0.9),
libghc-dyre-prof,
libghc-either-dev (>= 4.0.0.0),
libghc-either-prof,
libghc-enclosed-exceptions-dev (>= 1.0.0.1),
libghc-enclosed-exceptions-prof,
libghc-filepath-dev,
libghc-filepath-prof,
libghc-gtk-dev (>= 0.12.1),
libghc-gtk-dev (<< 0.15),
libghc-gtk-prof,
libghc-gtk-traymanager-dev (>= 0.1.2),
libghc-gtk-traymanager-dev (<< 0.2),
libghc-glib-dev,
libghc-glib-prof,
libghc-gtk-traymanager-dev (>= 1.0.0),
libghc-gtk-traymanager-dev (<< 2.0.0),
libghc-gtk-traymanager-prof,
libghc-hstringtemplate-dev (>= 0.8),
libghc-hstringtemplate-dev (<< 0.9),
libghc-hstringtemplate-prof,
libghc-http-dev,
libghc-http-prof,
libghc-gtk3-dev,
libghc-gtk3-prof,
libghc-mtl-dev (>= 2),
libghc-mtl-prof,
libghc-multimap-dev (>= 1.2.1),
libghc-multimap-prof,
libghc-network-dev (>= 2.6),
libghc-network-dev (<< 3),
libghc-network-prof,
......@@ -46,6 +55,8 @@ Build-Depends:
libghc-old-locale-prof,
libghc-parsec3-dev (>= 3.1),
libghc-parsec3-prof,
libghc-rate-limit-dev (>= 1.1.1),
libghc-rate-limit-prof,
libghc-safe-dev (>= 0.3),
libghc-safe-dev (<< 1),
libghc-safe-prof,
......@@ -58,6 +69,10 @@ Build-Depends:
libghc-time-locale-compat-dev (>= 0.1),
libghc-time-locale-compat-dev (<< 0.2),
libghc-time-locale-compat-prof,
libghc-time-units-dev (>= 1.0.0),
libghc-time-units-prof,
libghc-tuple-dev (>= 0.3.0.2),
libghc-tuple-prof,
libghc-utf8-string-dev,
libghc-utf8-string-prof,
libghc-x11-dev (>= 1.5.0.1),
......@@ -66,39 +81,53 @@ Build-Depends:
libghc-xdg-basedir-dev (>= 0.2),
libghc-xdg-basedir-dev (<< 0.3),
libghc-xdg-basedir-prof,
libghc-xmonad-contrib-dev,
libghc-xmonad-contrib-prof,
libghc-xml-dev,
libghc-xml-prof,
libghc-xml-helpers-dev,
libghc-xml-helpers-prof,
libghc-xmonad-dev,
libghc-xmonad-prof,
libgtk2.0-dev,
Build-Depends-Indep:
ghc-doc,
libghc-xmonad-contrib-dev,
libghc-xmonad-contrib-prof,
libghc-mtl-dev,
libghc-xdg-basedir-dev,
Build-Depends-Indep: ghc-doc,
libghc-configfile-doc,
libghc-hstringtemplate-doc,
libghc-http-doc,
libghc-x11-doc,
libghc-alsa-mixer-doc,
libghc-cairo-doc,
libghc-containers-doc,
libghc-dbus-doc,
libghc-dyre-doc,
libghc-either-doc,
libghc-enclosed-exceptions-doc,
libghc-filepath-doc,
libghc-gtk-doc,
libghc-glib-doc,
libghc-gtk-traymanager-doc,
libghc-hstringtemplate-doc,
libghc-http-doc,
libghc-gtk3-doc,
libghc-mtl-doc,
libghc-multimap-doc,
libghc-network-doc,
libghc-network-uri-doc,
libghc-old-locale-doc,
libghc-parsec3-doc,
libghc-rate-limit-doc,
libghc-safe-doc,
libghc-split-doc,
libghc-stm-doc,
libghc-text-doc,
libghc-time-locale-compat-doc,
libghc-time-units-doc,
libghc-tuple-doc,
libghc-utf8-string-doc,
libghc-x11-doc,
libghc-xdg-basedir-doc,
libghc-xmonad-contrib-doc,
libghc-xml-doc,
libghc-xml-helpers-doc,
libghc-xmonad-doc,
Standards-Version: 4.1.4
libghc-xmonad-contrib-doc,
Standards-Version: 4.2.1
Homepage: https://github.com/travitch/taffybar
Vcs-Browser: https://salsa.debian.org/haskell-team/DHG_packages/tree/master/p/taffybar
Vcs-Git: https://salsa.debian.org/haskell-team/DHG_packages.git [p/taffybar]
......
--- a/src/System/Taffybar/Widgets/Graph.hs
+++ b/src/System/Taffybar/Widgets/Graph.hs
@@ -11,12 +11,12 @@
-- Note: all of the data fed to this widget should be in the range
-- [0,1].
module System.Taffybar.Widgets.Graph
- -- * Types
+ -- Types
( GraphHandle
, GraphConfig(..)
, GraphDirection(..)
, GraphStyle(..)
- -- * Functions
+ -- Functions
, graphNew
, graphAddSample
, defaultGraphConfig
@@ -52,9 +52,9 @@
-- | The configuration options for the graph. The padding is the
-- number of pixels reserved as blank space around the widget in each
-- direction.
-data GraphConfig = GraphConfig
+data GraphConfig = GraphConfig {
-- | Number of pixels of padding on each side of the graph widget
- { graphPadding :: Int
+ graphPadding :: Int
-- | The background color of the graph (default black)
, graphBackgroundColor :: (Double, Double, Double)
-- | The border color drawn around the graph (default gray)
--- a/src/System/Taffybar/Widgets/VerticalBar.hs
+++ b/src/System/Taffybar/Widgets/VerticalBar.hs
@@ -29,8 +29,8 @@
data BarDirection = HORIZONTAL | VERTICAL
data BarConfig
- = BarConfig -- | Color of the border drawn around the widget
- { barBorderColor :: (Double, Double, Double)
+ = BarConfig { -- | Color of the border drawn around the widget
+ barBorderColor :: (Double, Double, Double)
-- | The background color of the widget
, barBackgroundColor :: Double -> (Double, Double, Double)
-- | A function to determine the color of the widget for the current data point
--- a/taffybar.cabal
+++ b/taffybar.cabal
@@ -27,7 +27,7 @@
library
default-language: Haskell2010
build-depends: base > 3 && < 5,
- time >= 1.4 && < 1.7,
+ time >= 1.4 && < 1.9,
time-locale-compat >= 0.1 && < 0.2,
old-locale,
containers,
--- a/taffybar.cabal
+++ b/taffybar.cabal
@@ -57,7 +57,7 @@
@@ -70,7 +70,7 @@
if flag(network-uri)
build-depends: network-uri >= 2.6 && < 3, network >= 2.6 && < 3
else
- build-depends: network-uri < 2.6, network < 2.6
+ build-depends: network < 2.6
hs-source-dirs: src
pkgconfig-depends: gtk+-2.0
exposed-modules: System.Taffybar,
pkgconfig-depends: gtk+-3.0
exposed-modules: System.Information.Battery,
--- a/src/System/Taffybar/Weather.hs
+++ b/src/System/Taffybar/Weather.hs
@@ -249,7 +249,7 @@
-- | The NOAA URL to get data from
baseUrl :: String
-baseUrl = "http://weather.noaa.gov/pub/data/observations/metar/decoded"
+baseUrl = "http://tgftp.nws.noaa.gov/data/observations/metar/decoded"
-- | A wrapper to allow users to specify a custom weather formatter.
-- The default interpolates variables into a string as described
no-network-uri
man-page.patch
scn16-16wngccb-workaround
newer-time
fix-haddock
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment